Edge downloads are not completing

Microsoft

When I attempt to downlaod a file in Edge, the download never finishes. I end up with a file named something like "Unconfirmed nnnnnn.crdownload". If I attempt to close Edge I get a warning about the file downloading. I have waited hours for downloads to finish. Makes no difference. If I close Edge, I cannot delete the file. I have to reboot before I can delete these files. 

 

(Dev - Version 121.0.2256.2 (Official build) stable app, dev channel (64-bit))

42 Replies

@josaxton  Having the exact same issue.  Happened with the update.  Some webpages will print to PDF and others will not.  I cannot figure out what the determining factor is.  I am running Edge on a Macbook pro, if that matters.

@KVallee yep, same here. edge is falling apart quickly. slow and laggy browsing, horrible sidebar function on workspaces, and now downloading. Dev edge was better, now its just as bad. switching back to chrome soon

Same here, in Stable, Beta, Dev
For me too. The stable version has this issue. I tried canary version and this problem is not there.
I have the same problem in version 120.0.2210.61 (Official Build)(64 bits).

I have 20 computers at the company with this same problem and the alternative I had was to put Google Chrome on all computers until Microsoft releases a correction update or explains what is happening with the correction.
One of the solutions I saw was to save the PDFs when printing and select "Microsoft Print to PDF" which is saving normally.
Same issue here. Seems to randomly affect users. Installing canary is our temp fix until it's resolved. We've also had mixed luck with having users use Chrome OR printing to PDF using Kofax Power PDF.
We are seeing the same in our environment, but only print to PDF or save to PDF in the printing dialog.

I started having the same issue around 12/11/23, using Microsoft Edge version 120.0.2210.61 (Official build) (64-bit) to print a PDF file with "Save as PDF."

 

To delete the crdownload file, you don't have to reboot. Just end the Microsoft Edge task from the Task Manager.

 

Workaround: Print with "Microsoft Print to PDF" or Google Chrome

Seeing the same problem for "Save to PDF" and all downloads. They hang at the end there leaving the *.crdownload" file behind.
Take time to get everything download once again documents of provide.

@moryarty 

 

But Canary has a lot more issues

Any update on this issue? I am seeing the same issue in my environment but not much chatter on the web about this which is odd.

I found that sensece had a lock on the file, I also noticed on several machines the startup type of a couple of defender related services was incorrect. So if you are using defender your issue may be the same as mine

I noticed in teh sense logs the following services did not have the correct startup types set they were both set to 4

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SgrmAgent
"Start"=dword:00000000

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SgrmBroker
"Start"=dword:00000002

This seems to have helped ion the system i have tried it on so far

Should have said you need to reboot

I have the same issue but not only with PDF but with any file. I've disabled Smartscreen policy in InTune but nothing helps. No logs anywhere that indicate something is being blocked. This happens in Edge and Chrome.
Could you elaborate more? how about Defender configuration using InTune?

I am just testing it the moment so have not looked at pushing the service startup from intune yet as we are hybrid I will more likley just do it in a GPO

 

If you look in the sense logs and look for warning you should see it saying the startup types are wrong if your issue is the same, just thought i would share what seems to be helping me as started to see quite a few posts about this

 

WheresMaWhiskey_0-1702500236937.png

 

 

 

PSA - this is now happening in Chrome - can anyone confirm they are also seeing issues in other browsers? This could possibly then be related to Defender or something else entirely...

@lexcyn Yes, I can confirm that this is happening in Chrome also; FF seems to work but because of policy restriction we don't allow FF to access org resources so no way to test that from SharePoint or any app, just the Internet.

 

So, files download from the Internet seems to work in FF. Edge and Chrome are unable to download files from SharePoint or any other company app, just tested one download from the Internet and it seemed to work, but most testing has been done internally.