Dev channel update to 93.0.961.2 is live


Hello Insiders!  Today we’re releasing build 93.0.961.2 to the Dev channel.  This is the final release for version 93, give or take some patches, so expect this to be coming to Beta soon!  Since there haven’t been too many builds between this one and last week’s, it’s kind of light this week, but here’s everything we’ve got: 


Added features: 


  • Added an allow list to media autoplay settings.  
  • Added the ability to un-ignore password health alerts for a particular website.  
  • Combined the Settings pages for Start, Home, and New Tab pages. 
  • Enabled the new Share experience by default. 


Improved reliability: 


  • Fixed an issue where the Web Widget crashes when switching browser profiles. 
  • Fixed a crash when navigating to certain pages. 
  • Fixed an issue on Mac where the browser crashes after being open for a while. 


Changed behavior: 


  • Fixed an issue on Mac where PDFs sometimes don’t display at the correct size.  Thanks for being persistent in reporting this and making sure we knew about it! 
  • Fixed an issue where PWAs or websites installed as apps sometimes open to blank windows. 
  • Fixed an issue where printing specific pages of a PDF sometimes fails. 
  • Fixed an issue where an error message that “Update policies are configured but will be ignored because this device isn’t domain joined.” unexpectedly appears when updating the browser. 
  • Fixed an issue where extension icons sometimes aren’t visible. 
  • Reduced the number of irrelevant entries saved in autofill. 
  • Temporarily disabled the ability to change fonts in Immersive Reader on Linux. 


Known issues: 


  • Certain extensions such as the Microsoft Editor extension don’t work on Linux.  As soon as they’re installed, they crash and are disabled.  We’re currently investigating. 
  • Users of certain ad blocking extensions may experience playback errors on Youtube.  As a workaround, temporarily disabling the extension should allow playback to proceed.  See this help article for more details. 
  • Some users are still running into an issue where all tabs and extensions immediately crash with a STATUS_INVALID_IMAGE_HASH error.  The most common cause of this error is outdated security or antivirus software from vendors like Symantec, and in those cases, updating that software will fix it. 
  • Users of the Kaspersky Internet Suite who have the associated extension installed may sometimes see webpages like Gmail fail to load.  This failure is due to the main Kaspersky software being out of date, and is thus fixed by making sure the latest version is installed. 
  • Some users are still seeing favorites get duplicated.  This issue should be reduced now that automatic deduplication has been introduced into Insider channels, but we’re still rolling that out in Stable.  We’ve also seen duplication happen when running the manual deduplicator on multiple machines before either machine has a chance to fully sync its changes, so make sure to leave plenty of time in between runs of the deduplicator. 
  • Some users are seeing “wobbling” behavior when scrolling using trackpad gestures or touchscreens, where scrolling in one dimension also causes the page to subtly scroll back and forth in the other.  Note that this only affects certain websites and seems to be worse on certain devices.  This is most likely related to our ongoing work to bring scrolling back to parity with Edge Legacy’s behavior, so if this behavior is undesirable, you can temporarily turn it off by disabling the edge://flags/#edge-experimental-scrolling flag. 


If you’re using Stable, version 92 made its way there last week, so make sure you check it out! 


34 Replies
Nice. But still no Skype in the share menu.

@josh_bodner still having the blank password page and now thick borders when the edge window is not maximized. I did try something on my Gentoo laptop. I removed my profile (/.config/microsoft-edge-dev) and started edge fresh. The password page was working without being signed in. I then signed in and during the sync process the password page became unavailable/blank.

The iOS version now requires iOS 13? Is that right?
Please add Tab Scrolling flag like google chrome.
  • Fixed an issue on Mac where PDFs sometimes don’t display at the correct size.  Thanks for being persistent in reporting this and making sure we knew about it! 

@josh_bodner thanks for getting this one sorted out!  Much appreciated.

Navigating to new site (not just blank tab) is randomly very slow since last 3 update. Doesnt happen always. Opening developer tools shows no traffic in network tab for few seconds when this happens.


since a few dev updates some embedded content is no longer showing, while on the stable channel everything is working fine, could you investigate that please? Thank you !


Edge dev :



Edge stable :



I still get the blank password page too. On the M1/ARM Mac Dev version.
The blank passwords page for the M1/ARM Mac version is still there. I know you said it's being worked on. If there is anything I can do to help, please let me know.

@josh_bodner the same as previous build.


Screenshot from 2021-07-28 13-59-40.png



  • Ubuntu 20.04 LST
  • Kernel 5.8.0-63-generic
  • NVDIA drivers version 470.57.02 (also tested with 460.XX)

Disabling hardware acceleration "fixes" it, but it is not a nice trade-off.


Can you please tell me without tpm how to run window 11 and its any procedure showing all channels because today iam doing some changes so only showing dev channel
@jcursiolf turning off hardware acceleration fixes it on my system too.

Gentoo kernel 5.13.5 Radeon RX 580 Series (POLARIS10, DRM 3.41.0)
Hello, any news on ability to sync my work account on linux? Thanks

@MikeKG Thanks to the F12 console output that was shared in last week's notes, we believe this has something to do with the Password Health feature that we recently rolled out, and are looking into a fix.  

@Tio_Dep what website is that?  I'm very intrigued that it appears to be showing an error page (since that thought bubble appears on our other error pages), but there's no text at all to indicate what the error is.  

@ankitbko Do you have any extensions installed?  We've had other reports of similar behavior over the past week, and in some cases, it's because of an extension that was injecting code into the page that was taking a long time to execute.  

@jcursiolf and everybody else seeing the black borders, thanks for reporting!  This is something we hadn't found ourselves since we all apparently run with our windows maximized :)


when i hover over the cloud it displays "it looks like the site has closed the connection", but it looks strange as a message because there is no problem on edge stable, why would the website close the connection to edge dev and not to edge stable ?

Thank you for the update