Dev channel update to 84.0.516.1 is live

Highlighted
Microsoft

Hello Insiders!  Today we’re releasing build 84.0.516.1 to the Dev channel.  In community news, we’ve got another AMA coming up!  It’s happening Thursday over on Reddit, see https://twitter.com/MSEdgeDev/status/1261029217132830720 for all the details.  We’ve also got a discussion going around all the different ways you get back to websites you’ve been to before right here:  https://techcommunity.microsoft.com/t5/discussions/discussion-getting-back-to-websites-important-to-....  Finally, we’ve got a preview of everything we’re going to talk about at Build 2020!  Whether you’re a web developer, an IT manager, or a student, we’ve got something for you:  https://blogs.windows.com/msedgedev/2020/05/19/microsoft-edge-news-developers-build-2020/.  In product news: 

 

Added features: 

 

  • Added UI to help enable media casting if users attempt to use it while it’s disabled.  Note that casting is currently only supported via ChromeCast devices. 
  • Added support for quieter notifications in edge://settings/content/notifications. 
  • Improved the UI when picking a certificate to use for website authentication. 
  • Added a Website Permissions Settings page for when a website wants to access serial ports. 

 

Improved reliability: 

 

  • Fixed a crash when typing in the address bar. 
  • Fixed a crash when closing the browser. 
  • Fixed an issue where opening an Application Guard window sometimes crashes the browser. 
  • Fixed an issue where IE mode doesn’t work or tries to launch IE as its own window instead of inside an Edge tab. 
  • Fixed an issue where running Edge’s installer for the same version that’s currently installed while the browser is open corrupts the installation. 
  • Fixed an issue where favorites sometimes aren’t synced. 
  • Improved the reliability of the account picture appearing properly next to the … menu for work and school accounts, especially after changing it. 

 

Changed behavior: 

 

  • Changed Shy UI to only invoke when the mouse is at the very top of the screen instead of just near it. 
  • Fixed an issue where the Immersive Reader toolbar sometimes is blank. 
  • Fixed an issue where the deletion of certain browsing data like passwords sometimes isn’t synced to other devices until Edge is restarted. 
  • Fixed an issue where the Passwords Settings page is blank on Mac. 
  • Changed password autofill behavior to no longer autofill passwords if there are multiple possible passwords.  Instead, the correct password must be selected. 
  • Fixed an issue where passwords can’t be copied out of Settings once they’ve been shown. 
  • Fixed an issue where clicking in the empty space of the Downloads management page scrolls it back to the top. 
  • Fixed an issue where clicking in the empty space of the History or Favorites management pages scrolls them back to the top. 
  • Fixed an issue where Spellcheck sometimes flags all words as misspelled when they’re written in a language that’s different than the underlying OS language. 
  • Improved detection of prices in foreign currencies when adding items to a Collection. 
  • Fixed an issue where pasting content from a Collections text note with a colored background doesn’t preserve the background color wherever it’s pasted. 
  • Improved error messaging when browser sign-in fails. 

 

Known issues: 

 

  • Tabs sometimes appear squished or too small, even when there are only a few of them.  This is most often caused by clicking a link in a different program that opens a new tab in Edge, and can usually be fixed by changing the size of the tab band, for example by resizing the window. 
  • Users of the Kaspersky Internet Suite who have the associated extension installed may sometimes see webpages like Gmail fail to load.  This failure is due to the main Kaspersky software being out of date, and is thus fixed by making sure the latest version is installed. 
  • Some users are seeing favorites get duplicated after we made some previous fixes in that area. The most common way this is triggered is by installing the Stable channel of Edge and then signing into it with an account that has already signed into Edge before.  Fixing this should be easier now that the deduplicator tool is available.  However, we’ve also seen duplication happen when running the deduplicator on multiple machines before either machine has a chance to fully sync its changes, so while we wait for some of the fixes we’ve made to come to Stable, make sure to leave plenty of time in between runs of the deduplicator.  We hope that this will be improved now that version 81 is released to Stable. 
  • After an initial fix for it recently, some users are still experiencing Edge windows becoming all black.  Opening the Browser Task Manager (keyboard shortcut is shift + esc) and killing the GPU process usually fixes it.  Note that this only appears to affect users with certain hardware and is most easily triggered by resizing an Edge window. 
  • Some users are seeing “wobbling” behavior when scrolling using trackpad gestures or touchscreens, where scrolling in one dimension also causes the page to subtly scroll back and forth in the other.  Note that this only affects certain websites and seems to be worse on certain devices.  This is most likely related to our ongoing work to bring scrolling back to parity with Edge Legacy’s behavior, so if this behavior is undesirable, you can temporarily turn it off by disabling the edge://flags/#edge-experimental-scrolling flag. 
  • There are some issues where users with multiple audio output devices sometimes don’t get any sound from Edge. In one case, Edge becomes muted in the Windows Volume Mixer and unmuting it fixes it.  In another, restarting the browser fixes it. 

 

We hope you’ll tune into Build, and we’re also looking forward to hearing from you at our AMA.  Everything we’re talking about has been shaped by you, and we’re looking forward to hearing how we can improve even more!

 

31 Replies
Highlighted

Will the casting work for DLNA Devices(Home TVs, projectors) or only ChromeCast devices? Any plans in case it is not supported?

Highlighted

@josh_bodner  -- still no fix for the squished tabs??

Highlighted

@Rohit Yadav 

 

Well, he did say
"Added UI to help enable media casting if users attempt to use it while it’s disabled.  Note that casting is currently only supported via ChromeCast devices. "

 

I just want to know where this is located?

"Added a Website Permissions Settings page for when a website wants to access serial ports. "

 

Dennis5mile

Highlighted

@josh_bodner 

 

Still '...you can temporarily turn it off by disabling the edge://flags/#edge-experimental-scrolling flag' so I still won't consider using Edge as my browser - not until the option of having regular scrolling behaviour rather than 'personality' becomes permanent. And as I keep saying the wobble effect is on EVERY site with a page long enough for vertical scrolling NOT 'some'. But in any case I won't accept the 'Edge Legacy' style scrolling with or without the added side-to-side wobble.

 

Enormously disappointed casting is only supported with chromecast. I have three devices potentially to cast to - one Roku stick, one Fire stick and one smart TV. All of them support DLNA, none chromecast. Given Windows itself does DLNA casting, the fact you, part of Microsoft, are supporting the GOOGLE casting system and not the more general DLNA is very poor.

Highlighted
Highlighted

@josh_bodner 

 

I see the certificate window is different . . . I don't see how to make one the default.  That would be excellent if I could select one of the 3 certificates I see every time I log in as a default for several work websites I use.

 

Thanks

Highlighted

Hi @Dennis5mile 

the serial port feature is located in the settings page inside "Site permissions": edge://settings/content/serialPorts 

 

Neon01

Highlighted
Settings> Site Permissions
Highlighted

@josh_bodner 

I read the Microsoft Edge at build 2020 blog and liked many features and one of them is sidebar, Sidebar searches your word or phrase with bing search in a bar that appears on the right meaning a user doesn't have to quit the workflow. Sidebar can be opened by right-clicking a selected word or phrase and clicking "Seach in sidebar for ...". I am suggesting here that can we also have a feature where we double-click a word, that word is searched in sidebar, this would make steps easier to search a word in the sidebar.

Highlighted

@josh_bodner Has there been any movement of support for HEVC/H265 videos on the Windows build?

Highlighted

@Chris Childerhose no, but we're tracking a fix for the squished tabs that's coming from upstream Chromium that looks like it will be in Canary soon.  

Highlighted

@sprite-1 no, this issue will likely take some time to get right.  The problem isn't with PWAs, it's actually with sites installed as apps that aren't true PWAs.  PWAs know what pages are and aren't within their scope, so navigation to other pages within that scope are fine.  Other sites installed as apps don't have any way of knowing that, so any navigation causes the behavior you see.  We're trying to figure out the best way to tackle this issue, but it will likely be a while.  

Highlighted

@Klb123 HEVC videos are already supported, but there's a little work you need to do first.  Specifically, you need to install the HEVC app from the Windows Store:  https://www.microsoft.com/en-us/p/hevc-video-extensions/9nmzlz57r3t7.  That adds support for H265 to the entire device.  

Highlighted
I have this already installed via Surface Pro 7, but it still cannot play HEVC H.265 videos.
Highlighted

@josh_bodner Then what was wrong with letting sites installed as apps be dependent on the domain the way it originally worked? Since the site itself is installed as an app, it would make sense to consider all of that domain's pages as part of te "app" then?

Highlighted

@Klb123 Hmm, is it a specific site you're having problems playing HEVC videos on, or just in general?  For example, can you get both videos on this page to play, in particular the top one?  https://h265.webmfiles.org/embed-h265-video.php.  If not, besides checking the normal things like making sure any extensions you have installed or any Tracking Prevention settings aren't interfering with the video, you might also want to make sure the edge://flags/#edge-playready-drm-win10 flag isn't disabled and hardware acceleration is enabled in settings.  

Highlighted

@sprite-1 in some cases it would, but it gets tricky really fast.  Google Docs, for example, share the same subdomain (docs.google.com), but each type of file (sheet, slide, etc.) should arguably have their own application since Google considers them three separate applications in their waffle menu.  After all, does it really make sense to have a shortcut to a Sheets application, but then open a Slide with it?  

 

Or, going the other way, Facebook has a bunch of games you can play (I still play Angry Birds, for example).  Those games live on their own subdomain though (apps.facebook.com).  If I have a shortcut to the main Facebook app, then I also expect that clicking a link to a game keeps me in the app since since it's just another link to a Facebook page, and any other link to a Facebook page like somebody's timeline or a message keeps me in the app.  A rule like "all that domain's pages" doesn't allow for that.  

 

The obvious fix to this is to have some list of exceptions to any rule, but creating such a list isn't a trivial task, and is very expensive to maintain.  The right answer ultimately may end up just being to wait for the website developer in question to make a real PWA, since they can ship those exact rules as part of the PWA package and have it "just work" across all browsers (that support PWAs).  

Highlighted

@josh_bodner 

 


@josh_bodner wrote:

@sprite-1 in some cases it would, but it gets tricky really fast.  Google Docs, for example, share the same subdomain (docs.google.com), but each type of file (sheet, slide, etc.) should arguably have their own application since Google considers them three separate applications in their waffle menu.  After all, does it really make sense to have a shortcut to a Sheets application, but then open a Slide with it?  


I would like to posit that this is more an issue with Google / sites in question and not exactly something that Microsoft should try to solve. The standards are there for them to follow and if they don't then they can't exactly expect browser vendors to bend over backwards for it. (With some exception where it starts affecting performance like what they do with YouTube)

 

Or, going the other way, Facebook has a bunch of games you can play (I still play Angry Birds, for example).  Those games live on their own subdomain though (apps.facebook.com).  If I have a shortcut to the main Facebook app, then I also expect that clicking a link to a game keeps me in the app since since it's just another link to a Facebook page, and any other link to a Facebook page like somebody's timeline or a message keeps me in the app.  A rule like "all that domain's pages" doesn't allow for that.  


In the case of Facebook, it would make sense to show the black bar up top when you navigate to apps.facebook.com in this case, and the person wouldn't be leaving the app anyway, they would just be seeing the black bar up top.

 

The way it was originally implemented made it so that the warning feature has the least amount of clashes with regular sites installed as PWA. Now, it feels like it  has a hair-trigger .

 

But if you're steadfast in this direction though, the least I could request is that you add an option to let users specify on their own what should be part of the "app" via a settings entry of some sort.

 

E.g. for Discord, that would be:
*.discord.com/channels/*

(Wild cards as *)

 

So you get to keep the behavior that you prefer while still allowing choice for power users. You don't need to maintain a list of exceptions this way and power users can set things up themselves.

Highlighted

@josh_bodner It cannot play the top one, it loads the seek bar with the correct time, but does not play and just shows a white box. Tracking prevention turned off, turned off all extensions, hardware acceleration enabled, and PlayReady flag enabled.

 

The top one works fine in legacy Edge and also on Edge for Android. I just tried Edge Canary and it was actually fine (no flags changed from default). It's just the current Dev build it will not play on.