84.0.480.0 (Official build) canary (64-bit) shows error on About screen

Occasional Contributor

An error occurred while checking for updates: We couldn't create that component (error code 3: 0x80040154). Version 84.0.480.0 (Official build) canary (64-bit)


I tried completely uninstalling Edge Canary and reinstalling it. Still shows this Error on About screen, although it seems to run fine.

Annotation 2020-04-09 124709.png



80 Replies
thanks, that really saved me some time knowing that uninstall/reinstall won't fix it because so far I tried restarting computer and changing some network settings but none of them worked :)
By the way I just finished installing and testing Edge canary Version 84.0.480.0 on Windows Sandbox which is a clean fresh OS and the problem still happened.
so this proves that the problem is not caused by any previous installations or left over files malfunctioning.

I think when Microsoft fixes this in the next update and puts it on their servers, we all have to reinstall our Edge canary because the connection between updater and server is interrupted.

another thing is that on the support page there is no mention of "error 3".
But it does mention Error 0x80040154
I know but there are also error codes 4, 7, 12 but not 3 so that article needs to be updated.

maybe there are 0x80040154 code 4, 0x80040154 code 7, 0x80040154 code 12 too.

plus, the suggestion action which is reinstalling Edge because the files are corrupted is unrelated. the files might be corrupted but reinstalling doesn't help.

@HotCakeX A friend had an error like this on an earlier build a week or two ago. Probably the next Canary update will simply auto-update as usual, without issue. If not, running the Installer without uninstalling it will probably work as they suggest.

@HotCakeX  @DavidGB @Don Cuthbert 


I am seeing the same error on three different machines with three different versions of Windows. Thanks for posting this message and your experiences. Hopefully the next update will resolve this issue.

@Don Cuthbert 


yup....same here.


But you saved me from messing about since I checked here first!

Same error for me as well......


Just updated Edge and I'm seeing the same issue. I wish I had checked here earlier before I went through the trouble of reinstalling.

Hello @Don Cuthbert!

When you unistalled microsoft edge canavary, you should delete microsoft edge canavary's folder then you restart your computer and reinstall it. (100% that you can fix the problem)


Link to install microsoft edge canavary:

Hello @DavidGB!

It have mention the error code 0x80040154, you have to expand  Windows 10 in the seventh part and then find your error code to fix the problem.

@Don Cuthbert


Get same error after update of the Edge Canary version. Reinstall not help. However, Edge Dev version 83.0.474.0 work fine.


2020-04-10 09_05_11-Window.jpg



Same here...



@Mac_Van_Tan wrote:

It have mention the error code 0x80040154, you have to expand  Windows 10 in the seventh part and then find your error code to fix the problem.

Yes we all did that, what I said is that "error code 3" is missing, not that part.

@Don Cuthbert 




Did following troubleshooting steps on my workstation:


  • Uninstall Edge Canary version 84.0.480.0
  • Install Edge Dev 83.0.474.0, update issue not appear in current version 
  • Uninstall Edge Dev 83.0.474.0, discover following register keys left:2020-04-10 15_59_55-Registry Editor.jpg
  • Execute "C:\Program Files (x86)\Microsoft\EdgeUpdate\MicrosoftEdgeUpdate.exe" /uninstall
    sequence in elevated CMD
  • Register key "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\EdgeUpdate"
    and folder location:
    "C:\Program Files (x86)\Microsoft\EdgeUpdate\" not appear after that sequence 
  • Install Edge Canary version 84.0.480.0, same error appear: We couldn't create that component (error code 3: 0x80040154)
  • Uninstall Edge Canary version 84.0.480.0
  • Register key "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\EdgeUpdate"
    and folder location:
    "C:\Program Files (x86)\Microsoft\EdgeUpdate\" not appear after that
  • Install Edge Dev 83.0.474.0, everything works fine, got missing icons in Favorites, must re-import

Hi everyone,


Thank you for sharing your experiences with this. One of our program managers had some initial troubleshooting tips:


"1. Press Win +R, type cmd.exe and press Enter

2. Type “%LOCALAPPDATA%/Microsoft/EdgeUpdate/MicrosoftEdgeUpdate.exe /regserver” and press Enter

3. Reboot the machine and verify if the issue is fixed."


If that doesn't resolve the error, you can also try uninstalling and reinstalling Canary. And to confirm, there are no known performance effects with this error, it just means that you might not see version 84 changes until after we can push the fix in a subsequent build.


Hope this helps, and please let us know if you see anything else come up!


Fawkes (they/them)
Project & Community Manager - Microsoft Edge

Did this fix resolved the issue for anyone? Did not work for me :(