Azure VM Remote desktop stopped working

%3CLINGO-SUB%20id%3D%22lingo-sub-153344%22%20slang%3D%22en-US%22%3EAzure%20VM%20Remote%20desktop%20stopped%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-153344%22%20slang%3D%22en-US%22%3E%3CP%3EHI%2C%3CBR%20%2F%3EMy%20Azure%20VM%20is%20no%20longer%20allowing%20me%20to%20connect%20using%20remote%20desktop.%20I%20receive%20error%20message%20%22RDP%20disconnected!%204%20An%20internal%20error%20has%20occurred.%22%3CBR%20%2F%3EI've%20run%20through%20all%20the%20suggested%20the%20steps%20on%20this%20page%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-machines%2Fwindows%2Ftroubleshoot-rdp-connection%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-machines%2Fwindows%2Ftroubleshoot-rdp-connection%3C%2FA%3E%2C%20and%20none%20of%20them%20fixed%20the%20issue.%20The%20Azure%20VM%20Resource%20health%20is%20fine%2C%20and%20the%20VM%20itself%20is%20running.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EDoes%20anyone%20have%20any%20other%20ideas%20on%20how%20I%20can%20get%20this%20resolved%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-153344%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-154731%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20VM%20Remote%20desktop%20stopped%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-154731%22%20slang%3D%22en-US%22%3EIs%20it%20a%20Domain%20joined%20VM%20or%20workgroup%20VM%20%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-153678%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20VM%20Remote%20desktop%20stopped%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-153678%22%20slang%3D%22en-US%22%3E%3CP%3EHere%20you%20can%20find%20several%20articles%20on%20resetting%20different%20VM%20configurations%3A%3C%2FP%3E%0A%3CP%3E-ERR%3AREF-NOT-FOUND-%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-machines%2Fwindows%2Freset-rdp%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-machines%2Fwindows%2Freset-rdp%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-153635%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20VM%20Remote%20desktop%20stopped%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-153635%22%20slang%3D%22en-US%22%3E%3CP%3Edo%20you%20get%20the%20internal%20error%20after%20entering%20credentials%3F%3C%2FP%3E%0A%3CP%3Eif%20so%20did%20you%20do%20any%20security%20or%20certificate%20change%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-153351%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20VM%20Remote%20desktop%20stopped%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-153351%22%20slang%3D%22en-US%22%3E%3CP%3ENo%2C%20I%20haven't%20made%20any%20changes%20to%20the%20VMs%20DNS%2C%20or%20the%20Virtual%20Subnet.%20I%20also%20have%20another%20Azure%20VM%20in%20the%20same%20subnet%20that%20I%20can%20still%20connect%20to%20so%20I%20don't%20think%20its%20network%20related.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-153347%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20VM%20Remote%20desktop%20stopped%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-153347%22%20slang%3D%22en-US%22%3E%3CP%3Edid%20you%20make%20any%20change%20to%20DNS%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

HI,
My Azure VM is no longer allowing me to connect using remote desktop. I receive error message "RDP disconnected! 4 An internal error has occurred."
I've run through all the suggested the steps on this page https://docs.microsoft.com/en-us/azure/virtual-machines/windows/troubleshoot-rdp-connection, and none of them fixed the issue. The Azure VM Resource health is fine, and the VM itself is running.

 

Does anyone have any other ideas on how I can get this resolved?

5 Replies

did you make any change to DNS?

No, I haven't made any changes to the VMs DNS, or the Virtual Subnet. I also have another Azure VM in the same subnet that I can still connect to so I don't think its network related.

 

 

do you get the internal error after entering credentials?

if so did you do any security or certificate change?

Here you can find several articles on resetting different VM configurations:

https://docs.microsoft.com/en-us/azure/virtual-machines/windows/reset-rdp

Is it a Domain joined VM or workgroup VM ?