WVD Portal unable to query sessions

Occasional Contributor

So, I extended my host pool, and for any of the systems now, when I click on the session host, I get:


"There was an error retrieving the user sessions. Please refresh the page and try again"


I can log on to the WVD devices fine, they are operating correctly. And Powershell looks like it's happy.

Get-AzWvdUserSession -HostPoolName WVDPool -ResourceGroupName WVD-Desktops-rg|select activedirectoryusername, applicationtype, createtime, name, userprincipalname| ft -auto

ActiveDirectoryUserName CreateTime          Name                         UserPrincipalName                      
----------------------- ----------          ----                         -----------------                      
DOMAIN\user             02/06/2020 08:51:30 WVDPool/

It just appears the portal is having difficulty. Any suggestions where to look to resolve this?


Also, despite having enabled full diagnostics on host pool, DAG and workspace, my logs appear to be empty. Why would that be?


Get-RdsDiagnosticActivities -TenantName xxx
Get-RdsDiagnosticActivities : There were no activities found.

Get-AzWvdSessionHost -HostPoolName WVDPool -ResourceGroupName WVD-Desktops-rg|select name, osversion, lastheartbeat, lastupdatetime, status |ft -auto

Name                  OSVersion  LastHeartBeat       LastUpdateTime      Status
----                  ---------  -------------       --------------      ------
WVDPool/ 10.0.18363 02/06/2020 08:33:54 01/06/2020 16:05:56 Available


Thanks for any advice


4 Replies
best response confirmed by Eva Seydl (Microsoft)

@andyinv We have an active bug where for some deployments, user sessions are not displayed on the portal. We are unable to repro it - so if you can let me know what your deployment looks like it will be highly appreciated. I am looking for whether the VMs, WVD objects are in the same subscription, resource group and location. If not, what are the differences.

Secondly, Get-Rds**** cmdlets cannot be used with ARM environments. You have to use LogAnalytics to view the diagnostics data. We do not control when the data will be populated - we pipe it to LogAnalytics and we have seen sometimes that the very first time you are trying to access data in the tables, it could take 24 hours to populate. After that it should an almost immediate update.

Thanks Pavithra

It had previously worked fine when I deployed two VMs. I subsequently deleted one and updated the image, and then deployed the new image to the pool with a further one VM.

All resources are in UK South and WVD metadata is in West US. Everything is in the same subscription. The infrastructure (domain controllers) are in one resource group, and the WVDs are in another (connecting to the network in the infrastructure rg). This worked fine, the only change that happened was after I had removed one of the hosts (I think).

Would be very happy to session-share with one of your techs if that can help?

@Pavithra Thiruvengadam 


Is there an update on this issue?


We are also seeing this exact same behavior with newly deployed host pools.  All resources are located in US West.  The Host Pool and Application Groups are in the same Resource Group.  The Workspace is in a different Resource group and each individual session host is in a separate resource group.


Pulling up the Users and searching on each one correctly shows the sessions connected to.  Pulling up the session host generates a Failed to retrieve user sessions error message.





are your machines set up to use a proxy?