Sage Accounts showing failed to connect error message when exporting to Excel

New Contributor

We have Azure Virtual Desktops that are shared by a number of users. 32-bit MS Office was installed as usual normal via the Office Deployment Tool. We also have Sage Accounts installed, mirroring a setup we used to have on a physical remote desktop server before we moved to the cloud.

 

However, when using Sage50 Cloud Accounts, whenever we try to "Send to Excel", we get an error message saying "Failed to connect to Excel". There are other similar issues too where finance users cannot export statements as attachments directly to Outlook. Both are obviously Office related.

 

This has worked for years for us on our physical platforms, and worked with physical PC's when accessing data off the same Sage server, but when using Sage on an Azure Windows 10 build it fails. Sage tell me this is because it is running on Microsoft's Azure virtual remote desktop, but I can't see what that has to do with it as the Sage client is still running on Windows 10 and is the same version as that running on physical PC's that have no problem. It also worked perfectly fine on Windows 10 on VMWare but we no longer have that facility.

 

Physical PC's accessing the Sage data on the virtual Windows server do not have a problem, and it is therefore not down to the virtual server that hosts the Sage data. The problem only shows up on the virtual desktops. We no longer have access to the physical PC's and are stuck with a non-functioning Sage to Excel facility. Strangely, export to Excel does work when you select the Reports option, but not the Sage to Excel function, as not all reports are in the Reports section.

 

Sage will not help, and tell me it is to do with the installation of Office on the Azure virtual desktop. But this version has worked on physical PC's.

 

We have re-installed, and even run the client Sage app as admin. This is hugely frustrating as a simple, quite common process should work just fine, but Sage won't help. Is there anything I can do?

 

Thank you.

2 Replies

@ITHRBruce Hi there, did you get anywhere with this in the end. We are about to try installing Sage on our AVD configurtion and wondering if we might come across this issue?

@lctimcoles

 

Hi,

 

Yes, I discovered that if I run a Quick Repair (via Control Panel, Programs and Features, MS Office 365, Change) on the PC in question, then it works without any problem. So try that. I sometimes had to also do it after a restart for a Windows Update, which may have caused it in the first place. So if it fails again, do a Quick Repair.

 

Apologies for not posting this before now, I thought I had done so.

 

Good luck.