Remote app pop up window not populating fields until input is detected.

Copper Contributor

We have a weird scenario here where a published app calls a popup window, the window should display rows/fields but they are not visible until user input is provided. Specifically:

    • The user must mouse over the popup and scroll their mouse wheel, then all fields appear
    • The user must resize the popup window (any direction), then all fields appear
    • The user must drag the vertical scroll bar up/down, then all fields appear

Here's our environment:

- Win 10 22H2, 19045.2846

- AVD Agent 1.0.6425.1200

- RD Client 1.2.4240.0, also happens w/ the AVD Beta app from MS Store

- Have gone back to complete default RD display and device redirection settings in AVD in our QA environment, problem persists. I've also toggled through all the relevant display and device settings.

- Have tried forcing the local machine to use both integrated or NVIDIA video card, same issue.


The session is essentially waiting for user input against the popup screen before it displays all the fields but I can't track it down for the life of me... any other things to look into?

10 Replies



We have been experiencing the same issues. If we login to the AVD via remote desktop session, the issue does not occur. Only via remote app.


This issue does not occur constantly, but it does occur frequently enough to be an issue.


We have tried different images (ie Windows 11 and Windows 10) and different sizes/SKU.


We have tried changing display settings on both host and client with varying results but none have resolved it, so hopefully someone will be able to advise on what else to try.  


The only success we had was when we tried AMD based AVDs which reduced the frequency the most. 





Thanks for the feedback, we've tried the same things as well.  

  • Intel & AMD sizes
  • We have not yet tried N series machines, but I doubt it would make a difference.
  • IBM Thinkpads and Dell Precisions, same issue.
  • RDP desktop session will not produce the same result, leading me to believe it has something to do w/ how AVD client or RDP settings is seeing the user input on popup.
  • Have not tried Win11, but good to know that it didn't solve the issue.

At what point does MS consider this a potential bug?  (honest question)



* We have not tried N Series either (but they are really expensive even to test!)

* The issue appears on all RDP clients (Web, MacOS, Linux, PC/Laptop based)

* We cannot try older builds of Windows 10 or 11 as creating new AVDs always uses the latest release (which is one of our theories).


It would be interesting to find out what application you are experiencing this with to see if there are any similarities with ours. 


Unfortunately I think we will need to post on other forums and possibly raise a support call with MS before this gets considered a bug. 

I am having the same issue, also some more. I just made a MS case. Keep you posted if they get it fixed. Personally I suspect the Remote Desktop Client/Azure stack. Also posted all my problems in the community, see
Thanks, keep us posted here. I have a ticket open also, but we go through a 3rd party so that has been a slow deal.
We are also facing the same issue and are gathering som data to create a case with Microsoft.


We have been having the issues since April.

You can simply click on the screen or move the arrow down to populate the box but this just won't do for our staff.

We have rolled back the SXS stack to keep a version running that works and doesn't cause the blank pop-up. The one that is working is sxs221103300. 

We keep the scheduled update window in a state of rotation to they don't auto update.

One of our Host Pools is a validation group so we keep that open to update weekly and testing whenever a new one is out but so far no go. 

I have an open ticket but have yet to get any support and keep escalating with our MS rep.

Unfortunately we also believe not updating the stack may be causing other issues.



Forgot to update this, but yes I met with MS support last week. Uninstalled all RD Components, had me manually remove and re-add the host to the host pool. He did point out that versions were not uninstalling and just installing versions in sequence. He gave me a registry edit that's supposed to disable the updates, but I have this in our QA environment but it didn't work. Thank you for pointing out the SxS stack that actually works, I'll have to see if that works for us too. Manually moving the update setting out each week sounds like a hassle... I suppose that's what needs to be done for now.





Where do we choose the stack used in AVD?


Thanks :)



The Remote Desktop Client sets up a connection with the AVD session host, so the Remote Desktop Client version dictates the stack version. The AVD session host has the last two stacks installed.



Using quser in cmd/ps you can see under the sessionname of the users which SxS they are using seeing you can correlate the name with the installed Azure Sxs Stack.