"WARNING: 1.0.1534.2001" after every Microsoft.RDInfra.RDPowershell command


This started happening about an hour ago.  Every time I run an RDS command, such as:




The command appears to complete successfully but is followed by:


WARNING: 1.0.1534.2001


The number "1.0.1534.2001" corresponds to the version of Microsoft.RDInfra.RDPowershell I have installed.  I checked and there's no later version available.  I uninstalled and reinstalled, but the same thing happens.

What, exactly, is that WARNING about?



9 Replies

I had a call with premier support today on an unrelated issue and mentioned the error WARNING: 1.0.1534.2001


I had been spinning up a new WVD environment and was concerned the warning may have an impact on the new deployment.

I confirmed the expected functionality was working and there were no unexpected issues. the host pool apps and users are all working correctly so don’t worry about the message. the MS rep I spoke to was aware of the issue and MS are in the process of resolving it.

In short, dismiss the warning for the short term it will have no impact om managing WVD.

A new patch has version has been released for the Microsoft.RDInfra.RDPowershell cmdlet.


please run the following in admin mode in powershell.


Install-Module Microsoft.RdInfra.RdPowershell Install-Module AzureRM -force
This will pull the new update and the error will no longer occur.

@Nic_Danger tried installing these 2 modules again but still seeing the error.


Also -InvokeRdsUserSessionLogoff seems to be broken, you just get the warning it doesnt complete the action

@Nic_Danger I tried this and it did not work.  I am still getting the WARNING message.


FWIW, we use the Az module, *not* the AzureRM module.



@FortyMegabytes there must be a condition within the module that is expecting a new version, but none is available. Purely assumption given it is providing simply a warning number and a version. Here is the latest version in the repository. You'll see it is the same version: 


S C:\Users\q1hgo3s.SALENT\OneDrive - Save A Lot\Scripts> Find-Module Microsoft.RDInfra.RDPowershell             

Version              Name                                Repository           Description
-------              ----                                ----------           -----------
1.0.1534.2001        Microsoft.RDInfra.RDPowershell      PSGallery            Windows Virtual Desktop PowerShell module
best response confirmed by FortyMegabytes (Contributor)

To anyone following this post:


There's a new version of Microsoft.RDInfra.RDPowershell available:


I ran:


Update-Module -Name Microsoft.RDInfra.RDPowershell


After exiting my PowerShell session and restarting, now all my GetRdsHostPool commands and such do not give the WARNING error.


@FortyMegabytes I'm not sure what the warning is about but it does not seem to negatively impact the commands I run.  I've actually added $warningpreference = "SilentlyContinue" to my scripts so that my screen does not get filled with that warning every time I run them.