Run-Time Error 3340: Do NOT have problem updates installed

Copper Contributor

Like many others, I returned to work today (11/18) only to find our app spitting out this Run-Time 3340, query is corrupt error. I tried searching the latest updates for the problem updates (KB4484127, KB4484119, KB4484113, and KB3085368) and none of these are present on the machine in question. The developer for the app we're using also suggested trying a fix for office 365, which did not work (we don't, as far as I can tell, actually use office 365 on that machine, so I wasn't really expecting a fix there to work). Does anyone know of any other update that might be causing this issue? I am not technical enough to know where to begin with Microsoft's suggested code fix, and with none of the problematic updates being present, I'm stumped as to where else to look to fix the issue.

19 Replies

@thefaydra check if this helps : 

To downgrade version, you need to launch CMD.EXE as Administrator and then add 2 lines:

[Office 2016/2019]

cd %programfiles%\Common Files\Microsoft Shared\ClickToRun
officec2rclient.exe /update user updatetoversion=16.0.12130.20272

Office [2013 with windows 32-bit]

cd %programfiles%\Microsoft Office 15\ClientX86 officec2rclient.exe /update user updatetoversion=15.0.5179.1000 

Office [2013 with windows 64-bit]

cd %programfiles%\Microsoft Office 15\ClientX64 officec2rclient.exe /update user updatetoversion=15.0.5179.1000


Hi.  What version/build of Office do you have? (where to get this information unfortunately depends on which version/build you have, but try starting with File/Account or File/Help).


KB4484127 is specific to Office 2010, KB4484119 to Office 2013, and KB4484113/KB3085368 are for Office 2016 MSI installations.  


If you don't have any of those updates, it suggests that you have either Office 2016 Click-to-run, or Officed 365.  If you do, you can use File/Account/UpdateOptions/UpdateNow to get a fix for this issue.


If you have Office 2016 MSI, then there is a fix avaialbe here:


For Office 2010/2013, a fix will be available soon.


Shane Groff

Access Engineering

@Shane Groff 


Do you have an idea as to why this option does not show up in my Office365 menu? v1910 or v1902

"File/Account/UpdateOptions/UpdateNow to get a fix for this issue."

Thanks for any input!

@lwestberg II'm not sure I understand your question.


When you choose 'File', then 'Account', what does it say under 'About Access'?

If it doesn't show a Version/Build number there, if you click on About About Access, then what build number does it show then?



@Shane Groff 


Attached are two screen shots.  Thanks for the help.

@tsgiannis This worked!! Thank you so much!

@lwestberg You are on Office Insider channel, so I think the Update Now option is hidden inside the Office Insider button.


You might need to switch from Monthly-Targeted back to Monthly in order to ensure you get the fix right away (it will be available soon, regardless, but I know it is available now for Monthly channel).

@Shane Groff   I wanted to personally thank you for the help you provided @thefaydra regarding the "run-time error 3340: Do NOT have problem updates installed" issue.  I have developed a database app over the past 20+ years that handles family financial management and personal investment management.  Today I ran into the "Query is corrupt" issue while using my app to process some QCDs out of my IRA.  I spent most of the afternoon trying to fix the issue without any success.  Longer story short, I found your thread on this issue.  Thank you so much!  I ran the update and everything cleared up.  What a relief!


Thanks for yout input I appreciate it.  Most of our machines have the screen shots in there attachments.  Do you have a suggestion?


Any help is appreciated


@Shane Groff 


Can you follow the steps here:


To see if you have a group policy setting here:



That may be hiding the Update Options button?

@Shane Groff 


Thanks Shane.  Oddly, I do not have that in the registry for any of our machines.  I tried to add it to one machine and it did not work.  If you run across any other ideas, I would appreciate that very much


I didn't notice that it says "Microsoft Store" next to your build number in the About Access box.


This means that you have the Microsoft Store version of Office.  To get an update, you should open the Microsoft Store, click on the ... in the upper right corner, and choose Downloads and Updates.

That should update your version of Office to get the fix.

@tsgiannis do you perhaps know the lines that need to be entered for Office 2010 as well?





Hi I have the Spanish version of Office 2013 32 bits. I try your solution but is not working.


I am not find  officec2rclient.exe in my computer.


Someone Knows when Microsoft will fixe the problem. They expected solve it the 29th, but not yet.


Regards from Spain and sorry by my English.




Are you certain that you have a C2R install?

If you start Access, click Open Other Files, then Click Account, do you see a button that says 'Update Now'?  Or do you just see 'About Access' like this:


If you have an MSI installation, rather than C2R, you should install KB2965317



@Shane Groff 


Thanks a lot by your answer.

I have the update button and when I try to update the system inform me that I have the last one:  2019 12 November, 15.0.518901000, KB 4527848

I try your one but is not compatible with my system.

Is my installation a C2R? Will come the solution about the 10th of December?

Best regards


I am trying to update every day but the error is not fixed yet. 10th of december with out news.

Hey Jordi,

It's only been Dec 10 for 3 hours here in Redmond. I'm not sure exactly what time it will be available, but it will be today (so within the next 21 hours).