Class Not Registered in MS Access Office 365

Copper Contributor

My work colleague has a new laptop running Windows 10 and Office 365 Professional.  I have copied across an Access database (.mdb) that runs beautifully on my laptop that runs Windows 10 and Office Professional 2013.  The database opens, and functions well except when running a module it fails and returns the runtime error "class not registered".  I have tried converting to .accdb and repairing Office 365 but the error persists.

I did not write the code, which was written 17 years ago and I'm not able to contact the person who wrote it.  I have attached the VB code in question.  The error occurs at the following (2) places in the code

Set GrpSvr = CreateObject("GrpSvr.GrpCall") 


The only difference I can see in our reference tools is that I have Microsoft Access 15.0 Object Library and hers is 16.0.  We both have the Microsoft DAO 3.6 Object Library with the same version of DAO360.dll installed.

Any advice is truly appreciated.

4 Replies


Further information that might be helpful....the new laptop that I am having problems with is running a 64-bit version of MS Access, but on my laptop where it works beautifully runs a 32-bit version of MS Access.  We both run 64-bit operating systems.  Will uninstalling the 64-bit version of Office 365 and then installing the 32-bit version on the new laptop work?

@stokeslj I actually recommend (particularly since this is old code) that you start by trying to comment out the procedure(s) where this code is called.  See if the code compiles without them because it is possible that it is no longer used.  That way you do not waste time on this issue unless you have to.

Thanks Maria, I tried your recommendation, but i still have the problem. I'll keep searching.


The solution was uninstalling the 64-bit version of Office 365 and installing the 32-bit version.