SOLVED
Home

RSAT missing DNS Server Tools?

Oliver Stähr
New Contributor

RSAT missing DNS Server Tools?

Hi,

on a fresh Win 10 insider client (16278 updated to 16299) I installed Windows_InsiderPreview_RSAT_x64_16279 but it seems to be missing DNS Server Tools, the MMC snap-in. All other tools like AD, DHCP, WSUS, RAS etc. are there.

It should be there, right?

Cheers, Oliver

 

 

51 Replies

RE: RSAT missing DNS Server Tools?

I just solved this issue on the Windows 10 that I upgraded last night to 16299.15. If you have a Windows Server 2016 (not insider) machine on your network, or another Windows 10 with the WS2016 (not insider) RSAT tools installed, you need to copy four files from it to your Windows 10 after installing RSAT 16279. system32: dnsmgmt.msc and dnsmgr.dll system32\en-us: dnsmgmt.msc and DNSmgr.dll.mui (or slightly fewer keystrokes if you are using the command prompt to do it, copy dnsmg*.* in both system32 and system32\en-us folders) Then run this command as admin: regsvr32 c:\windows\system32\dnsmgr.dll

Re: RE: RSAT missing DNS Server Tools?

The formatting went wonky on what I just posted but hopefully it is usable.

 

The last step of course is to make a shortcut to system32\dnsmgmt.msc and copy it into your start menu admin tools folder.

Re: RE: RSAT missing DNS Server Tools?

Nice workaround, thx. I hope it will be fixed in future RSAT releases.

Re: RE: RSAT missing DNS Server Tools?

It has not been fixed in WindowsTH-RSAT_WS_1709-x64.msu released today :(

 

Re: RE: RSAT missing DNS Server Tools?

I've been having problems getting RSAT to install on build 16299 and tried your method above, but get the error "MMC could not create the snap-in."

 

It seems like Microsoft is trying to get away from MMC. Is there some new way I'm suppose to be managing my servers that isn't powershell?

 

Edit: disregard, I forgot to run the regsvr32 command at the end. "facepalm:

Edit 2: If you don't have another Windows 10 or Server 2016 machine to copy from, and you just upgraded your copy of Windows (which broke RSAT), you can copy the files from the C:\Windows.old directory.

Re: RE: RSAT missing DNS Server Tools?

But the above workaround still works. Thanks.

Re: RSAT missing DNS Server Tools?

We're also seeing this issue on the current download here:

 

https://www.microsoft.com/en-us/download/details.aspx?id=45520

 

File: WindowsTH-RSAT_WS_1709-x64.msu

 

We'd prefer not to move files around manually in order to get DNS back - when can we expect an actual fix (i.e. a new release) for this issue?

 

And more importantly, how could this pass even the most basic of QA tests and be released to the general public? :)

Re: RSAT missing DNS Server Tools?

In my "perfect world" people would get fired over this. Think of all the thousands of wasted hours this will now cause.

Re: RE: RSAT missing DNS Server Tools?

This solution works from me. The 1709 RSAT update still has the same issue.

Re: RE: RSAT missing DNS Server Tools?

I was able to accomplish the same thing by just copying the files out of the windows.old directory on the same PC after moving to build 1709. Workaround works, but MS should actually fix the actual issue...

Re: RE: RSAT missing DNS Server Tools?

The DNS team is validating an official solution and working on putting together a KB article with the details. Thanks for your patience!

Re: RE: RSAT missing DNS Server Tools?

Any update on this?

Re: RE: RSAT missing DNS Server Tools?

I do not have a 2016 server or a windows.old with relevant dns msc files.  Some MSC Admin tools are only used by a very small fraction, but DNS? 

Please provide an update soon.

Re: RE: RSAT missing DNS Server Tools?

Attached are the files I've been using for the workaround. Agreed that this issue needs to be fixed - it is a bit ridiculous. Literally - Windows haters ridicule Microsoft over stupid little things like this, and preventable mistakes just reinforce the stereotype.

Re: RE: RSAT missing DNS Server Tools?

Thanks, I'm able to use DNS Manager now.

Re: RE: RSAT missing DNS Server Tools?

Thanks! Worked for me. I use DNS all the time as a Sys Admin. I am on the Insiders Program and waiting for 17025.1000 to download and install. I installed 1709 and noticed that my RSAT tool tiles were missing on my Start menu. I found that I needed to install RSAT for 1709. But then missing my DNS tool, I cannot be without, although, I am using PowerShell more to work with DNS.

Re: RE: RSAT missing DNS Server Tools?

The above worked for me thanks :) 

Re: RE: RSAT missing DNS Server Tools?

I had to re-install the RSAT again after the preview installation of Build 17025.1000. Also had to re-run the registration and pin the DNS link back to my Start menu.

Re: RSAT missing DNS Server Tools?


@Robert Affleck wrote:

In my "perfect world" people would get fired over this. Think of all the thousands of wasted hours this will now cause.


that won't solve the issue. Learn from the mistake and make sure won't happen again.

Re: RE: RSAT missing DNS Server Tools?

 

The "Additional Information" section of Remote Server Administration Tools for Windows 10  now recommends to use the WS2016 RSAT package instead if DNS tools are missing.  We are using 2012r2, so the WS2016 RSAT package is what I should use anyway.

 

When to use WS_1709 RSAT Package: When managing Windows Server, version 1709
When to use WS2016 RSAT Package: When managing targets older than Windows Server, version 1709

There are known issues that may impact RSAT functionality
Issue: DNS Tools missing
Impact: WS_1709 RSAT package users
Resolution: Use the WS2016 RSAT package

Re: RE: RSAT missing DNS Server Tools?

Yes, the "Additional Information" section on the download page does clarify things. The problem is, Microsoft has moved the goalposts on this. We are conditioned that RSAT gets broken after feature updates (upgrades), and that we need to go fetch the latest version to get things working again. In other words, match the version of RSAT to the client version.

 

Now there seems to be a directive to "install the RSAT version to match the server version being managed." What happens when you have a mixed environment with old and new? Dumb. The newest version of RSAT should always be (within reason) backwards-compatible.

Re: RE: DNS Server Tools?

I had a similar problem in that I couldn't connect to the internet because computer would not recognize the existence of a DSN server.--had Microsoft on phone for almost 3 hours no results.  Call my internet server company "Spectrum"  They sent someone out in 10 minutes he had me up and running. Changed a wire to my modem (thought lightening might have run in) but modem was on a circuit breaker.  He then downloaded files from main office to re-establish the DNS service to my desktop. I have lost other things doing Windows10 updates.  I have come to be suspicious of every update.  Now I'm getting a picture "that it is time to update my computer" and there is no company, product, or connection connected to the notice.  Nor is there a decline button.  I'm perplexed so I'll stop here on go work on that problem.  Any suggestions please post.

Re: RE: DNS Server Tools?

@Anonymous this is not the right place for address your issue. You must contact some local IT Support service, maybe you can find someone in https://community.spiceworks.com or you can receive more info in https://answers.microsoft.com/en-us/windows 

Re: RE: RSAT missing DNS Server Tools?

Thanks, this worked a treat.

Re: RSAT missing DNS Server Tools?

No ifs, ands or buts. I'm tired of downloading RSAT for Windows 10. After the 1709 update this week it broke again.

Installed WS_1709 after the update, no DNS, did a system restore to go back to WS_2016 but it will not install.

Just going to RDP to the DCs from now on.

Thanks again Microsoft for updating the updates and breaking other things along the way too.

Re: RE: DNS Server Tools?

Thanks!  Sorry I goofed. New--appreciate your help to do things right.

Re: RSAT missing DNS Server Tools?

Re: RSAT missing DNS Server Tools?

Perfect, better to publish a laborious workaround vs. fixing the package. /s

Re: RSAT missing DNS Server Tools?

Nope, another fail.

Running the batch file gives syntax errors.

Re: RSAT missing DNS Server Tools?

You must not work in software development...

Regardless - it has taken them a bit too long to fix this seemingly minor packaging bug.

Re: RSAT missing DNS Server Tools?

Re: RSAT missing DNS Server Tools?

I will give it a try after the next build comes down.

Re: RE: RSAT missing DNS Server Tools?

Thanks for posting the files, it works now.

Re: RSAT missing DNS Server Tools?

Reading through this and I see a lot of frustration.  One way to reduce this and possibly increase security is to provision a management server and run your elevated tools and scripts from that location.  This allows you protect against pass-the-hash like security risks by using your separate elevated account to log into your management server to complete elevated tasks.  Another approach if you have an RDS or Citrix farm is to publish the applications.  Running these from a windows 10 desktop is going to have it's challenges.  Having to reinstall RSAT tools to match the OS is not new.  Spend less time complaining and aligning with the problem, get outside the box and become the solution.

Re: RSAT missing DNS Server Tools?

Anyone have a clue how to successfully uninstall KB2693643?

PS> Uninstall-Package -Name "Update for Windows (KB2693643)"
PS> Get-Package -Name "Update for Windows (KB2693643)"

Name                           Version          Source                           ProviderName
----                           -------          ------                           ------------
Update for Windows (KB2693643)                                                   msu

As you can see, uninstall seems to succeed without throwing any errors, but Get-Package says it is still installed.  


Appwiz.cpl updates still lists a slightly different named  "Update for Microsoft Windows (KB2693643)"  with "An error has occurred. Not all of the updates were successfully uninstalled."

 

 

PS> wusa.exe /uninstall /kb:2693643

results in the following error message box:

"Windows Update Standalone Installer

"Installer encountered an error: 0x80070005

Access is denied."

 

In all cases, I have elevated PS.

 

 

 

Re: RSAT missing DNS Server Tools?

Travis, that is a good idea for the people that can afford the extra licensing.  Of course MimiKatz sniffs out credentials passed to RDP servers, so by default, the jump server might not help much.   A more secure solution would be to have a separate machine (preferably hardware based)  accessible only via KeyboardVideoMouse switch.  

Re: RSAT missing DNS Server Tools?

@dareames posted the answer to uninstalling in the link below.  My CBS.log had ~hundreds of error entries of not being able to remove mostly en-us folders, but none of those mattered when the registry key is deleted.

"Fall Creators Update - Cannot uninstall RSAT KB2693643"

Re: RE: RSAT missing DNS Server Tools?

Thank you this works!

Re: RSAT missing DNS Server Tools?

Installed Build 17063.rs_prerelease.171213-1610.  Although I had to go through it twice, it worked the second time around and my tiles showed up on my Start menu without having to move them or pinning them to the Start menu again.

The new build is soooo much better than 17046.  For those of you on the Fast Ring for Insider Preview, Build 17046 was available 12/19/2017.

Re: RE: RSAT missing DNS Server Tools?

Thank you Jerry! I had the same problem today
Solution

Re: RE: RSAT missing DNS Server Tools?

[UPDATE] The final 1803 release of RSAT is now on the public RSAT download page. Look for the WS_1803 package there, thanks!

 

-----

 

Here's the official KB workaround published by the DNS team:

https://support.microsoft.com/en-us/help/4055558/rsat-missing-dns-server-tool-in-windows-10-version-... (thanks @Christoff MOrlOck for posting this previously)

 

The RSAT download page now also has this info under Additional Information:

Issue: DNS Tools missing
Impact: WS_1709 RSAT package users
Resolution: Use the WS2016 RSAT package or apply this workaround

 

The DNS team has also fixed the root cause for RS4 and so the workaround will not be required for the upcoming RS4 RSAT package update.

 

 

Re: RE: RSAT missing DNS Server Tools?

I finished installing Build 17074 yesterday. I am missing many of my tiles on the start besides the RSAT tiles. All of my Office tiles, most of my Visual Studio tiles. And now there is a new Suggested in the left menu showing apps from the Microsoft Store.

I will run the work-around and see if it is still working, but I am looking forward to the RS4 RSAT update.

Re: RE: RSAT missing DNS Server Tools?

The work-around installed fine and I have my RSAT tiles back on my start menu. Just need to go find the rest of my Start Menu tiles.

Re: RE: RSAT missing DNS Server Tools?

Updated my workstation to 1709 yesterday and lost all shortcuts to the Server Manager. Seemed to disappear so I downloaded and installed the latest version and Manage DNS was missing. Followed the steps above by creating two txt files, copied the ~97MB WindowsTH-RSAT_WS_1709-x64.msu file to the same folder and ran the install bat as admin and it worked. Glad to have a workaround.

Re: RE: RSAT missing DNS Server Tools?

Work for me. Uninstall KB2693643--> restart pc--> WindowsTH-RSAT_WS2016-x64.msu 

Re: RE: RSAT missing DNS Server Tools?


@Jim Harle wrote:

Attached are the files I've been using for the workaround. Agreed that this issue needs to be fixed - it is a bit ridiculous. Literally - Windows haters ridicule Microsoft over stupid little things like this, and preventable mistakes just reinforce the stereotype.

i know this thread is somewhat old but this is still an ongoing issue. just wanted to point out that this workaround worked perfectly for me. Thanks for the files buddy.

Re: RSAT missing DNS Server Tools?

This Microsoft fix worked for me on version 1709.

Happy as got my DNS Manager back !!

Just make sure file names are correct and you run batch file from command box not right click method.

Re: RE: RSAT missing DNS Server Tools?

I have downloaded the RS3 version of the RSAT 2016.  I now have Windows 10 Enterprise v1803 build 17133.1.  I am still using the workaround with success.  Yes, I am still losing my RSAT icons for DNS and ADUC from my Start menu after the latest Insider's build downloads and installs.  

Waiting for RS4 of the RSAT to test and see if I can install without the workaround.  I can imagine that I would have to install RSAT anytime I would install a new build.  The workaround works well for me as that is the first thing I do after a new build is to run the bat file to install my RSAT tools.

Workaround to install RSAT for WS2016

Re: RE: RSAT missing DNS Server Tools?

The final 1803 release of RSAT is now on the public RSAT download page. Look for the WS_1803 package there, thanks!

Related Conversations
RSAT Download
Calvin Wong in Windows Server Insiders on
10 Replies
RSAT installation issue
Terry Lake in Windows Server Insiders on
2 Replies