what's new
438 TopicsIntroducing a refreshed design, task chat, and more in Microsoft Planner
We’re excited to announce that a modernized user interface and new features are now rolling out to basic plans in both Planner in Teams and Planner for the web. The updated design offers enhanced navigation, responsive layouts, a new goals view for setting objectives and priorities, and task chat—one of your most requested features—to enable real-time collaboration and @ mentioning team members. This release aims to make planning easier for everyday users while preparing for future AI-powered capabilities. Our goal is to streamline planning by making it more intelligent and connected, so teams can concentrate on achieving results rather than managing tasks. What's new in Planner A refreshed design: With this rollout, users will be able to manage their plans in a cleaner, more modern interface that brings a more consistent planning experience across work. Planner’s new look was designed to feel simpler, allowing users to find what they need. It reduces visual clutter, improves layout and spacing, and creates a more focused workspace. Task chat with @ mentions: A new task chat is coming to basic plans, bringing real-time, threaded conversations directly into tasks, including @ mentions, rich formatting, emojis, and notifications to help keep decisions tied to the specific task at hand. Plan members who are @ mentioned in a task will receive a notification in their Teams Activity feed and via email and can select the notification which takes them directly to the task card for additional context. Note that previously, users received notifications for every task comment, but as a result of customer feedback, we now only send notifications to mentioned users. The ability to @ mention team members directly in a task has been a top request, and we’re excited to roll this out in a familiar, chat-based experience. Please note, premium plans will continue to utilize the existing task conversation experience. This will converge into the new experience at a later point in time. Goals view: Basic plans will now include a dedicated Goals view, allowing teams to set clear, well-defined objectives to help prioritize work. By connecting tasks to shared goals, teams achieve greater alignment, gain clarity on priorities, and track progress and outcomes—driving the plan forward together. Access to Goals view in basic plans requires either a Planner premium license or a Microsoft 365 Copilot license. Notes on availability Please note that not all users will see the new Planner interface at the same time. This refreshed interface, along with Task chat and Goals view, begins rolling out to basic plans today and will continue to roll out over the coming weeks. This is only the beginning This redesign lays the groundwork for many more improvements coming to Planner in the next few weeks and months, including: Project Manager agent in basic plans – to help with task execution and the creation of status reports. Custom templates. Planner in Outlook. Stay tuned for announcements regarding these updates and more aligned to our long-term vision for integrated work management. Feature availability, naming, and timelines are subject to change. Please refer to the Microsoft 365 Roadmap for the latest status. Addressing your feedback We heard your feedback about inconsistencies between basic and premium plans. This refresh starts closing those gaps, so features appear consistently across plans based on your license. For example, users with a Planner premium license will now see Goals in basic plans, and users with a Microsoft 365 Copilot license will soon have access to Project Manager Agent in basic plans as well. Tell us what you think about the new Planner interface, Task chat, and Goals view by selecting More (circled question mark icon) in the top right corner of the app, then selecting Feedback from the dropdown menu. We also encourage you to share any feature requests by adding your ideas to the Planner Feedback Portal. Your feedback helps inform our feature updates, and we look forward to hearing from you. Learn more Visit planner.cloud.microsoft to access Planner directly from your browser. Sign up to receive future communication about Planner. Learn more about Planner in our Frequently asked questions. Check out the Planner adoption page and Planner help & learning page to learn more about Planner. Visit the Microsoft 365 roadmap for feature descriptions and estimated release dates for Planner. Walk through the interactive demos for Project Manager Agent in Planner and Project Manager Agent skills in Teams meetings.44KViews9likes121CommentsMicrosoft Sentinel data lake FAQ
Microsoft Sentinel data lake (generally available) is a purpose‑built, cloud‑native security data lake. It centralizes all security data in an open format, serving as the foundation for agentic defense, enhanced security insights, and graph-based enrichment. It offers cost‑effective ingestion, long‑term retention, and advanced analytics. In this blog we offer answers to many of the questions we’ve heard from our customers and partners. General questions What is the Microsoft Sentinel data lake? Microsoft has expanded its industry-leading SIEM solution, Microsoft Sentinel, to include a unified, security data lake, designed to help optimize costs, simplify data management, and accelerate the adoption of AI in security operations. This modern data lake serves as the foundation for the Microsoft Sentinel platform. It has a cloud-native architecture and is purpose-built for security—bringing together all security data for greater visibility, deeper security analysis, contextual awareness and agentic defense. It provides affordable, long-term retention, allowing organizations to maintain robust security while effectively managing budgetary requirements. What are the benefits of Sentinel data lake? Microsoft Sentinel data lake is purpose built for security offering flexible analytics, cost management, and deeper security insights. Sentinel data lake: Centralizes security data delta parquet and open format for easy access. This unified data foundation accelerates threat detection, investigation, and response across hybrid and multi-cloud environments. Enables data federation by allowing customers to access data in external sources like Microsoft Fabric, ADLS and Databricks from the data lake. Federated data appears alongside native Sentinel data, enabling correlated hunting, investigation, and custom graph analysis across a broader digital estate. Offers a disaggregated storage and compute pricing model, allowing customers to store massive volumes of security data at a fraction of the cost compared to traditional SIEM solutions. Allows multiple analytics engines like Kusto, Spark, and ML to run on a single data copy, simplifying management, reducing costs, and supporting deeper security analysis. Integrates with GitHub Copilot and VS Code empowering SOC teams to automate enrichment, anomaly detection, and forensic analysis. Supports AI agents via the MCP server, allowing tools like GitHub Copilot to query and automate security tasks. The MCP Server layer brings intelligence to the data, offering Semantic Search, Query Tools, and Custom Analysis capabilities that make it easier to extract insights and automate workflows. Provides streamlined onboarding, intuitive table management, and scalable multi-tenant support, making it ideal for MSSPs and large enterprises. The Sentinel data lake is designed for security workloads, ensuring that processes from ingestion to analytics meet evolving cybersecurity requirements. Is Microsoft Sentinel SIEM going away? No. Microsoft is expanding Sentinel into an AI powered end-to-end security platform that includes SIEM and new platform capabilities - Security data lake, graph-powered analytics and MCP Server. SIEM remains a core component and will be actively developed and supported. Getting started What are the prerequisites for Sentinel data lake? To get started: Connect your Sentinel workspace to Microsoft Defender prior to onboarding to Sentinel data lake. Once in the Defender experience see data lake onboarding documentation for next steps. Note: Sentinel is moving to the Microsoft Defender portal and the Sentinel Azure portal will be retired by March 31, 2027. I am a Sentinel-only customer, and not a Defender customer. Can I use the Sentinel data lake? Yes. You must connect Sentinel to the Defender experience before onboarding to the Sentinel data lake. Microsoft Sentinel is generally available in the Microsoft Defender portal, with or without Microsoft Defender XDR or an E5 license. If you have created a log analytics workspace, enabled it for Sentinel and have the right Microsoft Entra roles (e.g. Global Administrator + Subscription Owner, Security Administrator + Sentinel Contributor), you can enable Sentinel in the Defender portal. For more details on how to connect Sentinel to Defender review these sources: Microsoft Sentinel in the Microsoft Defender portal In what regions is Sentinel data lake available? For supported regions see: Geographical availability and data residency in Microsoft Sentinel | Azure Docs. Is there an expected release date for Microsoft Sentinel data lake in GCC, GCC-H, and DoD? While the exact date is not yet finalized, we plan to expand Sentinel data lake to the US Government environments. . How will URBAC and Entra RBAC work together to manage the data lake given there is no centralized model? Entra RBAC will provide broad access to the data lake (URBAC maps the right permissions to specific Entra role holders: GA/SA/SO/GR/SR). URBAC will become a centralized pane for configuring non-global delegated access to the data lake. For today, you will use this for the “default data lake” workspace. In the future, this will be enabled for non-default Sentinel workspaces as well – meaning all workspaces in the data lake can be managed here for data lake RBAC requirements. Azure RBAC on the Log Analytics (LA) workspace in the data lake is respected through URBAC as well today. If you already hold a built-in role like log analytics reader, you will be able to run interactive queries over the tables in that workspace. Or, if you hold log analytics contributor, you can read and manage table data. For more details see: Roles and permissions in the Microsoft Sentinel platform | Microsoft Learn Data ingestion and storage How do I ingest data into the Sentinel data lake? To ingest data into the Sentinel data lake, you can use existing Sentinel data connectors or custom connectors to bring data from Microsoft and third-party sources. Data can be ingested into the analytics tier or the data lake tier. Data ingested into the analytics tier is automatically mirrored to the lake (at no additional cost). Alternatively, data that is not needed in the analytics tier can be ingested directly into the data lake. Data retention is configured directly in table management, for both analytics retention and data lake storage. Note: Certain tables do not support data lake-only ingestion via either API or data connector UI. See here for more information: Custom log tables. What is Microsoft’s guidance on when to use analytics tier vs. the data lake tier? Sentinel data lake offers flexible, built-in data tiering (analytics and data lake tiers) to effectively meet diverse business use cases and achieve cost optimization goals. Analytics tier: Is ideal for high-performance, real-time, end-to-end detections, enrichments, investigation and interactive dashboards. Typically, high-fidelity data from EDRs, email gateways, identity, SaaS and cloud logs, threat intelligence (TI) should be ingested into the analytics tier. Data in the analytics tier is best monitored proactively with scheduled alerts and scheduled analytics to enable security detections Data in this tier is retained at no cost for up to 90 days by default, extendable to 2 years. A copy of the data in this tier is automatically available in the data lake tier at no extra cost, ensuring a unified copy of security data for both tiers. Data lake tier: Is designed for cost-effective, long-term storage. High-volume logs like NetFlow logs, TLS/SSL certificate logs, firewall logs and proxy logs are best suited for data lake tier. Customers can use these logs for historical analysis, compliance and auditing, incident response (IR), forensics over historical data, build tenant baselines, TI matching and then promote resulting insights into the analytics tier. Customers can run full Kusto queries, Spark Notebooks and scheduled jobs over a single copy of their data in the data lake. Customers can also search, enrich and promote data from the data lake tier to the analytics tier for full analytics. For more details see documentation. What does it mean that a copy of all new analytics tier data will be available in the data lake? When Sentinel data lake is enabled, a copy of all new data ingested into the analytics tier is automatically duplicated into the data lake tier. This means customers don’t need to manually configure or manage this process, every new log or telemetry added to the analytics tier becomes instantly available in the data lake. This allows security teams to run advanced analytics, historical investigations, and machine learning models on a single, unified copy of data in the lake, while still using the analytics tier for real-time SOC workflows. It’s a seamless way to support both operational and long-term use cases—without duplicating effort or cost. What is the guidance for customers using data federation capability in Sentinel data lake? Starting April 1, 2026, federate data from Microsoft Fabric, ADLS, and Azure Databricks into Sentinel data lake. Use data federation when data is exploratory, infrequently accessed, or must remain at source due to governance, compliance, sovereignty, or contractual requirements. Ingest data directly into Sentinel to unlock full SIEM capabilities, always-on detections, advanced automation, and AI‑driven defense at scale. This approach lets security teams start where their data already lives — preserving governance, then progressively ingest data into Sentinel for full security value. Is there any cost for retention in the analytics tier? Analytics ingestion includes 90 days of interactive retention, at no additional cost. Simply set analytics retention to 90 days or less. Analytics retention beyond 90 days will incur a retention cost. Data can be retained longer within the data lake by using the “total retention” setting. This allows you to extend retention within the data lake for up to 12 years. While data is retained within the analytics tier, there is no charge for the mirrored data within the lake. Retaining data in the lake beyond the analytics retention period incurs additional storage costs. See documentation for more details: Manage data tiers and retention in Microsoft Sentinel | Microsoft Learn What is the guidance for Microsoft Sentinel Basic and Auxiliary Logs customers? If you previously enabled Basic or Auxiliary Logs plan in Sentinel: You can view Basic Logs in the Defender portal but manage it from the Log Analytics workspace. To manage it in the Defender portal, you must change the plan from Basic to Analytics. Once the table is transitioned to the analytics tier, if desired, it can then be transitioned to the data lake. Existing Auxiliary Log tables will be available in the data lake tier for use once the Sentinel data lake is enabled. Billing for these tables will automatically switch to the Sentinel data lake meters. Microsoft Sentinel customers are recommended to start planning their data management strategy with the data lake. While Basic and Auxiliary Logs are still available, they are not being enhanced further. Sentinel data lake offers more capabilities at a lower price point. Please plan on onboarding your security data to the Sentinel data lake. Azure Monitor customers can continue to use Basic and Auxiliary Logs for observability scenarios. What happens to customers that already have Archive logs enabled? If a customer has already configured tables for Archive retention, existing retention settings will not change and will be automatically inherited by the Sentinel data lake. All data, including existing data in archive retention will be billed using the data lake storage meter, benefiting from 6x data compression. However, the data itself will not move. Existing data in archive will continue to be accessible through Sentinel search and restore experiences: o Data will not be backfilled into the data lake. o Data will be billed using the data lake storage meter. New data ingested after enabling the data lake: o Will be automatically mirrored to the data lake and accessible through data lake explorer. o Data will be billed using the data lake storage meter. Example: If a customer has 12 months of total retention enabled on a table, 2 months after enabling ingestion into the Sentinel data lake, the customer will still have access to 10 months of archived data (through Sentinel search and restore experiences), but access to only 2 months of data in the data lake (since the data lake was enabled). Key considerations for customers that currently have Archive logs enabled: The existing archive will remain, with new data ingested into the data lake going forward; previously stored archive data will not be backfilled into the lake. Archive logs will continue to be accessible via the Search and Restore tab under Sentinel. If analytics and data lake mode are enabled on table, which is the default setting for analytics tables when Sentinel data lake is enabled, all new data will be ingested into the Sentinel data lake. There will only be one storage meter (which is data lake storage) going forward. Archive will continue to be accessible via Search and Restore. If Sentinel data lake-only mode is enabled on table, new data will be ingested only into the data lake; any data that’s not already in the Sentinel data lake won’t be migrated/backfilled. Only data that was previously ingested under the archive plan will be accessible via Search and Restore. What is the guidance for customers using Azure Data Explorer (ADX) alongside Microsoft Sentinel? Some customers might have set up ADX cluster for their DIY lake setup. Customers can choose to continue using that setup and gradually migrate to Sentinel data lake for new data that they want to manage. The lake explorer will support federation with ADX to enable the customers to migrate gradually and simplify their deployment. What happens to the Defender XDR data after enabling Sentinel data lake? By default, Defender XDR tables are available for querying in advanced hunting, with 30 days of analytics tier retention included with the XDR license. To retain data beyond this period, an explicit change to the retention setting is required, either by extending the analytics tier retention or the total retention period. You can extend the retention period of supported Defender XDR tables beyond 30 days and ingest the data into the analytics tier. For more information see Manage XDR data in Microsoft Sentinel. You can also ingest XDR data directly into the data lake tier. See here for more information. A list of XDR advanced hunting tables supported by Sentinel are documented here: Connect Microsoft Defender XDR data to Microsoft Sentinel | Microsoft Learn. KQL queries and jobs Is KQL and Notebook supported over the Sentinel data lake? Yes, via the data lake KQL query experience along with a fully managed Notebook experience which enables spark-based big data analytics over a single copy of all your security data. Customers can run queries across any time range of data in their Sentinel data lake. In the future, this will be extended to enable SQL query over lake as well. Note: Triggering a KQL job directly via an API or Logic App is not yet supported but is on the roadmap. Why are there two different places to run KQL queries in Sentinel experience? Advanced hunting queries both XDR and analytics tables, with compute cost included. Data lake explorer only queries data in the lake and incurs a separate compute cost. Consolidating advanced hunting and KQL explorer user interfaces is on the roadmap. This will provide security analysts a unified query experience across both analytics and data lake tiers. Where is the output from KQL jobs stored? KQL jobs are written into existing or new custom tables in the analytics tier. Is it possible to run KQL queries on multiple data lake tables? Yes, you can run KQL interactive queries and jobs using operators like join or union. Can KQL queries (either interactive or via KQL jobs) join data across multiple workspaces? Security teams can run multi-workspace KQL queries for broader threat correlation Pricing and billing How does a customer pay for Sentinel data lake? Billing is automatically enabled at the time of onboarding based on Azure Subscription and Resource Group selections. Customers are then charged based on the volume of data ingested, retained, and analyzed (e.g. KQL Queries and Jobs). See Sentinel pricing page for more details. 2. What are the pricing components for Sentinel data lake? Sentinel data lake offers a flexible pricing model designed to optimize security coverage and costs. At a high level, pricing is based on the volume of data ingested/processed, the volume of data retained, and the volume of data processed. For specific meter definitions, see documentation. 3. How does the business model for Sentinel SIEM change with the introduction of the data lake? There is no change to existing Sentinel analytics tier ingestion business model. Sentinel data lake has separate meters for ingestion, storage and analytics. 4. What happens to the existing Sentinel SIEM and related Azure Monitor billing meters when a customer onboards to Sentinel data lake? When a customer onboards to the Sentinel data lake, nothing changes with analytic ingestion or retention. Customers using data archive and Auxiliary Logs will automatically transition to the new data lake meters. How does data lake storage affect cost efficiency for high volume data retention? Sentinel data lake offers cost-effective, long-term storage with uniform data compression of 6:1 across all data sources, applicable only to data lake storage. Example: For 600GB of data stored, you are only billed for 100GB compressed data. This approach allows organizations to retain greater volumes of security data over extended periods cost-effectively, thereby reducing security risks without compromising their overall security posture. here How “Data Processing” billed? To support the ingestion and standardization of diverse data sources, the Data Processing feature applies a $0.10 per GB (US East) charge for all data ingested into the data lake. This feature enables a broad array of transformations like redaction, splitting, filtering and normalization. The data processing charge is applied per GB of uncompressed data Note: For regional pricing, please refer to the “Data processing” meter within the Microsoft Sentinel Pricing official documentation. Does “Data processing” meter apply to analytics tier data mirrored in the data lake? No. Data processing charge will not be applied to mirrored data. Data mirrored from the analytic tier is not subject to either data ingestion or processing charges. How is retention billed for tables that use data lake-only ingestion & retention? Sentinel data lake decouples ingestion, storage, and analytics meters. Customers have the flexibility to pay based on how data is retained and used. For tables that use data lake‑only ingestion, there is no included free retention—unlike the analytics tier, which includes 90 days of analytics retention. Retention charges begin immediately once data is stored in the data lake. Data lake storage billing is based on compressed data size rather than raw ingested volume, which significantly reduces storage costs and delivers lower overall retention spend for customers. Does data federation incur charges? Data federation does not generate any ingestion or storage fees in Sentinel data lake. Customers are billed only when they run analytics or queries on federated data, with charges based on Sentinel data lake compute and analytics meters. This means customers pay solely for actual data usage, not mere connectivity. How do I understand Sentinel data lake costs? Sentinel data lake costs driven by three primary factors: how much data is ingested, how long that data is retained, and how the data is used. Customers can flexibly choose to ingest data into the analytics tier or data lake tier, and these architectural choices directly impact cost. For example, data can be ingested into the analytics tier—where commitment tiers help optimize costs for high data volumes—or ingested data directly into the Sentinel data lake for lower‑cost ingestion, storage, and on‑demand analysis. Customers are encouraged to work with their Microsoft account team to obtain an accurate cost estimate tailored to their environment. See Sentinel pricing page to understand Sentinel pricing. How do I manage Sentinel data lake costs? Built-in cost management experiences help customers with cost predictability, billing transparency, and operational efficiency. Reports provide customers with insights into usage trends over time, enabling them to identify cost drivers and optimize data retention and processing strategies. Set usage-based alerts on specific meters to monitor and control costs. For example, receive alerts when query or notebook usage passes set limits, helping avoid unexpected expenses and manage budgets. See our Sentinel cost management documentation to learn more. If I’m an Auxiliary Logs customer, how will onboarding to the Sentinel data lake affect my billing? Once a workspace is onboarded to Sentinel data lake, all Auxiliary Logs meters will be replaced by new data lake meters. Do we charge for data lake ingestion and storage for graph experiences? Microsoft Sentinel graph-based experiences are included as part of the existing Defender and Purview licenses. However, Sentinel graph requires Sentinel data lake and specific data sources to build the underlying graph. Enabling these data sources will incur ingestion and data lake storage costs. Note: For Sentinel SIEM customers, most required data sources are free for analytics ingestion. Non-entitled sources such as Microsoft Entra ID logs will incur ingestion and data lake storage costs. How is Entra asset data and ARG data billed? Data lake ingestion charges of $0.05 per GB (US EAST) will apply to Entra asset data and ARG data. Note: This was previously not billed during public preview and is billed since data lake GA. To learn more, see: https://learn.microsoft.com/azure/sentinel/datalake/enable-data-connectors When a customer activates Sentinel data lake, what happens to tables with archive logs enabled? To simplify billing, once the data lake is enabled, all archive data will be billed using the data lake storage meter. This provides consistent long-term retention billing and includes automatic 6x data compression. For most customers, this change results in lower long‑term retention costs. However, customers who previously had discounted archive retention pricing will not automatically receive the same discounts on the new data lake storage meters. In these cases, customers should engage their Microsoft account team to review pricing implications before enabling the Sentinel data lake. Thank you Thank you to our customers and partners for your continued trust and collaboration. Your feedback drives our innovation, and we’re excited to keep evolving Microsoft Sentinel to meet your security needs. If you have any questions, please don’t hesitate to reach out—we’re here to support you every step of the way. Learn more: Get started with Sentinel data lake today: https://aka.ms/Get_started/Sentinel_datalake Microsoft Sentinel AI-ready platform: https://aka.ms/Microsoft_Sentinel Sentinel data lake videos: https://aka.ms/Sentineldatalake_videos Latest innovations and updates on Sentinel: https://aka.ms/msftsentinelblog Sentinel pricing page: https://aka.ms/MicrosoftSentinel_Pricing6.3KViews1like9CommentsWhat's new in Microsoft Teams | May 2026 - Build Edition
It's hard to believe May is over already! You may have noticed this edition of What's new in Teams is landing a few days later than usual — that's intentional. We're publishing alongside Microsoft Build, our annual developer conference where we showcase the latest in AI, agents, and the tools that help developers. It's one of the most energizing weeks of the year, full of announcements, hands-on sessions, and a first look at where the platform is headed. A lot of what's in this release ties directly to what's being unveiled on the Build stage, and I wanted to highlight a few Teams Platform features worth calling out: Linear, Cursor, and Atlassian Rovo agents in Teams — three powerful new partner agents that turn channel conversations into shipped code, filed issues, and updated project plans without ever leaving the chat. New Teams CLI — one command to register, configure, and deploy a Teams agent, so developers can spend their time on agent logic instead of managing complex processes Collaborative features for agents – our new agent capabilities include quoted replies to keep conversations anchored, slash commands to quickly take action in the flow of work, and expressive emoji reactions that add nuance without adding noise, all helping teams stay aligned and move faster in collaboration with agents. A few other highlights I'm especially excited about beyond Platform: New AI-generated Video recap in Teams turns meeting recordings into short, narrated highlight reels—so you can quickly catch up on what matters most without watching the full session. In Teams Phone, Brand Impersonation Protection alerts you in real time when a caller may be posing as a trusted brand like your bank or IT helpdesk, so you can decline or report the call with confidence. These are just a taste of what's new. Read on to see everything we've released in May across chat, meetings, phone, rooms, frontline, and more. Product areas covered in this update: (All features are generally available unless otherwise noted.) Teams Platform Chat and Collaboration Meetings Teams Phone Workplace - Places and Teams Rooms Fundamentals and Security Frontline workers Certified for Teams Devices Teams Platform Slash commands for agents- Public Preview Triggering an agent shouldn't break your flow. With slash commands, users can invoke agent actions, retrieve information, or kick off tasks directly from the compose box using simple "/" prompts — keeping agents one keystroke away in any chat or channel. Quoted replies for agents- Public Preview Threaded conversations are easier to follow when agents stay anchored to the right message. With quoted replies, your agent can now reference the exact message a user is responding to so context isn't lost as threads grow longer or branch into side discussions. Agents can also send quoted replies of their own, keeping multi-turn exchanges clear and traceable for everyone in the chat. Message Reactions for Agents – Public Preview Ever wish your agent could just give a thumbs-up instead of cluttering a thread with another reply? Now it can. Agents in Teams can now respond with emoji reactions the same way people do, matching the rhythm of the conversation with a lightweight signal instead of an extra message. Threads stay clean, exchanges feel more natural, and you get a clear acknowledgment without the noise. New Teams CLI Building an agent today means juggling registration, credentials, manifest creation, and deployment across multiple tools, slowing developers down before they even get to the interesting work. The new Teams CLI collapses all of it into a single command, working alongside coding agents to take a Teams agent from idea to running instance in minutes. By handling setup and diagnostics behind the scenes, developers can focus on agent logic instead of managing configuration complexity. Learn more here. Linear agent in Teams Software teams lose momentum every time a channel decision has to be manually translated into a Linear issue or project update. The Linear agent in Teams closes that gap by turning conversations directly into actionable work — creating issues, capturing context, and updating project workflows from inside the thread where the decision was made. The Linear agent is available now in the Microsoft Marketplace. Cursor agent in Teams Engineering work stalls every time you have to leave a Teams discussion to fix a bug or ship a feature in a separate tool. The Cursor agent in Teams keeps you in the flow: @mention it in any channel or chat to invoke Cursor's Cloud Agents directly inside the conversation, where it returns results with full context of the discussion. The result is a faster path from idea to production, without ever leaving Teams. The Cursor agent is available now in the Microsoft Marketplace. Atlassian Rovo agent in Teams Jumping between Teams, Jira, and Confluence to turn a chat decision into actual project work slows everyone down. The Atlassian Rovo agent in Teams brings AI-powered context and action across Jira, Confluence, and Teamwork Graph organizational data into your conversations — so you can go from a question in chat to creating Jira issues, drafting Confluence pages, and updating workflows in a single interaction. Rovo evolves Atlassian's previous Jira and Confluence apps into an orchestrating "uber agent" for Atlassian AI, now available in the Microsoft Marketplace. MCP servers/connectors discovery and connection UI from agent settings- Public Preview Connecting an agent to the right external system used to mean piecing together configurations from multiple places. Now, you can discover, connect, and manage MCP servers and connectors all from one unified experience inside agent settings in Teams — so it's faster and more secure to plug external data and services into agent workflows. App centric management in Teams Admin Center to manage the Apps access for tenants, end-users, and groups in GCC In GCC environments, controlling who can install which Teams apps used to require broad permission policies that didn't scale well as app catalogs grew. With app-centric management, GCC admins can now set defaults for newly published apps and decide app-by-app whether everyone, specific users and groups, or no one, can install them. Existing app permission policies are migrated automatically, so current availability stays intact. Visual enhancements in adaptive cards Agent responses used to feel flat, with long walls of text and little room for users to drill into the details that matter. New visual TableSet, Accordion, and Loop components let agent builders structure responses into navigable tabs, expandable sections, and repeating content so users can scan and act on information the same way they would in a polished app. Expanded action capabilities such as Popover and richer content support through references and Citations round out the experience. Organization evaluation score for apps and agents- Public Preview IT admins used to manually review trust data for Teams agents and apps in the admin center to verify security, privacy, and compliance standards. This new feature enables admins to define their company's approval requirements once; the system then automatically assesses apps and agents, generating an evaluation score and detailed report per agent/app. This speeds up decision-making by clearly surfacing which ones meet all company standards and which need further review. M365 Agents Toolkit and Developer Portal Support for Agents in Gov Clouds Developers building for regulated customers used to face a choice: ship in commercial cloud, or rebuild from scratch for government environments. Now, the Microsoft 365 Agents Toolkit and Developer Portal are expanding support for building agents in Government Community Cloud (GCC), GCC High (GCCH), and DoD — so the same solution can reach highly regulated organizations without redesign or re-architecture. M365 certification bulk management IT admins today have to enable trusted third-party apps one at a time in the Teams admin center, a slow and repetitive process when working across hundreds of apps. This feature evolves the org-wide third-party app setting from a simple ON/OFF toggle into a granular dropdown with a new "Allow only Microsoft 365 certified apps" option, letting admins turn on every Microsoft-certified app across their tenant in a single click. As apps earn or lose certification, the platform keeps availability in sync automatically — no ongoing manual upkeep. Observability features for A365 Agents in Teams- Public Preview As more A365 agents act on behalf of users in Teams, IT needs more than just visibility and control—they need to understand how those agents are operating in real time. These new observability capabilities provide deep insights into agent activity, usage, performance, and interactions across Teams and the Microsoft 365 Copilot Agent Store. By surfacing real-time metrics and governance signals, admins can monitor behavior, identify issues, and ensure agents are operating securely, compliantly, and effectively at scale. A365 agents on Teams mobile- Public Preview Bring AI agents with you wherever work happens. A365 agents are now available on Teams mobile in public preview, so you can discover, chat with, and add approved agents to conversations and meetings from your phone, the same way you would from desktop. From the Teams mobile app store, browse the "Agents for your team" category, request an agent, and start delegating tasks on the go after admin approval. Enhanced Teams Store- Public Preview Finding the right agent in Teams just got easier, and knowing what it does is now instant. The enhanced Teams Agents & Apps Store solves both problems. Smarter search surfaces helpful suggestions that appear the moment you open the search box, and results update instantly as you type. Once you find what you're looking for, redesigned tiles, clickable sample prompts, and a personalized "Your Agents & Apps" view make it easy to evaluate an agent and put it to work right away. Chat and Collaboration Create workflows with slash commands Jumping out of a chat to update your status or schedule a message breaks your concentration just when you're trying to get something done. Now, you can stay in the compose box using slash commands. Type / on an empty line to interact with apps and agents, create and manage workflows, or run Teams actions like /busy, /goto, or /schedulemessage. Whether you're inserting a GIF or managing workflows, slash commands offer a consistent and efficient way to get things done without leaving your flow. Improved code readability with line numbers Pointing teammates to "the third line from the bottom" gets old fast when you're reviewing code in a chat. Teams now displays automatic line numbers in code blocks so you can reference specific lines naturally in reviews and discussions, and enhanced keyboard navigation lets you move through code without reaching for the mouse. Badging updates help find messages that count in the chat list That little badge on your Teams app icon tells you something needs attention, but tracking down exactly which message is driving it can take longer than you'd like. Now, unmuted chats show a purple indicator when they affect the badge. In addition, mentions, followed threads, and tag mentions display a purple number showing how many unread items are part of the count. Catch up on Teams conversations on mobile Catch up on everything that needs your attention in a single, unified view. Each conversation appears on its own swipeable card with full context and all the actions you need - reply, react, save, mark read/unread, follow/unfollow - to complete your triage. Simply tap the Catch up button at the top of your chat list to get started and get swiping! Learn more about Catch up. Quick access to read items from unread-only mode Unread-only mode keeps your chat list focused on what needs attention, but sometimes you still need to find a message you read earlier. Now, hovering over any section in unread-only view reveals an eye icon that opens a list of read chats and channels for that section, without leaving your unread view. Instant search results when typing in Teams Find in chat and channel Hitting Enter, scanning results, refining your query, and trying again is a slow way to find a message. Find in chat and Find in channel now show results instantly as you type, so you can refine on the fly and get to the right message faster. Advanced filters in Teams Find in chat and channel When the right message is buried under hundreds of others, scrolling isn't a search strategy. New filters in Find in chat and Find in channel let you narrow results by sender, date, attachments, or mentions directly from the right rail — accessible via Ctrl+F (Windows), Cmd+F (Mac), or the Find icon in any chat or channel header. Teams honors the Windows Do not disturb setting Setting Windows to Do not disturb but still getting pinged by Teams defeats the whole point of focus time. Teams integrates with the Do not disturb setting in Windows to help reduce interruptions during focused work. Teams notifications are paused when the Windows Do not disturb setting is turned on, and resume after it is turned off. Meetings Video recap Catching up on meetings just got a whole lot faster. Video recap turns your recorded Teams meetings into short, narrated highlight reels, pairing an AI-generated voiceover with real clips of the key moments, decisions, and shared visuals from the conversation. Whether you missed a meeting or just want to revisit the most important parts, video recap helps you quickly grasp the flow, tone, and outcomes without scrubbing through the full recording. Available to Microsoft 365 Copilot–licensed users on Teams for Windows, Mac, and the web, for recorded English-language meetings between 10 and 90 minutes. Ability to delete recap Cleaning up after a sensitive meeting used to mean deleting recording, transcript, AI summary, and notes from separate places, or asking an admin for help. Organizers can now delete all of it in one place from the recap page's More (…) menu. Shared files stay put in their original locations. It's a quick, confident way to support your retention practices — no admin setup required. Teams Phone Brand Impersonation Protection in Microsoft Teams Calling Stay one step ahead of scammers. Teams now detects and warns you when a caller may be impersonating a trusted brand—like your IT helpdesk, bank, or Microsoft Support—before you engage. When a potential threat is detected, you'll see an in-call alert with clear identity signals (such as "Scam suspected"), empowering you to decline, leave, or report the call instantly. No extra tools needed—protection is built right into your calling experience. It's proactive security that keeps your credentials, data, and organization safe without disrupting your workflow. Report a Suspicious Call in Teams Suspicious calls used to be easy to hang up on but hard to actually do anything about. Users can now report calls that appear unusual or suspicious directly in the Calls app history. After selecting, “Report call”, in the call’s additional options, users can add a reason to the report and have the option to block the caller. When a call is reported, the signal helps strengthen Microsoft’s detection systems to reduce future unwanted or malicious activity. By making it easy to report in the moment, users can contribute to ongoing threat protection while helping improve overall call security across the organization. Queues app for Teams Mobile Customer-facing employees can't always sit at a desk all day, but stepping away used to mean dropping out of the queue and missing calls. The Queues app — with advanced queue management and collaborative calling — is now supported on Teams mobile, so information workers like bank tellers or IT help desk representatives can stay opted in, review recent calls, and return missed customer calls from their phone. The result: faster response, fewer missed opportunities, and a more consistent customer experience away from the desk. Consult and merge a PSTN caller through DTMF Need to consult a subject matter expert in a private conversation before merging them into a meeting, but they're behind an auto attendant phone menu? Now you can. Meeting organizers can consult and merge PSTN callers into active Teams meetings, even when reaching them requires navigating Dual-Tone Multi-Frequency (DTMF) menus, so the right person joins the conversation without delays or call drops. Workplace - Places and Teams Rooms Enhanced media quality for Direct Guest Join in Teams Rooms on Windows You’ll notice media quality improvements including support for up to 16 participant videos (4×4 grid) available in May and simulcast streaming (June) when using Direct Guest Join. These updates make cross-platform meetings more immersive and reliable when joining Teams meetings from Zoom, Google Meet, or Cisco devices. Learn more. Miracast support for Teams Rooms on Windows devices including touch boards Cables and connectors slow down meetings, especially in flex spaces where guests and visitors need to share quickly. Teams Rooms on Windows all-in-one touch boards, now support Miracast for cable-free wireless screen mirroring alongside Teams Cast and HDMI ingest. Walk in, mirror your screen, present. Available with Teams Rooms Pro. Learn more. Multi-camera view support for GCC-H and DoD in Teams Rooms on Windows Remote participants in large rooms often miss what's happening because they're stuck looking at a single, fixed camera angle. GCC-H and DoD cloud customers can now use multi-camera views in Microsoft Teams Rooms on Windows, allowing remote participants to switch between multiple in-room camera feeds for improved visibility and engagement in larger spaces. Find camera requirements here. Available with Teams Rooms Pro. Learn more. Multi-stream IntelliFrame support for GCC-H and DoD in Teams Rooms on Windows In hybrid meetings, remote attendees often see in-room participants in a single distant frame— making it hard to read faces and engage. Multi-stream IntelliFrame, now available for GCC-H and DoD customers in Teams Rooms on Windows, sends a separate video feed of each in-room participant for far more inclusive hybrid conversations. Requires a compatible intelligent camera. Available with Teams Rooms Pro. Learn more. Book future meetings directly from Teams panels You can now make an upcoming meeting reservation from a Teams panel by browsing the calendar on the device and choosing any open time slot through midnight the next day. Add a guest during booking streamlining ad-hoc scheduling and coordination. Available with Teams Rooms Pro and Shared Device licenses. Learn more. Enhanced issue detection in Teams Rooms on Windows and auto-remediation with Teams Rooms Pro Management To minimize delays due to equipment issues, Teams Rooms on Windows proactively monitors room audio, video, and display signals to detect issues in meeting spaces. Teams Rooms Pro Management automatically remediates common issues that can be resolved through software, configuration changes, or device resets during nightly maintenance. This ensures users have reliable, ready-to-use meeting rooms, while IT admins benefit from reduced manual troubleshooting and increased uptime. Available for Teams Rooms Pro-licensed rooms. Learn more. Room health signals and notifications in Teams Rooms on Windows When critical issues impact room functionality, meetings can be delayed or derailed. Room health signals now trigger display of a banner notification on both the front-of-room display and console in Teams Rooms on Windows. Room health signals help get issues resolved quickly and ensure productive meetings. Available with Teams Rooms Pro. Learn more. Expanded access to the AI Assistant for all roles in the Teams Rooms Pro Management portal Admins now have broader access to the AI Assistant in the Teams Rooms Pro Management portal, no longer limited to global admin roles. Using role-based access controls (RBAC), admins see only rooms and devices they manage, improving visibility and support while adhering to security policies. Learn more. Fundamentals and Security Agent metadata visibility in Teams Admin Center Approving an AI agent for the organization used to mean piecing together what it could actually do from multiple places. IT admins can now view detailed agent metadata — capabilities, knowledge sources, and allowed actions — directly in the Teams Admin Center before approving or enabling agents. With this visibility centralized in one place, admins can understand what kind of agent they are approving and broaden rollout once they're certain agents meet their security and compliance standards. User-Reported Teams Message Security Signals in the Teams Admin Center Users flag suspicious messages every day, but those signals used to be hard for IT to act on at scale. Admins can now monitor user-reported security signals directly in the Teams Admin Center through the Security Message Violation report, surfacing flagged messages and false-positive reports in one centralized view, so security controls can be tuned to real-world threat exposure without leaving the admin center. Account switching for native Mac controls via dock and menu bar Juggling work, guest, and tenant accounts in Teams on Mac used to mean opening the full app every time you needed to switch. Now, account and tenant switching controls live directly in the macOS dock and menu bar — exactly where Mac users expect them — so toggling between organizations or accounts takes one click. Frontline workers Explore our learn docs for more information on all of our Teams for frontline solutions. Guided setup for Frontline Rolling Teams out to thousands of frontline workers used to mean stitching together onboarding, team structure, and pinned-app policies across multiple tools. Guided setup in the Teams Admin Center now walks admins through all of it in one place — making it easier to expand pilots, keep app layouts uniform, and track adoption with built-in insights. Learn more in the official documentation here or sign up here to explore additional deployment capabilities in private preview. Automatically fill open shifts with Smart Scheduling Smart scheduling in Shifts takes the manual effort out of building frontline schedules. Managers can automatically assign open shifts based on employee availability, scheduled time off, constraints such as maximum weekly or daily hours, and historical data about what shifts people usually work. Simply create open shifts for the required number of positions, select "Assign open shifts," and let Teams find the best match for each slot. Any shifts that can't be filled automatically are flagged for manual review, so managers stay in control while saving significant time. The result: faster, fairer schedules with less effort for managers and frontline workers alike. Deliver operational updates with the Communicator app Critical updates for frontline workers — safety alerts, training reminders, outage notifications — often get lost in long channel threads or scattered across other apps. The Communicator app in Microsoft Teams enables operations teams to deliver structured, actionable updates directly within the channels frontline workers already use. Whether sharing safety alerts, training reminders, or outage notifications, teams can publish consistent, easy-to-act-on messages, track delivery and engagement, and communicate seamlessly without requiring additional apps or workflow changes. Sign up for the limited public preview: aka.ms/CommunicatorApp Run hands-free site walkthroughs with voice in Frontline Agent Typing inspection notes on a phone while walking a site is slow, error-prone, and can be a safety risk. Frontline Agent enables voice-driven site walkthroughs, allowing workers to complete inspections, capture issues, and document compliance tasks using natural speech. Inputs are automatically transcribed into structured digital records, reducing manual data entry, speeding up reporting, and ensuring critical insights from the field are consistently captured. Sign up for the limited public preview: aka.ms/SiteWalkthrough Certified for Teams Devices Barco ClickShare Hub Core with Logitech Meetup 2 The ClickShare Hub Core and Logitech MeetUp 2 bundle is a solution certified for Microsoft Teams Rooms designed for small meeting rooms. ClickShare Hub Core enables one-click, wireless conferencing and 4K content sharing with one next-gen ClickShare Button (featuring Wi-Fi 6E and USB-C DisplayPort™). Built on the Microsoft Device Ecosystem Platform (MDEP), it’s designed to deliver a secure meeting experience. The widely recognized Logitech MeetUp 2 video bar delivers USB-connected high-quality audio and video with AI-enhanced performance. For meeting participants, this bundle ensures intuitive and engaging meetings. For IT managers, it pairs ease of installation and eco-friendliness with enterprise-grade security, compliance, and standardized integration. Learn more Jabra Scheduler Jabra Scheduler is a smart, professional room scheduling panel that makes finding and booking meeting rooms fast. With an integrated lightbar and intuitive touchscreen, it’s certified for Microsoft Teams. Easy to deploy, simple to scale, and built to unlock more productive meetings across your workplace. Learn more Neat Pad Pro Neat Pad Pro elevates how meetings come together. As a meeting room controller or scheduling display, it gives teams effortless command and IT a simple, scalable way to manage rooms. With a 10-inch touchscreen, built-in microphones, and intelligent processing, it enhances audio, sharpens control, and improves accessibility—so meetings run more smoothly and sound clearer. Learn more Jabra Speak2 40 Built for hybrid workers who take meetings from anywhere, the Jabra Speak2 40 delivers true full-duplex audio with a 50mm speaker, wideband sound, and four advanced beamforming microphones — connecting via either USB-C or USB-A on the same cable. Learn more. Owl Labs Meeting Owl 5 Pro The Meeting Owl 5 Pro is redefining the center-of-table experience by making hybrid meetings simpler and smarter than ever. Our next-gen camera, speaker, and microphone device powers enterprise-grade hybrid meetings with an easy-to-use BYOD solution. It combines 360-degree 4K video with award-winning automatic speaker-switching software to enable effective hybrid collaboration in any space. Features native HDMI and Ethernet ports for a seamless single-cable BYOD experience built with security and reliability in mind. Compatible with all video conferencing platforms, including Microsoft Teams, Zoom, and many others. Learn more.4.8KViews0likes0CommentsSentinel Foundry - MCP Server (Preview) (Github Community Release)
I’ve been cooking something that a lot of people in SOC have been struggling with — especially on the engineering side of Microsoft Sentinel. Thanks to the Microsoft Security team for shaping the capabilities of Sentinel even better with Sentinel Data Lake & Modern SecOps. Today’s the day I can finally share it. Note: This is not an official Microsoft product, but it is designed to make the Sentinel Build even better (complement) with much more intelligence. 🚀 Sentinel Foundry is now in public preview with 43 tools. (Sentinel Foundry - MCP Server) It’s an MCP server built to act like the brain of a strong Sentinel engineer — helping make building, improving, and operating Sentinel far more practical, faster, and honestly more enjoyable. For a lot of teams, the challenge is not understanding what Sentinel can do. The hard part is the engineering work around it: -> Deciding what data should actually be ingested -> Building a clean, scalable Sentinel foundation -> Writing useful detections instead of noisy ones -> Balancing security value with cost -> Turning ideas into deployable engineering outputs That is exactly why I built Sentinel Foundry to help communities grow stronger. It helps with the real engineering tasks behind Sentinel — from architecture thinking to detection design, deployment planning, ingestion strategy, automation ideas, and many of the workflows outlined in the GitHub project. How does it work? Here’s one of the flagship prompts I ran with it: “Give me a complete security posture report for our workspace. Score each pillar and tell me what to prioritise.” And within seconds, it produced a structured engineering blueprint that would normally take a lot longer to pull together manually. You can see the example prompts here in what it can do: https://github.com/prabhukiranveesam/Sentinel-Foundry#what-can-it-do I want building Sentinel to feel less like repetitive engineering overhead — and more like real security engineering that is fast, creative, and enjoyable. If you work with Sentinel as a SOC L2 analyst, engineer, detection engineer, consultant, or architect, I’d genuinely love for you to try it and tell me what you think. 🔗 Public Preview: https://github.com/prabhukiranveesam/Sentinel-Foundry This is just the start of an AI era — and I’m excited to keep shaping it with more powerful features over the coming days. This is very easy to set up and will be available to all of you at no cost during this month as part of the public preview, and your feedback is extremely valuable to shape this as a powerful solution.518Views0likes1CommentDetecting AI agents and non-human identities in Microsoft Sentinel: the classic-agent blind spot
Build 2026 made the direction official. The industry is moving from the app era into the agent era, and Microsoft spent a real share of the keynote on securing agents across their lifecycle, from discovering what is exploitable to governing what is running in production. On the identity side the centerpiece is Microsoft Entra Agent ID, now generally available, which gives AI agents first-class identities and extends Conditional Access, Identity Protection, and full audit logging to them. That is good news for agents you build the new way. It is not the whole picture, and the gap is where most SOCs will get hurt first. Modern agents are covered. Classic agents are not. Entra Agent ID draws a hard line between two kinds of agent. Modern agents are created through the Agent ID platform, each backed by an agent identity blueprint. They carry a proper Agent ID, a full audit trail, and the complete set of governance capabilities, including Identity Protection for Agents, which establishes a baseline for an agent's normal activity and flags anomalies automatically. Classic agents are everything that came before, or that gets built outside the platform: AI agents implemented as ordinary service principals or app registrations, for example Copilot Studio agents created before Agent ID was enabled, or any home-grown automation calling Graph with client credentials. In the Entra agent registry they appear with "Has Agent ID: No," and that flag matters, because the Agent ID protections apply to identities that actually hold an Agent ID. Classic agents sit outside Identity Protection for Agents and Conditional Access for Agents. Here is the uncomfortable part. The non-human identities you already run, the service principals behind your pipelines, your integrations, your scripts, your pre-platform Copilot Studio bots, are almost all classic agents. They tend to outnumber your human accounts, they have no MFA in any meaningful sense, and a credential added to one does not show up in the Azure portal. The new platform protections do not reach them. Until you migrate them, the only place you get detection coverage on that population is your SIEM. So this is the job Sentinel does that Agent ID does not: detect risky behavior on the classic, service-principal-backed agents that the platform cannot yet protect. The telemetry you have, and the one switch people forget Three tables carry most of the signal. AADServicePrincipalSignInLogs records service principal authentications, the client-credentials sign-ins your agents and automation use. No user, no MFA, just an app proving it holds a secret or certificate. AADManagedIdentitySignInLogs does the same for managed identities. AuditLogs records directory changes, including the one that matters most for persistence: a new credential added to an application or service principal. One practical warning before any of this works. Service principal and managed identity sign-in logs are not streamed by default. You have to enable those categories explicitly in the Entra diagnostic settings feeding your workspace. Plenty of teams write the detection, never check, and never notice the table is empty. Verify that first. Detection 1: a new credential on a service principal or app Adding a secret or certificate to an existing service principal is one of the cleanest persistence techniques in a Microsoft cloud. The attacker compromises a privileged user or app, drops a fresh credential on a service principal that already holds useful Graph permissions, and now has access that survives password resets and session revocation. It maps to MITRE T1098.001, Account Manipulation: Additional Cloud Credentials. For a classic agent it is especially nasty, because there is no Identity Protection baseline watching it. // Detection 1: new secret or certificate added to an application or service principal // MITRE T1098.001 - Account Manipulation: Additional Cloud Credentials AuditLogs | where OperationName has_any ("Add service principal", "Certificates and secrets management") | where Result =~ "success" | extend Initiator = coalesce( tostring(InitiatedBy.user.userPrincipalName), tostring(InitiatedBy.app.displayName)) | extend InitiatorIp = tostring(InitiatedBy.user.ipAddress) | mv-apply Target = TargetResources on ( where Target.type =~ "Application" | extend TargetName = tostring(Target.displayName), TargetId = tostring(Target.id), KeyChanges = Target.modifiedProperties ) | mv-apply Prop = KeyChanges on ( where tostring(Prop.displayName) =~ "KeyDescription" | extend NewKeys = parse_json(tostring(Prop.newValue)), OldKeys = parse_json(tostring(Prop.oldValue)) ) | extend AddedKeys = set_difference(NewKeys, OldKeys) | where array_length(AddedKeys) > 0 | project TimeGenerated, Initiator, InitiatorIp, TargetName, TargetId, AddedKeys | order by TimeGenerated desc The operation filter catches the three shapes this event takes in the log: "Add service principal," "Add service principal credentials," and "Update application - Certificates and secrets management." The modifiedProperties parsing isolates the KeyDescription change, and set_difference confirms a key was actually added rather than removed, so rotating out an old credential does not, on its own, fire the rule. False positives come from legitimate rotation and from automation that provisions app credentials (CI/CD, infrastructure as code). The initiator is the discriminant. A credential added by your deployment pipeline's service account at the usual time is routine. The same change initiated by an interactive admin out of hours, or by an account that never normally touches app credentials, is what you want to surface. Allow-list the expected initiators, not the targets. Detection 2: a classic agent signing in from a first-seen IP A service principal that has only ever authenticated from your Azure regions and suddenly signs in from somewhere new is a strong signal that its credential has been lifted and is being used elsewhere. Service principals have stable, boring network behavior, which makes a first-seen IP a far cleaner indicator for them than it is for roaming human users. This is the behavioral baseline Identity Protection gives you for free on modern agents, rebuilt in KQL for the classic ones it ignores. MITRE T1078.004, Valid Accounts: Cloud Accounts. // Detection 2: classic-agent service principal signing in from a previously unseen IP // MITRE T1078.004 - Valid Accounts: Cloud Accounts let baseline = 14d; let detection = 1d; let KnownIPs = AADServicePrincipalSignInLogs | where TimeGenerated between (ago(baseline + detection) .. ago(detection)) | where tostring(ResultType) == "0" | summarize KnownIPSet = make_set(IPAddress) by AppId; AADServicePrincipalSignInLogs | where TimeGenerated > ago(detection) | where tostring(ResultType) == "0" | lookup kind=leftouter KnownIPs on AppId | where set_has_element(KnownIPSet, IPAddress) == false | summarize FirstSeen = min(TimeGenerated), Resources = make_set(ResourceDisplayName, 10) by ServicePrincipalName, AppId, IPAddress | order by FirstSeen desc The query builds a per-application baseline of source IPs over the previous two weeks, then flags any successful sign-in today from an address outside that set. Two tuning notes. Brand-new service principals have no baseline, so they surface on first use. That is usually worth seeing once, but you can exclude AppIds younger than the baseline window if it gets noisy. And if your agents egress through shifting cloud IP ranges, widen the comparison from an exact IP to the autonomous system number or a known-range allow-list, otherwise you will chase your own infrastructure. This complements Agent ID, it does not replace it! The endgame is not to run these rules forever. It is to shrink the population they apply to. Inventory your tenant for agents marked "Has Agent ID: No," prioritize the ones holding sensitive Graph permissions, and migrate them onto the Agent ID platform, where Identity Protection and Conditional Access take over the baselining you are doing here by hand. Microsoft has signaled a migration path from classic to modern agents. Treat these two detections as the coverage you need in the meantime, and as a permanent safety net for anything that never makes the move. If you do one thing this week: enable the service principal sign-in log category, deploy detection 1, and pull a list of every service principal that had a credential added in the last 90 days. That list alone tends to be more interesting than people expect. Cheers, Marcel270Views0likes0CommentsWhat’s New in Microsoft 365 Copilot | May 2026
Welcome to the May 2026 edition of What's New in Microsoft 365 Copilot! Every month, we highlight new features and enhancements to keep Microsoft 365 admins up to date with Copilot features that help your users be more productive and efficient in the apps they use every day.21KViews10likes4CommentsWhat’s new in Microsoft Sentinel: May 2026
Welcome to the May edition of What's new in Microsoft Sentinel. This month’s updates focus on unified role-based access control (RBAC), ecosystem breadth, AI-agent security, and high-assurance identity. RBAC and row-level scoping are now generally available, giving security teams a single, granular permissions model across Sentinel and the Microsoft Defender portal and enabling multi-team SOC collaboration. The Sentinel connector catalog has passed 400 connectors, expanding coverage across Microsoft and third-party data sources and helping customers and partners onboard new data faster with the Codeless Connector Framework (CCF). The Agent 365 connector, now in public preview, brings AI agent telemetry into Sentinel data lake as first-class standardized signals so you can monitor agent behavior alongside identity, endpoint, and cloud activity. Finally, Entra Verified ID partner integrations in Microsoft Security Store are now generally available, delivering high‑assurance identity verification that makes account recovery after compromise far safer and significantly reduces the risk of re‑compromise. Read on for the full list of updates across Sentinel in May. Sentinel innovations: Sentinel SIEM Sentinel data lake Microsoft Security Store Sentinel SIEM Unified role-based access controls and row level scoping [Generally available] Sentinel now delivers general availability of two powerful access management capabilities: Unified RBAC and row-level data scoping. Together, these innovations provide a consistent, end-to-end model for controlling who can access data and what actions they can take — extending unified permissions management across the Defender portal while enabling granular, row-level visibility within a single Sentinel workspace. With Unified RBAC, organizations can simplify and centralize permissions across security workloads, reducing operational overhead, while row-level scoping enables secure collaboration across multiple teams by ensuring users only see data aligned to their role or scope. This milestone unlocks more scalable, multi-team SOC operations without the need for workspace segmentation, helping us to advance toward fully unified, granular access control across Microsoft Security. Tenant groups [Public preview] Managing security across multiple tenants just got simpler. Tenant Groups in the Microsoft Defender multi-tenant portal (MTO) give managed security service providers (MSSPs), cloud service partners (CSPs), and multi-tenant security teams a flexible way to organize tenants into logical groupings such as customer segment, geography, or operational priority, and instantly switch views with a single click. This streamlined experience reduces noise, improves investigation focus, and aligns to how teams actually work, all while respecting existing permissions and access controls. Learn more. Out-of-the-box integrations for Sentinel automation [Public preview] Out-of-the-box (OOTB) integrations for Sentinel automation brings a centralized catalog to easily discover, configure, and manage both Microsoft and third-party integrations. With simple, authentication-based setup, users can quickly add integrations and seamlessly incorporate them into playbooks. The experience places OOTB and custom integrations side by side, with enhanced with smart search, recommendations, and duplicate prevention to streamline automation workflows end to end. Learn more. UEBA enhancements [Public preview] Microsoft Sentinel UEBA continues to evolve with improvements that simplify management and expand detection coverage. A dedicated UEBA tab view in the Sentinel settings page consolidates UEBA and behaviors settings, making configuration easier to find and manage. Learn more. UEBA insights and anomalies now support the OktaV2_CL table alongside the existing Okta_CL table, extending anomalous activity and anomalous MFA failures detections to customers using the newer Okta connector format, without requiring new anomaly types. Learn more. UEBA extends GCP Audit Logs coverage with five anomaly detections for login activity, privileged actions, resource deployments, secret/KMS key access, and infrastructure usage. Learn more. Together, these updates make UEBA easier to operate while extending its visibility into identity and behavior signals from additional cloud and identity providers. Read the latest blog from the Microsoft Defender Research Team to learn more about Microsoft Sentinel UEBA and binary feature stacking, which uses clear binary signals to help establish behavioral context and inform investigation and detection decisions. Threat Intelligence – TAXII Export connector [Generally available] Sentinel supports threat intelligence export through the built-in Threat Intelligence – Trusted Automated Exchange of Intelligence Information (TAXII) Export connector, giving customers a standards-based way to share curated Structured Threat Information Expression (STIX) objects with supported TAXII 2.1 platforms. Configured from the Defender portal, the connector handles destination setup and intelligence delivery to external platforms. The capability supports cross-organization intelligence sharing for collective defense and centralized management in multi-tenant environments, with use cases across government, critical infrastructure, and large distributed organizations. Additional enhancements are planned, including more export options and expanded destination support. Learn more. Decision-stage resources for SIEM migration to Sentinel The AI-powered SIEM migration experience helps teams analyze detections, identify required data sources and connectors, and plan a phased move to Sentinel. But, customers still need help turning that analysis into a clear decision. To support that step, we’re introducing two new customer-facing resources: the Sentinel SIEM Migration Decision and Planning Guide, which explains the migration journey, outputs, and decision checkpoints before execution, and the Decision-Stage Customer FAQ, which answers common questions around disruption, cost, dual running, detection coverage, and delivery support. Together, these resources help make migration conversations more concrete and move teams more quickly from evaluation to a clearer, lower-risk next step. Learn more: Read the blog: AI-powered SIEM migration experience announcement Download the guide: Decision and planning guide Download the FAQ: Decision-stage customer FAQ Learn more: SIEM migration experience documentation Register for live AMA (Jun 23 at 9am PT): Live Microsoft Tech Community AMA on SIEM migration Sentinel data lake 400+ Sentinel data connectors The Sentinel connector catalog now includes 400+ connectors, providing broad, ready-to-deploy coverage across Microsoft and third-party data sources. Customers can flexibly ingest security data into Microsoft Sentinel analytics tier or the data lake tier. The Codeless Connector Framework (CCF) and VS code-based connector builder agent enables partners and customers to onboard new data sources faster and scale the catalog. Discover connectors in the Sentinel Content hub within the Defender portal or build custom connectors when needed. Learn more. Agent 365 connector [Public preview] Agent 365 connector streams AI agent telemetry from Agent 365 into Sentinel data lake, giving SOC teams visibility into agent behavior alongside identity, endpoint, and cloud signals. With the Agent 365 connector in place, Sentinel data lake becomes the system of record for agent security, turning activity such as data exposure or access drift into first-class security signals that analysts can correlate, hunt across, and investigate. Telemetry is normalized and to mapped to standard Advanced Security Information Model (ASIM) schemas, ready for analytics and detections, and end-to-end investigations can run through KQL, graph, and MCP-powered workflows. Install the connector with a single click from Sentinel Content Hub in the Defender portal. Learn more. CCF support for Azure Blob Storage [Public preview] Sentinel Codeless Connector Framework (CCF) supports Azure Blob Storage as a data source, providing an ingestion pattern designed for high-volume security data. Partners and customers can build CCF connectors that read from Blob Storage through a durable architecture that buffers spikes, handles backpressure, and reduces data loss risk during outages or throttling, making ingestion more reliable for variable or distributed pipelines. The pattern broadens compatibility with partners already streaming logs to Azure as part of their audit data delivery, with Cloudflare and Netskope as early adopters. App Assure further provides engineering-backed support for designing, validating, and remediating the Azure Blob Storage CCF connector integration. Learn more. Data filtering and splitting [Generally available] At RSAC, we announced built‑in filtering and splitting capabilities in Microsoft Sentinel, which is now generally available. As security teams ingest more data, it is important to optimize security data pipeline by controlling what data is ingested and in which tier. With filtering and splitting natively integrated into the Defender portal, security teams can shape data before it reaches Sentinel, without switching tools or managing custom JSON files. Using simple KQL‑based transformations directly in the UI, you can filter low‑value events and intelligently route data, making ingestion optimization faster, more intuitive, and easier to manage at scale. Filtering at ingest time allows you to remove low‑value or benign events to reduce noise, lower unnecessary processing, and ensure high‑signal data drives detections and investigations. Splitting enables intelligent routing of data between the analytics tier and the data lake tier based on relevance and usage. Together, these capabilities help you balance cost and performance while scaling data ingestion sustainably as your digital estate grows. Learn more. Transition your Sentinel connectors to the Codeless Connector Framework (CCF) [Action required] Azure has announced that the legacy Azure Data Collection API will be deprecated on September 14, 2026. Sentinel recommends customers review existing connectors and upgrade to the latest Codeless Connector Framework (CCF) versions to ensure continued access to the newest Sentinel capabilities. CCF delivers a fully managed SaaS experience with built-in health monitoring, centralized credential management, and improved performance. This enables partners and customers to onboard new data sources faster and at scale. Microsoft Security Store Entra Verified ID partner integrations via Security Store [Generally available] Security Store helps organizations secure one of the most critical steps in incident response: safe account recovery after compromise. Once a SOC team detects and contains a potential account takeover (ATO), restoring access requires high confidence that the user is legitimate. Through partner integrations with IDEMIA, AU10TIX, CLEAR, 1Kosmos, and WhoAmI, customers can extend Entra Verified ID with high-assurance identity verification (such as document and biometric checks) to validate users during recovery, onboarding, or helpdesk workflows. This helps replace weaker fallback methods that attackers often exploit, enabling SOC and IT teams to safely restore access while reducing risk of re-compromise. Learn more. Purview Data Security Triage Agent in Defender [Public preview] Security Store powers how customers discover and activate data security agents across Defender and Microsoft Purview, starting with the Data Security Triage Agent. This capability delivers AI-generated summaries and prioritization of Data Loss Prevention (DLP) alerts directly into Defender XDR, helping security teams reduce noise and focus on the incidents that matter most. By unifying discovery and activation through Security Store, customers can deploy data security agents in fewer steps and enable more integrated workflows across threat and data protection surfaces. Learn more. Additional resources Blogs and documentation: From idea to production: Building Security Store Advisor with an agentic SDLC Upcoming webinars: June 4: End-to-End Security in the Age of Agentic AI June 10: Deploy, optimize, and implement threat protection with Sentinel June 10: Security Foundations for AI Adoption June 24: Modern Security Made Simple: Stay Ahead of Threats with Sentinel Upcoming events: June 2–3: Microsoft Build, San Francisco (and free online) CEO Satya Nadella Day 1 keynote 90+ sessions, Microsoft Security experts onsite Register: build.microsoft.com Stay connected Check back each month for the latest innovations, updates, and events to ensure you’re getting the most out of Microsoft Sentinel. We’ll see you in the next edition!971Views3likes0Comments