Windows Update - 'Policies set on your device' is empty but receiving updates

Copper Contributor

Hello, my organisation has recently started to test Intune and we have a few test devices including my laptop on Intune at the moment. I configured a Windows 10 update rings profile and targeted a test group which my laptop belongs to. I received the March updates (KB4589211, KB5000808) last week but when I go to 'view configured update policies' , it says 'No policies have been configured yet'. Check for Updates as a user is disabled and we are not doing co-management, so the updates must have come from MDM/Intune policy. I used to see a lot of policies listed here but now it's completely empty. Do you know why it's like this? Other devices in the test group are showing the same, not just my device. 

Many thanks in advance for your help.

7 Replies
Hey there! Which policies exactly are you setting in Intune? For example, the Feature Deployment (Preview) feature where you can target a specific version does NOT set anything on the device given it talks directly to the server. Additionally, please note, even with no policies configured you would still get updates.

Hi, thank you for your reply. Both Windows 10 update Rings and Feature updates (preview). Deferral for feature update is set to 0 in the first one and in the feature update (preview) policy, I am specifying 1909 and it works. I just thought it's strange I don't see anything at all in the 'Policies set on your device' area on my laptop.

Hi @Aria Carley  - I think I might be having a similar problem here on Windows 10 1909 devices. WUfB been configured and working fine for months, now Windows Update in Settings App is not showing any configured policies. However, the registry (HKLM\SOFTWARE\Microsoft\PolicyManager\current\device\Update) and the MDMDiagReport.html still looking OK. Screenshots attached. This appears to be a bug raised by people on twitter a few months ago. Are you aware of the issue and a potential fix? Let me know if you need this raised via a different channel.


Adam Juelich on Twitter: "Anyone else using WUfB all of the sudden see Policies not being listed in ...




Did anyone ever get back to you on this with a solution or fix.? Saw others on twitter saying the same yet no mention from MS on if its a bug or known issue.
A support ticket was raised but was closed without a resolution. Asked me to raise in the feedback hub which I did. The bug didn't appear to have any impact, other than not displaying update policies in the settings app. Upgrading machines from 1909 to 20H2 displayed the policies again
Thanks Mark. I have also seen the same result which leads me to think its a bug with 1909 that Microsoft has yet to confirm. I'm currently tracking a open case with Windows support at the moment to get them to confirm but the likelihood is I might get an answer once 1909 has gone out of support. Thanks for the feedback!