WSL 2 not working after installing 20262

Occasional Contributor

Just getting involved with Insider Preview...upgraded 2019 Datacenter (latest official release) to 20262. After the upgrade, downloaded and ran the Linux Kernel update package. When running WSL commands from the command-line, almost every command I run returns the same output that wsl --help enumerates. If I run wsl --set-default-version 2, it enumerates the help context. Did I miss a step to get this to work or is this a known bug?

32 Replies

@Mary Hoffman 

I see, but there wasn't any new LTSC version of server released since WS2019 (1809), so it is clear that WSL2 was released only in the SAC.

 

AFAIK the WS2022 is being developed in the same cycle as the Windows 10 and Windows Server 21H2.

If that is true, there is quite a big chance WSL2 will be part of the WS2022, when released.

Well, unless the product team decides to remove it, not include it or simply not support it.

If nothing goes wrong the WS2022 will be here in few months, so there isn't much time left for the decision to be made.

When it will be announced what will be part of the LTSC and what will be deprecated?

 

thanks

 

Lubomir

@Mary Hoffman Is it possible to extend the life of the last WSL2 release (20241) until it returns to the releases?

 

Really need WSL2 and really don't want to revert to windows 10.

@Mary HoffmanWe need a proper desktop environment, and CUDA support on a command line (e.g. for tensorflow or Docker or other Linux command line applications that need GPU acceleration). So we need WSL2. Strangely, Microsoft offers this option on Windows 10 but not Windows Server. (At the same time, Windows 10 and Windows 10 Pro for Workstation do not allow multiple users to logon simultaneously, so we cannot use them). There was a glimmer of hope with WSL2 support in the early vNext versions of Windows Server 2022, so we started using it, tolerating all the bugs. Now, Microsoft appears to be dropping the ball again, by dropping WSL2 support from Windows Server LTSC entirely... I am not sure why such strange decisions are being made. If we want multiple users + a desktop environment + CUDA on a command line, we are out of luck. Microsoft is leaving us without any option here, other than a full Linux desktop.

@tbertenshaw

IMHO it could be technically possible to release a patch of the Microsoft-Windows-Security-SPP-Component, where AFAIK the timebomb lives, specifically for this build, but don't put much hope on MS doing it.
To be honest I would be happier if they would rather fix it for the builds coming.

TBH just want a working version. Backported or new version with it fixed or instructions to unbreak it.

@Mary Hoffman

I don't think this is quite right. WSL(1) was indeed available in Windows Server 2019 LTSC and I was able to use it perfectly fine. WSL2 on the other hand wasn't, because it simply did not exist back then yet.

Also, WSL2 was backported to Windows 10 Versions 1903 and 1909 a while ago (WSL 2 Support is coming to Windows 10 Versions 1903 and 1909), but not the Windows Server 2019 LTSC, which is based on Windows 10 version 1809.

WSL2 then worked perfectly for the first early LTSC preview builds, but then suddenly stopped working once the flighting branch was changed to "fe_release[_server]" in build 20246 onwards. Main Windows 10 Insider Preview also switched branches there (Announcing Windows 10 Insider Preview Build 20246 | Windows Insider Blog). WSL1 however appears to continue to work just fine.

I had opened a GitHub issue about this a while ago: WSL 2 broken on Windows Server Preview (since change to fe_release branch) · Issue #6301 · microsoft...

Any news on if WSL2 is in this new preview of Windows Server 2022? 

@tbertenshaw 

It unfortunately doesn't look like that. :cryingwithlaughter:

Still the same behavior.

It isn't possible to run the command

wsl --set-default-version 2

 

@LubomirH would be nice if someone at MS just explained the situation. i.e. we don't plan to introduce until after GA or its still being planned or its unsupported at the moment but you can fudge it by X etc. 

@LubomirH I can verify that build 20313 it is still broken.  I landed here trying to figure out what had gone wrong and what the triage was.  I'm in the same boat as you as my working WSL2 compatible version expired on 1/31 and now won't start up.

This is frustrating as all get out.

If anybody hoped it is fixed in the build 20324, rest assured it isn't. :cry:

The command

PS C:\Users\Administrator> wsl --set-default-version 2

still just outputs the same as the command bellow

wsl --help

and doesn't switch to mode 2

PS C:\Users\Administrator> wsl --status
Default Version: 1

Windows Subsystem for Linux was last updated on 4/2/2021
The Windows Subsystem for Linux kernel can be manually updated with 'wsl --update', but automatic updates cannot occur due to your system settings.
To receive automatic kernel updates, please enable the Windows Update setting: 'Receive updates for other Microsoft products when you update Windows'.
For more information please visit https://aka.ms/wsl2kernel.

Kernel version: 5.4.72

  

Do you mean WSL1 or WSL2 here? WSL2 didn't exist at the time of Windows Server 2019, so that can't be the rationale, and WSL1 is present in the Windows Server LTSC 2022 Insider builds, right now.

Are you suggesting that WSL will be completely pulled (i.e. WSL1 as well) from Windows Server LTSC 2022 before release?

It seems odd that we would get WSL1 but not WSL2 in Windows Server LTSC 2022, since AFAIK all development effects and new features have been focussed on WSL2 for the last year or two.

@TBBle 
I agree. 
We do have a need of WSL2 on Server2022. IE a server with GUI and WSL2 and a decent support lifecycle