Windows Server 2019 Build 17623 SMB1 does no more exists?

Iron Contributor



I tried for a test to enable SMB1 support for the build 17623, but when I give the PowerShell command:


Set-SmbServerConfiguration -EnableSMB1Protocol $true

I have the error:


Set-SmbServerConfiguration : The specified service does not exist.
At line:1 char:1
+ Set-SmbServerConfiguration -EnableSMB1Protocol $true
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (MSFT_SmbServerConfiguration:ROOT/Microsoft/...erConfiguration) [Set-SmbSe
rverConfiguration], CimException
+ FullyQualifiedErrorId : Windows System Error 1243,Set-SmbServerConfiguration


Could you confirm that it is no more possible to enable SMB1? I know it is deprecated, but we have still a pair of Windows Server 2003 domain controllers and so it is not possible to join the domain for the server with the build.



11 Replies
best response confirmed by Marco Mangiante (Iron Contributor)

Have you installed the 'SMB 1.0/CIFS File Sharing Support' feature?

Thanks @Alan CR


I completely override the step: now it works.




You have to install SMB 1.0 support in server manager (add roles and features). Also guest access is blocked in newer versions of windows 10:
Microsoft Verified Best Answer



thanks for your reply and information.

There is a simple command in PowerShell that does the work:


Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol

the link is for reference:


I've seen that Microsoft disabled the smb1, if I remember well, in the first iteration of the semi annual edition of Windows Server.

Hey Guys

I have a server 2019 data center on azure and I cannot seem to be able to install the SMB 1.0 to be able to connect to my on-prem AD.

I have downloaded the 2019 data center image and mounted it on this server and further added the source path for installing the role. And it didnt fix the issue.

I further tried to install it using Powershell wiht below commands:

Get-WindowsOptionalFeature -Online -FeatureName "SMB1Protocol"

FeatureName      : SMB1Protocol
DisplayName      : SMB 1.0/CIFS File Sharing Support
Description      : Support for the SMB 1.0/CIFS file sharing protocol, and the Computer Browser protocol.
RestartRequired  : Possible
State            : DisabledWithPayloadRemoved
CustomProperties :
                   ServerComponent\Description : Support for the SMB 1.0/CIFS file sharing protocol, and the Computer Browser protocol.
                   ServerComponent\DisplayName : SMB 1.0/CIFS File Sharing Support
                   ServerComponent\Id : 487
                   ServerComponent\Type : Feature
                   ServerComponent\UniqueName : FS-SMB1
                   ServerComponent\Deploys\Update\Name : SMB1Protocol


When I try to enable it I get the following error that says source file could not be found.

 C:\Users\myserver> Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol -source e:\sources\install.wim:4
Enable-WindowsOptionalFeature : The source files could not be found.
Use the "Source" option to specify the location of the files that are required to restore the feature. For more information on specifying
a source location, see
At line:1 char:1
+ Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol -sour ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Enable-WindowsOptionalFeature], COMException
    + FullyQualifiedErrorId : Microsoft.Dism.Commands.EnableWindowsOptionalFeatureCommand


I also tried installing it and that didnt work either.

 C:\Users\myserver> install-windowsfeature SMB1Protocol -Source wim:E:\sources\install.wim:4
install-windowsfeature : ArgumentNotValid: The role, role service, or feature name is not valid: 'SMB1Protocol'. The name was not found.
At line:1 char:1
+ install-windowsfeature SMB1Protocol -Source wim:E:\sources\install.wi ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidArgument: (SMB1Protocol:String) [Install-WindowsFeature], Exception
    + FullyQualifiedErrorId : NameDoesNotExist,Microsoft.Windows.ServerManager.Commands.AddWindowsFeatureCommand

Success Restart Needed Exit Code      Feature Result
------- -------------- ---------      --------------
False   No             InvalidArgs    {}


I am really stuck.. I would appericiate if someone could guide me.








@Marco Mangiante 

I have the same issue, all the workarounds relate to having a server with the option already installed however this is my first 2019 server.

@Marco MangianteHere's possibly a silly question - I only want to enable the SMB 1.0 client on this server.  I don't want to enable SMB 1.0 server.  My goal is to grab files from a Windows 2003 server, and then turn off the client - however I don't want SMB1.0 shares to be exposed from the Windows 2019 server I am working on.


Is there a way to do this without enabling the entire server?

@Alan CR  This worked for me thanks .

@Eric Levinson 


I have a similar setup, a 2019 server need to map a drive from an AS400 SMBv1 share.

And only want to enable the SMB v1 client part on the 2019 server.


Did you get it to work?



Hi there, did you ever solve this?



I had this problem myself and managed to eventually solve it


The basic problem is that the installation files for SMB1 are not contained within the Server 2019 image that's deployed in Azure. However, you can specify a source for the installation files and continue the install. HOWEVER, if you have updated your Azure VM to the latest updates, you can no longer use the evaluation Server 2019 ISO File as a source.


Here's how I got around the problem:


1. Install a fresh copy of Windows Server 2019 to a temporary server  and join it to my domain. Make sure the build number is 17763.737 or lower.

2. Attach the Windows Server 2019 evaluation ISO to the server. Install the SMB1 feature and enter WIM:E:\sources\install.wim:4 as the source.

3. Reboot the server once the feature is installed

4. Install all the latest updates to the server and reboot

5. Share the C:\windows\winsxs folder on the server. Give "everyone" read permission.

6. Go to the server where you are unable to install SMB1. Do the installation but put the source as \\servername\winsxs that you shared in step 5. The installation will complete


It's pretty awful workaround but it worked for me... I guess if you have access to an ISO containing a newer build number, that would also work.

1 best response

Accepted Solutions
best response confirmed by Marco Mangiante (Iron Contributor)

Have you installed the 'SMB 1.0/CIFS File Sharing Support' feature?

View solution in original post