Server 2019 Volume licensing activation key not working

Occasional Contributor

I have a server that I am trying to install Server 2019 Standard. The Volume Licensing activation key is not working. The product was downloaded from the Volume Licensing portal along with the license key.  The activation pane shows a product ID, and on the product key space the last (5) digits are already populated.  The server had a previous Server 2016 evaluation running on it before it was reformatted before attempting to install Server 2019.

26 Replies
best response confirmed by veronica_Duff (Occasional Contributor)

Might also try;


slmgr /ipk #####-#####-#####-#####-#####

slmgr /ato




@Dave Patrick  Thanks.  I tried it and got the following errors: 0xC004F050 The Software licensing service reported the product key is invalid. 




error-2-Capture.PNGACTIVATE-SCREEN- Capture.PNG

Also try phone activation;


slui 4




@Dave Patrick Thank you, Dave.  Tried that as well and got, "Can't activate Windows by phone."

@Dave Patrick  Okay, I will contact them.  Thank you for your assistance!

You're welcome.




Open Command Prompt


c:\windows\system32\slmgr.vbs /ipk PRODUCT_KEY


Sample: c:\windows\system32\slmgr.vbs /ipk 12345-12345-12345-12345-12345




Find available target editions

DISM.exe /Online /Get-TargetEditions

Change your target edition

DISM /online /Set-Edition:ServerStandard /ProductKey:XXXXX-XXXXX-XXXXX-XXXXX-XXXXX /AcceptEula


Works on MS Server 2019 Trial 05/09/2019



We had a similar issue as the OP and tried these commands among others. However, they appear not to work on the Server 2019 Standard Evaluation edition if you have a VLSC MAK key. Googling around indicates that you need a retail key for the commands to work.


The question for me is how to extract a retail key from a VLSC MAK key. Is that even possible at all?



Tony G


@tonymoo wrote:

However, they appear not to work on the Server 2019 Standard Evaluation edition if you have a VLSC MAK key.

That's correct, the technet evaluation cannot be activated using a volume key. The correct distribution media can be downloaded from the volume center.



worked for me, thanks @rao_kru   


I got this error with MAK keys and media from VLSC with 2019 Standard installed from usb stick.
Same MAK key and media from our MDT server don't give any errors...

But it's only Standard version, others version from same media dosen't give errors.


It did not work for me for the Version Win SRV 2019 STD Core

but I called MS and they told me to use this

Run CMD as Administrator

slmgr.vbs -ipk YOUR PRODUCT KEY.


this one helped and windows was activated


Thanks for posting. This little jewel worked like a charm




This should be at the top. Worked immediately without fail after trying all of the above suggestions and usual advice.

@szpitalsochaczew  thanks a lot. Worked like a charm.

Worked.I wonder why the license manager tool worked within command prompt, but doesn't in Settings-> Activation?





Thanks for posting. It's the only thing that worked for me!