Problems downloading the ISO

Brass Contributor

Today I have tried to redownload the iso of the latest build, just for testing internet speed. It gest stuck just after confirmation of the iso option and of the language (English US). It gets stuck at:

Validating your request. This may take several minutes. Do not refresh the page or select back, doing so will cancel the request.

And the spinning wheel endlessly. For the moment, it is not a problem, since I have the latest build, but I hope it gets fixed until the next one is published. This happens both on my Ubuntu Server 20.04 machine, on Firefox, and on Windows Server vNext, on Edge.

11 Replies

Can confirm this issue, tried on Chrome 99 and Chromium Edge 100 on Windows 10 Enterprise 2004, also on a separate computer using Chrome 99 on Windows 11 Pro Insider

是啊,昨天就有这个问题了,我也不能下,很难受≧ ﹏ ≦
Thanks for letting us know. This is being investigated.
Downloads are working again. Thank you.

@Mary Hoffman 

Problems downloading the ISO Not fixed. Here is a screen of errors:Error.jpg

it is also not possible to download the image of an insider build 22593

You may have encountered a transient issue. I was unable to reproduce this issue. I downloaded Windows_InsiderPreview_Server_vNext_en-us_25083.iso successfully. Please try your download again.

There was no Build 22593 for Windows Server. There may have been a 22593 for client, however, in checking the Windows Client download page at, it appears that 22598 is currently offered.

@Mary Hoffman 


Alas, everything remains the same for the server - 25083, and for the client - 22598. Thus, you risk losing a very large number of testers.

I am also seeing this issue right now. Is there a way to get around it?


@Radu Ilie 

I suggest empty the cache of the browser, then re-log-in the download page, accepting all the cookies. I have noticed that, if you do not accept all the cookies, the download process gets certain issues. You could give this a try.

@Radu Ilie 

I think I am now registered but the download is still failing. Thanks

Edited. Finally got it working. Disabled Duck Duck Go and uBlock and it's all good. Thanks!