In-place build upgrade failure and workaround

Brass Contributor

I have noticed that, since the first build the new Microsoft Edge was bundled with Windows Server vNext, I could not upgrade from one weekly build to the next without re-installing from scratch. I could upgrade from an older build that did not include Edge to a newer one that did, but not from one with Edge to anther with Edge. I tought that Edge was the culprit, but I could not uninstall it through the regular means, for I have wound a guide to forcly uninstall it via command line. It was uninstalled, but Windows upgrade to the new build failed again. Then, I tought that enabling Network Sharing was the culprit. So, did a fresh install once again, but kept it disabled, as out of the box. The latest build came, it failed in-place upgrade, but at an earlier stage. Yet, Edge was updated after the fresh installation a few days ago and it was removable through Control Panel or Settings. So I did uninstall it, then tried an in-place upgrade and it worked. It had reinstalled Edge. So, I guess the update/upgrade system for the Chromium Edge between Windows builds (that upgrade like previous redstones, through a Windows re-install mechanism with documents, settings and programs being kept) it is not fully developed. Edge updates on a different way then the OS itself, in a way enherited from the Chromium browser, it is not fully integrated into Windows yet, altough I have looked via 7zip and the Windows Install.wim file contains it. Probably, due to that, especially when the installed version of the Chromium Edge browser is updated beyong what is in the install.wim, issues can appear. I guess that, if the update/upgrade mechanism for Edge in Windows it is not solved, that Edge should not be bundled with Windows until that, while still being available for users via the Microsoft Edge msi installer for Enterprise. A workaround, so far, seems to be uninstalling it before an in-place build upgrade..

5 Replies

Thank you for reporting the issue, we are actively working on a fix.  I will circle back when I have an ETA



Just an update...  fix should be available in next weeks Windows Server Insider build 

@Elden Christensen 

Thank you for the reply. In my opinion there are there possible solutions to this issue, that I assume is, most likely, present not just in Windows Server vNext LTSC, but also on standard Windows 10 Insider builds.

1) Chromium Edge is not bundled with Windows Server, but it comes later through manual install from the Enterprise msi installer or via Windows Update. I guess this is the easiest solution;

2) Chromium Edge is bundled with Windows Server, but not part of install.wim and it gets installed on the later stages of the Windows install process. This would make Edge a program installed on Windows like other non-Windows programs that are installed in Windows and, on in-place upgrade from build to build, the Windows upgrade function shall treat it like any other installed program and migrate it (like Microsoft Office or Microsoft SQL);

3) Chromium Edge is deeply bundled with Windows 10 and Windows Server and it gets updated only through Windows Update, like a Windows component. In case of an in-place upgrade from build to build, it should be replaced with the rest of the OS (kernel, Windows Explorer etc). This last solution is, probably, the hardest and, I assume, the developers know it.

@Radu Ilie 

Thanks! I been trying to upgrade the insider server build for last few days and tried all possible solution, then I found this post, uninstalled edge and install went without a issue.

You will see the same issue if you try to upgrade from Windows Server 2019 if Edge is installed.  The failure will be something like:


0x8007042B - 0x2000D

The installation failed in the SAFE_OS phase with an error during MIGRATE_DATA operation