I can't Turn on network discovery

%3CLINGO-SUB%20id%3D%22lingo-sub-178750%22%20slang%3D%22en-US%22%3EI%20can't%20Turn%20on%20network%20discovery%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-178750%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EWhy%20in%20Advanced%20sharing%20settinggs%20the%26nbsp%3BTurn%20on%20network%20discovery%20can't%20save%20the%20settings%20in%20Windows%20Server%202019%20Preview%3F%20Although%20as%20an%20admin%20I%20turn%20it%20on%20and%20save%20settings%2C%20it's%20again%20off%20when%20I%20open%26nbsp%3B%3CSPAN%3EAdvanced%20sharing%20settinggs%3C%2FSPAN%3E.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThe%20second%20problem%20is%20that%20when%20I%20click%20Choose%20media%20streaming%20optons%2C%20I%20get%20the%20message%20The%20page%20failed%20to%20load.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-178750%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ENetworking%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-251581%22%20slang%3D%22en-US%22%3ERe%3A%20I%20can't%20Turn%20on%20network%20discovery%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-251581%22%20slang%3D%22en-US%22%3E%3CP%3EFor%20network%20discovery%2C%20it's%20a%20common%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOpen%20services.msc%20and%20make%20sure%20the%20following%20services%20are%20all%20running%3A%3C%2FP%3E%3CUL%3E%3CLI%3EDNS%20Client%3C%2FLI%3E%3CLI%3EFunction%20Discovery%20Resource%20Publication%3C%2FLI%3E%3CLI%3ESSDP%20Discovery%3C%2FLI%3E%3CLI%3EUPnP%20Device%20Host%3C%2FLI%3E%3C%2FUL%3E%3CP%3EAfter%20that%20turn%20network%20discovery%20on%20again%20and%20it%20should%20stay%20enabled.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-180442%22%20slang%3D%22en-US%22%3ERe%3A%20I%20can't%20Turn%20on%20network%20discovery%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-180442%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan't%20anyone%20say%20what's%20the%20problem.%20In%20Server%202016%20the%20Network%20discovery%20works%20OK.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-522774%22%20slang%3D%22en-US%22%3ERe%3A%20I%20can't%20Turn%20on%20network%20discovery%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-522774%22%20slang%3D%22en-US%22%3EThank%20you%2C%20this%20fixed%20the%20issue%20for%20me.%3CBR%20%2F%3EIn%20Windows%20Server%202019%2C%20the%20SSDP%20and%20UPnP%20service%20were%20disabled%20by%20default.%3CBR%20%2F%3E%3CBR%20%2F%3EBig%20thanks%2C%20just%20playing%20with%20a%20virtual%20machine.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-658878%22%20slang%3D%22en-US%22%3ERe%3A%20I%20can't%20Turn%20on%20network%20discovery%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-658878%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F332578%22%20target%3D%22_blank%22%3E%40GarrettG%3C%2FA%3E%26nbsp%3Bsame%20here.%202%2F2%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1319699%22%20slang%3D%22de-DE%22%3ERe%3A%20I%20can't%20Turn%20on%20network%20discovery%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1319699%22%20slang%3D%22de-DE%22%3EWorked%20like%20a%20charm%2C%20thank%20you!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2122310%22%20slang%3D%22en-US%22%3ERe%3A%20I%20can't%20Turn%20on%20network%20discovery%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2122310%22%20slang%3D%22en-US%22%3E%3CP%3EThis%20also%20was%20the%20fix%20for%20me%20on%20a%20new%20Server%202022%20setup%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F332578%22%20target%3D%22_blank%22%3E%40GarrettG%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hi

 

Why in Advanced sharing settinggs the Turn on network discovery can't save the settings in Windows Server 2019 Preview? Although as an admin I turn it on and save settings, it's again off when I open Advanced sharing settinggs.

 

The second problem is that when I click Choose media streaming optons, I get the message The page failed to load.

6 Replies

Hi

 

Can't anyone say what's the problem. In Server 2016 the Network discovery works OK.

For network discovery, it's a common issue.

 

Open services.msc and make sure the following services are all running:

  • DNS Client
  • Function Discovery Resource Publication
  • SSDP Discovery
  • UPnP Device Host

After that turn network discovery on again and it should stay enabled.

Thank you, this fixed the issue for me.
In Windows Server 2019, the SSDP and UPnP service were disabled by default.

Big thanks, just playing with a virtual machine.

@GarrettG same here. 2/2

Worked like a charm, thank you!

This also was the fix for me on a new Server 2022 setup

@GarrettG