WINDOWS UPDATE SERVICES NOT START ERROR

Highlighted
Occasional Contributor

Hi guys,
I have a very big problem with one windows server 2016 vm.
After windows update and reboot windows update doesn't start and if i try to star manually i receive this error pop-up:

Windows could not start the Windows Update service on Local Computer. Error 0x80070539: The security ID Structure is invalid.

I have try all windows update error solved result founded in a web but without success.

The  0x80070539 error are insoluted.

Any idea??

Thanks

 

20 Replies
Highlighted

I'd check the Windows Update (wuauserv) service is set to start using the Local System account

 

 

Highlighted

When you start the Update Server what Event ID it generates on the Windows Event Log? 

Highlighted
Yes...The same error.
Highlighted

I'd try to download and run the windows update trouble shooter.

https://support.microsoft.com/en-us/help/10164/fix-windows-update-errors

Also try repairing system and service corruption by running;

sfc /scannow

dism /online /cleanup-image /restorehealth

 or worst-case a repair install by running setup.exe from the root of the install media.

 

 

Highlighted
Locate Cryptographic and Background Intelligence Transfer Service and double click on the service icon.
Check if the service status is stopped. If yes, click on Start to start the service.
 
Check if you can start Windows update service.
Highlighted

The description for Event ID 7023 from source Service Control Manager cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

Windows Update
%%2147943737

The resource loader failed to find MUI file

Highlighted

Cryptographic start

Background Intelligence Transfer Service NOT start

After Background Intelligence Transfer Service Started the Same error when I try Windows Update Service Start.

Highlighted

Alvise, I would imagine you're reading the Event Log from another machine? If you read it locally you should get the proper content of the event.

Cheers. Emanuel

Highlighted

Hi Emanuel

I have open event log in local machine (view attach image)

Correct?

 

Highlighted

Hi Emanuel

I have open event log in local machine (view attach image)

Correct?

 

Highlighted

Hi Alvise.

Sorry about that, that usually happens when you open an event log on a different machine, I thought this might be the case here as well.

 

That aside, I am a bit clueless about what could cause the issue, so the following question is my first guess: was that a clean install (from a Windows ISO), or deployed from an image/ clone not properly sysprepped?

The Windows Update client has its own system identifier, and maybe this could cause problems? Although in this case the service should at least start...

Highlighted

windows update trouble shooter FIX IT the problem but sfc /scannow return the error in attach.(CBS.log)

sfc.jpg

Highlighted

 

 Attach CBS.log

Highlighted

No problem.
I have installed the wserver 2016 from iso.
The machine run from february with any problem...windows update has been work corretly but now dowsn't work.
Another problem is the windows toolbar...I don't open...if i click into windows logo toolbar doesn't start.

Highlighted

Hello again, Alvise.

A log file is probably not too important and you could easily delete it (back it up first if you think it could be relevant at some point, though), but the log complains about some executables, too: tssdis.exe, explorer.exe, nltest.exe.

Maybe the installation source is corrupted? If I were you, I'd look into those before looking at the Windows Update issue...

Highlighted

The real problem is that server is a production server and cannot stopped..
I can try to resolve the problem in the night when doesn't work but I don't how to resolve..
Can I try to reinstall windows server 2016? Do you have any idea?

Thx

Highlighted

You could try to do a system restore from before you started noticing the issues, and then restore the data for the app(s) running on the server. It shouldn't take long, but you'd still need to do it during a maintenance window.

If you don't have a backup that old, then deploy a new VM and migrate the app(s) there.

 

One more thing: if you are sure nothing bad was installed on your VM, the fact that some files are altered could indicate an issue with the storage where you have the vhdx/vmdk. Maybe you should chkdsk the storage as well... At least that's something you can do with no downtime. :)

 

Highlighted

I have a old vm but without any program.

Another vm backup have the same problem.

Thanks for your support

 

The best solution is: Create a New VW! :)

 

 

Highlighted

Cheers, Alvise.

Highlighted

You can try a repair install by running setup.exe from the root of the install media but this is very risky move. Better to stand up a new one, patch it fully, then migrate the roles or applications over to it.