Windows Server 2019 warns No Internet Access after AD, DNS and DHCP setup

%3CLINGO-SUB%20id%3D%22lingo-sub-1226460%22%20slang%3D%22en-US%22%3EWindows%20Server%202019%20warns%20No%20Internet%20Access%20after%20AD%2C%20DNS%20and%20DHCP%20setup%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1226460%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20Windows%20Server%202019%20VM%20(HyperV)%20where%20I%20setup%20my%20first%20DC.%20I%20also%20setup%20DNS%20and%20DHCP%20on%20the%20server.%20After%20deploying%20these%2C%20the%20yellow%20warning%20icon%20appeared%20on%20the%20network%20icon%20in%20the%20bottom%20right%20corner%2C%20and%20it%20says%20%22No%20internet%20access%22.%26nbsp%3BIndeed%2C%20Internet%20access%20seems%20to%20be%20working%20normally.%20The%20only%20issue%20is%20the%20DNS%20sometimes%20unable%20to%20resolve%20certain%20random%20domains.%20It%20seems%20that%20unbinding%20IPv6%20from%20the%20NIC%20almost%20solved%20this%20issue%2C%20but%20the%20warning%20icon%20and%20the%20No%20Internet%20message%20remains.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20tried%20the%20troubleshooting%20tool.%20It%20is%20unable%20to%20diagnose%20the%20issue%2C%20and%20suggests%20a%20network%20reset.%20I%20did%20it%20twice%2C%20but%20it%20did%20not%20change%20anything.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20took%20a%20dump%20of%20the%20network%20packets%20when%20the%20diagnostic%20tool%20is%20run%2C%20but%20I%20see%20nothing%20unusual.%20It%20finally%20connects%20to%20%3CA%20href%3D%22http%3A%2F%2Fwww.microsoft.com%3A80%2F%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttp%3A%2F%2Fwww.microsoft.com%3A80%2F%3C%2FA%3E%26nbsp%3Bwhich%20I%20think%20is%20the%20normal%20way%20to%20determine%20if%20Internet%20is%20available.%20The%20server%20responds%20200%20Ok%20and%20some%20codes.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20don't%20know%20where%20to%20look%20further.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20ipconfig%20%2Fall%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWindows%20IP%20Configuration%3C%2FP%3E%3CP%3EHost%20Name%20.%20.%20.%20.%20.%20.%20.%20.%20.%20.%20.%20.%20%3A%20SrvApp19%3CBR%20%2F%3EPrimary%20Dns%20Suffix%20.%20.%20.%20.%20.%20.%20.%20%3A%20psw.local%3CBR%20%2F%3ENode%20Type%20.%20.%20.%20.%20.%20.%20.%20.%20.%20.%20.%20.%20%3A%20HybridIP%20Routing%20Enabled.%20.%20.%20.%20.%20.%20.%20.%20%3A%20NoWINS%20Proxy%20Enabled.%20.%20.%20.%20.%20.%20.%20.%20%3A%20No%3CBR%20%2F%3EDNS%20Suffix%20Search%20List.%20.%20.%20.%20.%20.%20%3A%20psw.local%3C%2FP%3E%3CP%3EEthernet%20adapter%20Ethernet%3A%3C%2FP%3E%3CP%3EConnection-specific%20DNS%20Suffix%20.%20%3ADescription%20.%20.%20.%20.%20.%20.%20.%20.%20.%20.%20.%20%3A%20Microsoft%20Hyper-V%20Network%20Adapter%3CBR%20%2F%3EPhysical%20Address.%20.%20.%20.%20.%20.%20.%20.%20.%20%3A%2000-15-5D-00-78-03%3CBR%20%2F%3EDHCP%20Enabled.%20.%20.%20.%20.%20.%20.%20.%20.%20.%20.%20%3A%20No%3CBR%20%2F%3EAutoconfiguration%20Enabled%20.%20.%20.%20.%20%3A%20Yes%3CBR%20%2F%3EIPv4%20Address.%20.%20.%20.%20.%20.%20.%20.%20.%20.%20.%20%3A%2010.0.0.112(Preferred)%3CBR%20%2F%3ESubnet%20Mask%20.%20.%20.%20.%20.%20.%20.%20.%20.%20.%20.%20%3A%20255.255.255.0Default%20Gateway%20.%20.%20.%20.%20.%20.%20.%20.%20.%20%3A%2010.0.0.254%3CBR%20%2F%3EDNS%20Servers%20.%20.%20.%20.%20.%20.%20.%20.%20.%20.%20.%20%3A%20127.0.0.1%3CBR%20%2F%3ENetBIOS%20over%20Tcpip.%20.%20.%20.%20.%20.%20.%20.%20%3A%20Enabled%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20attach%20one%20of%20the%20diagnostic%20reports.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20to%20anyone%20who%20can%20help.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1226460%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ENetworking%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1248862%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Server%202019%20warns%20No%20Internet%20Access%20after%20AD%2C%20DNS%20and%20DHCP%20setup%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1248862%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F580962%22%20target%3D%22_blank%22%3E%40Luigi_Iotti%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDon't%20unbind%20IPv6%20%3A)%3C%2Fimg%3E%20DNS%20listener%20binding%20does%20use%20IPv6%20too.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20it's%20on%20boot%20up%2C%20check%20the%20Event%20Log%20for%26nbsp%3B%3CSPAN%3EEvent%20ID%204013%20-%26nbsp%3B%3C%2FSPAN%3EThe%20DNS%20server%20is%20waiting%20for%20Active%20Directory%20Domain%20Services...%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENormal%20if%20you%20only%20have%20the%201%20DC%20and%20the%20VM%20completes%20the%20boot%20process%20before%20the%20services%20are%20ready%20to%20start.%20DNS%20usually%20waits%20until%20AD%20is%20complete.%26nbsp%3B%20%26nbsp%3BYou%20could%20always%20spin%20up%202nd%20DC%20with%20DNS%20and%20point%20to%20that%20and%20see.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1489726%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Server%202019%20warns%20No%20Internet%20Access%20after%20AD%2C%20DNS%20and%20DHCP%20setup%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1489726%22%20slang%3D%22en-US%22%3E%3CP%3ESame%20problem%20here%20and%20seen%20a%20couple%20of%20times%20already.%20I'm%20just%20testing%20a%20W2019%20deployment%20in%20VMware%20Workstation.%20Brought%20up%20W2019%20server%2C%20added%20DNS%2C%20DHCP%20and%20promoted%20to%20DC.%20Internet%20is%20clearly%20working%20as%20can%20browse%20BBC%20website.%20DNS%20settings%20on%20the%20DC%20look%20correct%20-%20forwarding%20to%20the%20router%20and%20using%20127.0.0.1%20for%20it's%20own%20settings.%20Also%20deployed%20a%20W10%20DC%20using%20DHCP%20and%20added%20to%20domain.%20It's%20fine%2C%20i.e.%20not%20reporting%20%22No%20internet%22%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1489765%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Server%202019%20warns%20No%20Internet%20Access%20after%20AD%2C%20DNS%20and%20DHCP%20setup%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1489765%22%20slang%3D%22en-US%22%3EAlso%20noticed%20that%20it's%20on%20a%20private%20network%2C%20not%20the%20domain%20network.%20Wonder%20if%20that's%20part%20of%20the%20problem%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1490361%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Server%202019%20warns%20No%20Internet%20Access%20after%20AD%2C%20DNS%20and%20DHCP%20setup%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1490361%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20got%20a%20workaround%20for%20this.%20I%20appears%20to%20be%20something%20to%20do%20with%20when%20you%20have%20a%20single%20DC%20where%20the%20DNS%20is%20configured%20as%20127.0.0.1.%20With%20a%20set-up%20like%20this%2C%20the%20%22No%20internet%22%20message%20occurs%20although%20it's%20clear%20one%20has%20perfect%20internet%20access.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%227F1BT7U%5B1%5D.png%22%20style%3D%22width%3A%20417px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F201193i9FEE293722EFA54C%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%227F1BT7U%5B1%5D.png%22%20alt%3D%227F1BT7U%5B1%5D.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EMy%20workaround%20is%20to%20add%20the%20IP%20address%20of%20another%20DNS%20server.%20The%20upstream%20router%20in%20this%20example%20but%20could%20equally%20be%208.8.8.8%20(Google%20DNS)%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22ZzvHoDn%5B1%5D.png%22%20style%3D%22width%3A%20420px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F201195i8AECF347DA28E5BB%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22ZzvHoDn%5B1%5D.png%22%20alt%3D%22ZzvHoDn%5B1%5D.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EOnce%20you%20add%20that%20second%20DNS%2C%20the%20%22No%20internet%22%20message%20disappears.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20a%20more%20normal%20domain%20set-up%2C%20best%20practise%20means%20you%20have%20two%20domain%20controllers%20and%20DNS%20servers.%20In%20which%20case%2C%20the%20DC%20would%20have%20DNS%20settings%20of%20127.0.0.1%20(itself)%20and%20the%20IP%20of%20the%20other%20DNS%20server.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1490822%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Server%202019%20warns%20No%20Internet%20Access%20after%20AD%2C%20DNS%20and%20DHCP%20setup%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1490822%22%20slang%3D%22en-US%22%3E%3CP%3Egoogle%20DNS%20knows%20nothing%20of%20your%20private%20domain.%20domain%20controller%20should%20always%20have%20at%20least%20own%20static%20ip%20address%2C%20and%20loopback%20(127.0.0.1)%20listed%20on%20connection%20properties.%20Never%20use%20router%20or%20public%20DNS%20here.%20Internet%20queries%20are%20passed%20on%20in%20a%20top-level%20down%20fashion%20by%20default%20to%20the%2013%20root%20hint%20servers%2C%20or%20optionally%20any%20configured%20forwarders.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22roothints.jpg%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F201228i1BC5136C58F6C869%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22roothints.jpg%22%20alt%3D%22roothints.jpg%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22forwarders.jpg%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F201229iE2EAB5C28AAC9DF2%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22forwarders.jpg%22%20alt%3D%22forwarders.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1491722%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Server%202019%20warns%20No%20Internet%20Access%20after%20AD%2C%20DNS%20and%20DHCP%20setup%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1491722%22%20slang%3D%22en-US%22%3EThis%20fault%20is%20nothing%20AFAIK%20to%20do%20with%20root%20hints%20-%20they%20are%20only%20ever%20used%20when%20the%20forwarder%20DNS%20server%20fails%20or%20is%20not%20configured.%3CBR%20%2F%3E%3CBR%20%2F%3EIt's%20some%20flaw%20in%20the%20check%20for%20internet%20access%20when%20running%20on%20a%20single%20domain%20controller%20system.%20When%20you%20promote%20a%20member%20to%20a%20domain%20controller%20and%20install%20a%20DNS%20server%20at%20the%20same%20time%2C%20it%20removes%20the%20DNS%20settings%20against%20the%20NIC%2C%20uses%20that%20for%20the%20DNS%20server%20forwarder%20and%20replaces%20it%20with%20127.0.0.1.%20This%20works%20perfectly%20for%20everything%20except%20for%20whatever%20test%20is%20being%20carried%20out%20for%20internet%20connectivity.%3CBR%20%2F%3E%3CBR%20%2F%3EAdding%20the%20DNS%20setting%20on%20the%20DC%20for%20an%20upstream%20DNS%20server%20(e.g.%20router%20or%20Google%20DNS%20or%20OpenDNS)%20and%20the%20check%20starts%20working.%3CBR%20%2F%3E%3CBR%20%2F%3EThe%20DC%20itself%20will%20refer%20to%20itself%20as%20127.0.0.1%20is%20checked%20first%20and%20most%20of%20the%20time%20will%20work.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1491731%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Server%202019%20warns%20No%20Internet%20Access%20after%20AD%2C%20DNS%20and%20DHCP%20setup%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1491731%22%20slang%3D%22en-US%22%3E%3CP%3EIt%20might%20be%20because%20it's%20very%20common%20for%20the%20forwarded%20DNS%20server%20to%20fail%20to%20resolve%20if%20it's%20picked%20up%20the%20upstream%20router%20like%20this.%20I'm%20just%20going%20to%20change%20the%20forwarder%20to%20Google%20DNS%20and%20remove%20from%20the%20static%20IP%20configuration%20to%20see%20if%20that%20works%20as%20well.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Z0SdSp0%5B1%5D.png%22%20style%3D%22width%3A%20422px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F201288i6DF14D48F1FA3A55%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22Z0SdSp0%5B1%5D.png%22%20alt%3D%22Z0SdSp0%5B1%5D.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1492004%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Server%202019%20warns%20No%20Internet%20Access%20after%20AD%2C%20DNS%20and%20DHCP%20setup%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1492004%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3Bgoogle%20DNS%20knows%20nothing%20of%20the%20internal%20domain%20and%20cannot%20be%20used%20for%20DNS%20on%20server's%20connection%20properties.%20Always%20use%20the%20server's%20own%20static%20ip%20address%20plus%20loopback%20and%20no%20others%20such%20as%20router%20or%20public%20DNS%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1688639%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Server%202019%20warns%20No%20Internet%20Access%20after%20AD%2C%20DNS%20and%20DHCP%20setup%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1688639%22%20slang%3D%22en-US%22%3E%26gt%3Bgoogle%20DNS%20knows%20nothing%20of%20the%20internal%20domain%20and%20cannot%20be%20used%20for%20DNS%20on%20server's%20connection%20properties%3CBR%20%2F%3E%3CBR%20%2F%3EI'm%20talking%20about%20the%20forwarders%20above%20and%20Google%20DNS%20servers%20are%20as%20good%20as%20any%20others%20in%20resolving%20*external*%20requests.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1688642%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Server%202019%20warns%20No%20Internet%20Access%20after%20AD%2C%20DNS%20and%20DHCP%20setup%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1688642%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CBLOCKQUOTE%3E%3CHR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F408911%22%20target%3D%22_blank%22%3E%40rob_nicholson_helios%3C%2FA%3E%26nbsp%3Bwrote%3A%3CBR%20%2F%3E%26gt%3Bgoogle%20DNS%20knows%20nothing%20of%20the%20internal%20domain%20and%20cannot%20be%20used%20for%20DNS%20on%20server's%20connection%20properties%3CBR%20%2F%3E%3CBR%20%2F%3EI'm%20talking%20about%20the%20forwarders%20above%20and%20Google%20DNS%20servers%20are%20as%20good%20as%20any%20others%20in%20resolving%20*external*%20requests.%3CHR%20%2F%3E%3C%2FBLOCKQUOTE%3E%0A%3CP%3EI'd%20suggest%20starting%20your%20own%20thread%20as%20opposed%20to%20hijacking%20another.%20Makes%20things%20easier%20to%20follow.%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1923570%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Server%202019%20warns%20No%20Internet%20Access%20after%20AD%2C%20DNS%20and%20DHCP%20setup%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1923570%22%20slang%3D%22en-US%22%3E%3CP%3EI%20found%20that%20my%20member%20server%202019%20was%20having%20this%20issue%2C%20and%20it's%20because%20the%20router%20is%20giving%20out%20IPv6%20addresses%20but%20there%20is%20no%20internet%20access%20on%20IPv6.%20The%20solution%20was%20to%20disable%20IPv6%20on%20the%20network%20adapter%20on%20the%20server%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2270750%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Server%202019%20warns%20No%20Internet%20Access%20after%20AD%2C%20DNS%20and%20DHCP%20setup%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2270750%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F580962%22%20target%3D%22_blank%22%3E%40Luigi_Iotti%3C%2FA%3Etry%20restarting%20the%20Network%20Location%20Awareness%20service%20and%20allow%20it%20to%20restart%20the%20Network%20List%20service%20automatically.%20If%20it%20solves%20the%20warning%20then%20it's%20because%20the%20Network%20Location%20Awareness%20service%20is%20starting%20before%20DNS.%20You%20can%20fix%20this%20by%20creating%20a%20dependency%20using%20the%20following%20command%20from%20an%20elevated%20command%20prompt%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-bash%22%3E%3CCODE%3Esc%20config%20nlasvc%20depend%3DDNS%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2809468%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20Server%202019%20warns%20No%20Internet%20Access%20after%20AD%2C%20DNS%20and%20DHCP%20setup%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2809468%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1025026%22%20target%3D%22_blank%22%3E%40Jason_Pitts%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E1.%20Press%20Windows%20%2B%20R%20keys.%3C%2FP%3E%3CP%3E2.%20Type%20regedit%2C%20click%20OK.%3C%2FP%3E%3CP%3E3.%20Go%20to%20HKEY_LOCAL_MACHINE%5CSYSTEM%5CCurrentControlSet%5CServices%5CNlaSvc%5CParameters%5CInternet.%3C%2FP%3E%3CP%3E4.%20Make%20sure%20following%20values%20exist%20in%20right%20pane%20of%20Internet%3A%3C%2FP%3E%3CP%3E%22ActiveDnsProbeContent%22%3D%228.8.4.4%22%3C%2FP%3E%3CP%3E%22ActiveDnsProbeContentV6%22%3D%222001%3A4860%3A4860%3A%3A8844%22%3C%2FP%3E%3CP%3E%22ActiveDnsProbeHost%22%3D%22dns.google%22%3C%2FP%3E%3CP%3E%22ActiveDnsProbeHostV6%22%3D%22dns.google%22%3C%2FP%3E%3CP%3E%22ActiveWebProbeHostV6%22%3D%22%3CA%20href%3D%22http%3A%2F%2Fwww.msftconnecttest.com%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ewww.msftconnecttest.com%3C%2FA%3E%22%3C%2FP%3E%3CP%3E%22EnableActiveProbing%22%3D%221%22%3C%2FP%3E%3CP%3E5.%20Restart%20Network%20Location%20Awareness%20service%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EReferenced%20from%3A%20Arash.Dargahi%3C%2FP%3E%3CP%3EOn%20domain%20controllers%20using%20127.0.0.1%20as%20their%20primary%20DNS%2C%20run%20the%20following%3A%3C%2FP%3E%3CP%3Ereg%20add%20%22HKEY_LOCAL_MACHINE%5CSOFTWARE%5CPOLICIES%5CMICROSOFT%5CWindows%5CNetworkConnectivityStatusIndicator%22%20%2Fv%20UseGlobalDNS%20%2Ft%20REG_DWORD%20%2Fd%201%20%2Ff%3C%2FP%3E%3CP%3Ereg%20add%20%22HKEY_LOCAL_MACHINE%5CSOFTWARE%5CPOLICIES%5CMICROSOFT%5CWindows%5CNetworkConnectivityStatusIndicator%22%20%2Fv%20NoActiveProbe%20%2Ft%20REG_DWORD%20%2Fd%200%20%2Ff%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Hi all.

 

I have a Windows Server 2019 VM (HyperV) where I setup my first DC. I also setup DNS and DHCP on the server. After deploying these, the yellow warning icon appeared on the network icon in the bottom right corner, and it says "No internet access". Indeed, Internet access seems to be working normally. The only issue is the DNS sometimes unable to resolve certain random domains. It seems that unbinding IPv6 from the NIC almost solved this issue, but the warning icon and the No Internet message remains.

 

I tried the troubleshooting tool. It is unable to diagnose the issue, and suggests a network reset. I did it twice, but it did not change anything.

 

I took a dump of the network packets when the diagnostic tool is run, but I see nothing unusual. It finally connects to http://www.microsoft.com:80/ which I think is the normal way to determine if Internet is available. The server responds 200 Ok and some codes.

 

I don't know where to look further. 

 

My ipconfig /all:

 

Windows IP Configuration

Host Name . . . . . . . . . . . . : SrvApp19
Primary Dns Suffix . . . . . . . : psw.local
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : psw.local

Ethernet adapter Ethernet:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Hyper-V Network Adapter
Physical Address. . . . . . . . . : 00-15-5D-00-78-03
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 10.0.0.112(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.0.0.254
DNS Servers . . . . . . . . . . . : 127.0.0.1
NetBIOS over Tcpip. . . . . . . . : Enabled

 

I attach one of the diagnostic reports.

 

Thank to anyone who can help.

13 Replies

@Luigi_Iotti 

 

Don't unbind IPv6 :) DNS listener binding does use IPv6 too.

 

If it's on boot up, check the Event Log for Event ID 4013 - The DNS server is waiting for Active Directory Domain Services...

 

Normal if you only have the 1 DC and the VM completes the boot process before the services are ready to start. DNS usually waits until AD is complete.   You could always spin up 2nd DC with DNS and point to that and see. 

 

 

 

 

 

 

Same problem here and seen a couple of times already. I'm just testing a W2019 deployment in VMware Workstation. Brought up W2019 server, added DNS, DHCP and promoted to DC. Internet is clearly working as can browse BBC website. DNS settings on the DC look correct - forwarding to the router and using 127.0.0.1 for it's own settings. Also deployed a W10 DC using DHCP and added to domain. It's fine, i.e. not reporting "No internet"

Also noticed that it's on a private network, not the domain network. Wonder if that's part of the problem?

I've got a workaround for this. I appears to be something to do with when you have a single DC where the DNS is configured as 127.0.0.1. With a set-up like this, the "No internet" message occurs although it's clear one has perfect internet access.

 

7F1BT7U[1].png

My workaround is to add the IP address of another DNS server. The upstream router in this example but could equally be 8.8.8.8 (Google DNS):

 

ZzvHoDn[1].png

Once you add that second DNS, the "No internet" message disappears. 

 

In a more normal domain set-up, best practise means you have two domain controllers and DNS servers. In which case, the DC would have DNS settings of 127.0.0.1 (itself) and the IP of the other DNS server.

google DNS knows nothing of your private domain. domain controller should always have at least own static ip address, and loopback (127.0.0.1) listed on connection properties. Never use router or public DNS here. Internet queries are passed on in a top-level down fashion by default to the 13 root hint servers, or optionally any configured forwarders.

 

roothints.jpgforwarders.jpg

 

 

 

 

This fault is nothing AFAIK to do with root hints - they are only ever used when the forwarder DNS server fails or is not configured.

It's some flaw in the check for internet access when running on a single domain controller system. When you promote a member to a domain controller and install a DNS server at the same time, it removes the DNS settings against the NIC, uses that for the DNS server forwarder and replaces it with 127.0.0.1. This works perfectly for everything except for whatever test is being carried out for internet connectivity.

Adding the DNS setting on the DC for an upstream DNS server (e.g. router or Google DNS or OpenDNS) and the check starts working.

The DC itself will refer to itself as 127.0.0.1 is checked first and most of the time will work.

It might be because it's very common for the forwarded DNS server to fail to resolve if it's picked up the upstream router like this. I'm just going to change the forwarder to Google DNS and remove from the static IP configuration to see if that works as well.

 

Z0SdSp0[1].png

 google DNS knows nothing of the internal domain and cannot be used for DNS on server's connection properties. Always use the server's own static ip address plus loopback and no others such as router or public DNS

 

 

 

 

>google DNS knows nothing of the internal domain and cannot be used for DNS on server's connection properties

I'm talking about the forwarders above and Google DNS servers are as good as any others in resolving *external* requests.

 


@rob_nicholson_helios wrote:
>google DNS knows nothing of the internal domain and cannot be used for DNS on server's connection properties

I'm talking about the forwarders above and Google DNS servers are as good as any others in resolving *external* requests.

I'd suggest starting your own thread as opposed to hijacking another. Makes things easier to follow.

 

 

I found that my member server 2019 was having this issue, and it's because the router is giving out IPv6 addresses but there is no internet access on IPv6. The solution was to disable IPv6 on the network adapter on the server

@Luigi_Iottitry restarting the Network Location Awareness service and allow it to restart the Network List service automatically. If it solves the warning then it's because the Network Location Awareness service is starting before DNS. You can fix this by creating a dependency using the following command from an elevated command prompt:

 

sc config nlasvc depend=DNS

 

 

@Jason_Pitts 

1. Press Windows + R keys.

2. Type regedit, click OK.

3. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet.

4. Make sure following values exist in right pane of Internet:

"ActiveDnsProbeContent"="8.8.4.4"

"ActiveDnsProbeContentV6"="2001:4860:4860::8844"

"ActiveDnsProbeHost"="dns.google"

"ActiveDnsProbeHostV6"="dns.google"

"ActiveWebProbeHostV6"="www.msftconnecttest.com"

"EnableActiveProbing"="1"

5. Restart Network Location Awareness service


Referenced from: Arash.Dargahi

On domain controllers using 127.0.0.1 as their primary DNS, run the following:

reg add "HKEY_LOCAL_MACHINE\SOFTWARE\POLICIES\MICROSOFT\Windows\NetworkConnectivityStatusIndicator" /v UseGlobalDNS /t REG_DWORD /d 1 /f

reg add "HKEY_LOCAL_MACHINE\SOFTWARE\POLICIES\MICROSOFT\Windows\NetworkConnectivityStatusIndicator" /v NoActiveProbe /t REG_DWORD /d 0 /f