SOLVED
Home

Server 2016 RRAS setup problems

Alexander Bontenbal
Occasional Contributor

 For a couple of days, I'm trying to set up a VPN server on a new Server 2016 VPS. It's just a standard Server 2016 without any other roles added.

 

When I finish the Routing and Remote Access Server setup, it says the RRAS service is ready to start, when I click on OK it starts the server, but then it's everytime hanging on 'Please wait while the Routing and Remote Access server finishes initialization'

 

No matter how long I wait, it doesn't get beyond that point.

 

Looking at the logs in the event viewer, I got several warnings and errors from WMI:

 

Warnings:
A provide, WebAdministrationProvider, has been registered in the Windows Management Instrumentation namespace Root\WebAministration to use the LocalSystem account. This account ios privileged and the provider may cause a security violation if it does not correctly impersonate user requests.

 

Errors:

Event provider GatewayHealthMonitorProvider attempted to register query "select" from MSFT_GatewayHealthEvent" whose target class "MSFT_GatewayHealthEvent" in ///./root/Microsoft/Windows/RemoteAccess/GatewayHealthMonitor namespace does not exist. The query will be ignored.

 

And then some errors like the above one, but for RAServerPSProvider and RAMgmtPSProvider.

 

Now I have tried it multiple times to set up, even a new install twice, but I can't seem to get beyond this point.

 

Does someone know how to solve this problem?

 

2 Replies
I tried it again and now, after a long time of hanging on the same notification, it said:

An error occurred while trying to start the Remote Access Management service on **servername**. For more information about the error, see Event Viewer.

Now I saw by the system log the following error:

Remote Access Connection Manager failed to start because the Protocol engine (IKEv2) failed to initialize. The call timed out while waiting to acquire the transaction lock.

Not sure what to do about that?
Solution

I had contact with the VPS provider, after some searching, it turned out it was the network adaptor not being compatible with Windows Server. They assigned another type of network adaptor and now it's running as it should be.

Related Conversations