Extended tabs blank

Copper Contributor

I have a Server 2012R2 box that is experiencing an issue that was reported back in Windows 7-Server 2008 period, but the directions to correct the problem back then are not fixing the problem now.

If I open the MMC or the Services there are two tabs at the bottom... an extended or and a Standard.  The Standard tab looks correct, but if I click on the Extended tab it is blank.


I ran the regsvr32 on jscript.dll, mmcndmgr.dll, vbscript.dll but these did not correct the issue.  I read it is possible to a bad install of IE9, but 2012 is on IE11...sooooo....yea.


Any ideas?

9 Replies

@mmaus0891 - It's probably not this simple, but have you gone to File | Options and deleted the files in the console that it is using for services? Then close Services and reopen. 



@Edward Dake I had not tried that yet.  I went ahead and delete the files, but it did not correct the issue.  :(



Someone mentioned possibly trying to Reset the settings in IE to the default and see if that works. 


Internet Explorer | Settings Gear | Internet Options | Advanced Tab | Reset button


If that doesn't work, looks like some have solved it with a Repair install. Hope this helps.



@Edward Dake Looks like we have a GPO that has this button locked out on this server.  I will have to search and find where this GPO is and disable it to reset.  Ill keep ya posted.  Thanks for the advice.

@mmaus0891  - Thanks for letting me know. I wonder if there is some other IE GPO setting that is affecting the snap-in? Interesting!


RSOP or GPRESULT are your friends. Assuming those aren't locked down by GPO as well. :cool:

Hi @mmaus0891,


The Group Policy Objects (GPO) for the MMC console can be found over here:

User Configuration > Policies > Administrative Templates > Windows Components > Microsoft Management Console


There is a GPO that restricts the Extended view, but according to your screenshot that you provided in your initial post it doesn't seem to be anything restricting your MMC console's extended view.


Anyhow the GPO for the extended view is called: Extended View (Web View).




However it's likely that an Internet Explorer GPO could be causing your issue, better check the GPOs applied to your server with: GPresult /H "C:\Temp\GPReport.html"



Best regards,

@mmaus0891 Did you ever figure this one out? I've been battling this on several 2012 R2 boxes.

Im affraid I am still fighting with this myself.


The culprit for me was IE GPO preventing scripts from running.


Computer Management >Windows Components > Internet Explorer > Internet Control Panel > Security Page > Local Machine Zone

  • Allow active scripting - Enabled: Enable
  • Allow binary and script behaviors - Enabled: Enable
  • Run ActiveX controls and plugins - Enabled: Enable
  • Script ActiveX controls marked safe for scripting - Enabled: Enable


It's likely that whoever created the policy was thinking "ActiveX bad" and "scripts bad," but it should be fine to allow them from the local zone since a lot of Windows components depend on them.