Error 0x80242017 when installing KB5004945 from WSUS (but not from Microsoft)

Occasional Contributor

I have several clients running Win 10 v20H2 that are failing to install the update "2021-07 Cumulative Update for Windows 10 Version 20H2 for x64-based Systems (KB5004945) from our WSUS server with "Status: download error - 0x80242017". However, if I manually log into the workstation and "Check online for updates from Microsoft Update", it downloads and installs the update with no errors.


The "Self Contained" cab file for the update is present in the proper directory on the WSUS server, although the two "Express" files are not. The WSUS server is running on Windows Server 2019 v1809.


Here's what I've done for troubleshooting on the client side:


Run Windows Update Troubleshooter: It can't find any issues.

Reset Windows Updates components "manually" using batch script.

Run dism /online /cleanup-image /restorehealth

Run sfc /scannow


2021-07-07 (3).png


I've attached the System and WindowsUpdateClient event logs, as well as the CBS.log and DISM.log from the workstation I'm troubleshooting with.


16 Replies
It seems like there have been corrupted files on the system which has been fixed, did you manage to update after running the SFC command?
Are you able to install other updates?
Nope. Rebooted and retried after dism and sfc, and still failed with the exact same error.
Are they Domain-Joined devices?
If yes, just for test try remove one of them from the Domain and see if the problem persist?
Make sure report this issue through the Feedback Hub app.
Yes, they are domain-joined. I tried removing a client from the domain, then re-importing the WSUS registry settings to point it back at the WSUS server, and it still gives the same error (0x80242017).
Ok, I think I've figured this out. I'm getting the same errors as described. It seems that service stack updates are packaged with the cumulative updates sporadically. The last standalone service stack update I see is from January. However, there was a SSU packaged with the May cumulative update. Without this CU installed (and the embedded SSU) then this cumulative update will not install. The problem from a WSUS perspective is the May CU will be expired and will not installed / flagged as needed if a computer missed it (for instance, offline or whatever).

So, as a test I downloaded kb5003214 from the Microsoft Catalog server. I then extracted using expand windows10.0-kb5003214-x64_ea5dec15d30be080e9aa13c46daa299781b2611d . -F:*

I copied to a computer not updating and ran Dism.exe /online /add-package:c:\

Then I re-ran Windows Update pointed at my WSUS server and it worked.

Credit from this post
See the section titled "WSUS detection and installation problems"

More info can be found at
best response confirmed by JWW-CSISD (Occasional Contributor)
I posted a reply with the answer and it was removed. No idea why. It's a service stack update issue. If a computer missed the May cumulative update then KB5004945 won't install in my experience. The May CU included the latest SSU. Without it, you get 0x80242017

@skilley1425 That did it.


It looks like the issue was happening on newly imaged machines with a base install of 20H2, so when Windows Update tried to skip straight to the 2021-07 CU (KB5004945), it didn't have the servicing stack update from the 2021-05 CU (KB5003173).


I download "2021-05 Cumulative Update for Windows 10 Version 20H2 for x64-based Systems (KB5003173)" from the Windows Update Catalog and manually installed it and rebooted, and after that, KB5004945 downloaded and installed from WSUS with no further errors.


I'd say MS needs to mark KB5003173 as a prereq for installation of KB5004945.



Agree there. Or maybe just include the latest SSU in every CU? It's only 14 MB
I install kb5003173 will prompt “正在处理 1 (共 1) - 正在添加程序包 Multiple_Packages~~~~
[=== 6.0% ]
发生错误 - 错误: 0x80073701”

@skilley1425I have just tested this solution and have installed the KB5003173. Even after a reboot, I continue to get into the error. Are there any other ideas or do I need to do something else? I am clueless

Have you installed the latest CU from the Microsoft Catalog? KB5004237 includes a SSU update it would appear.

@skilley1425I have installed KB5003173, and KB5004945 still fails to install. Or more correctly, it installs but on reboot, it fails to complete and has to roll back. The new KB5004237 fails in the same fashion. It seems there is some component that is checked at restart that is failing and a rollback is triggered. All I can do is clear the Software Distribution folders and pause the updates or else I am bugged with a rollback attempt every time I start my PC.

What you describe differs from my experience, so you may be dealing with a different beast.
Is your error code 0x80242017 or something else?
Hello there. This detailed explanation worked for me. Before I found this post, I tried to install KB5003214 update but failed with this error message: This update is not applicable to your computer. So thank you, problem solved.

@arossi1512.  did you ever make any progress with this issue? we're battling the exact same thing here.....i thought i was making some headway by first manually installing kb5005260 and then kb5003214 , reboot and then 5004237 would install fine but found that doesnt work in all cases and even then the latest 5005033 from august fails at the same 98% post install reboot stage (and takes a good 20-30 min at that stage to undo the changes).  this is getting pretty old !   in our case we were either on 2004 or 1909 and did a 20h2 upgrade w/ the /dynamicupdates set to disabled (to save time and just let wsus handle the updates after like usual) so not sure if that has anything to do w/ this or if microsoft just botched more updates on us here