Alder Lake 12th Gen Intel CPU won't boot on Windows Server 2022 with HyperV enabled

%3CLINGO-SUB%20id%3D%22lingo-sub-3010622%22%20slang%3D%22en-US%22%3EAlder%20Laker%2012th%20Gen%20Intel%20CPU%20won't%20boot%20on%20Windows%20Server%202022%20with%20HyperV%20enabled%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3010622%22%20slang%3D%22en-US%22%3E%3CP%3EMy%20PC%20has%2012700K%2C%20ASUS%20Z690%20mainboard%2C%2064GB%20DDR5%2C%26nbsp%3B%20and%20Samsung%20980Pro.%20I'm%20trying%20to%20run%20Windows%20Server%202022%20on%20it%2C%20but%20it%20will%20not%20boot%20when%20I%20enabled%20Hyper-V.%20It%20will%20boot%20fine%20without%20Hyper-V%20role.%20I'm%20just%20wondering%20if%20anyone%20had%20tried%20coupling%2012th%20CORE%20and%20Server%202022%20OS.%20Does%202022%20handle%20the%20Performance%20Cores%20and%20Efficient%20Cores%20well%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-3010622%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EHyper-V%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

My PC has 12700K, ASUS Z690 mainboard, 64GB DDR5,  and Samsung 980Pro. I'm trying to run Windows Server 2022 on it, but it will not boot when I enabled Hyper-V. It will boot fine without Hyper-V role. I'm just wondering if anyone had tried coupling 12th CORE and Server 2022 OS. Does 2022 handle the Performance Cores and Efficient Cores well?

5 Replies

Doesn't look to be supported.

TUF GAMING Z690-PLUS WIFI D4 | Motherboards | ASUS Gloabl

Windows Server Catalog

this does not mean it cannot or won't work but does mean the process of testing / vetting all components is left to the end user to do.

 

 

I've upgraded my home server to alder lake (12700k) recently and ran into the same problem. It couldn't boot into my Windows Server 2019 install.

I've had to disable the efficiency cores in the bios. Windows Server doesn't seem to play nice with them.

It's now been running fine for a month with only 8 Performance Cores. It's a bummer that I can't use the 4 efficiency cores, but it's still been a huge upgrade over the amd 3700x i've had in it before.

I've also tried running Windows Server vNext (Windows 11 Kernel) and it couldn't boot either. The kernel most definitely supports hybrid cores so I'm a bit confused on what the problem could be. I find it interesting that you can boot into Windows Server with Hyper-V disabled, as I couldn't even boot into vNext at all. Maybe the Hyper-V Service was enabled by default on my install.
Thanks. It works.
Why Hyper-V uses kernels that are not designed for it. It is very strange that Windows server is not patched for new processors
 It is very strange that Windows server is not patched for new processors

Well not really since it has never worked like that. The burden of testing / vetting the hardware and submitting for certification has always been on the manufacturer to do.

Windows Hardware Compatibility Program | Microsoft Docs

 

 

Server runs on the alder lake but hyper-v can be installed but only with the bcdedit /set hypervisorlaunchtype off setting and this means you can't start the VM error message hypervisor is not running.  Personally I find it strange that hyper-v is not supported on a new CPU.