quick assist deployment thru Powershell-GPO

Contributor

Since that Microsoft is turned with quick assist to the Windows Store we cannot use Quick assist anymore. I cannot install  / deploy it thru Powershell whatever i try thru GPO, manual, scheduled task etc, it will not work. The only way that the install succeeds is when go to the Store and download and install it when i am an admin. But i want to deploy Quick Assist thru Powershell...

 

What i tried:

#sets switches

param

(

[Parameter(Mandatory=$false)][Switch]$Install,

[Parameter(Mandatory=$false)][Switch]$Uninstall,

[Parameter(ValueFromRemainingArguments=$true)] $args

)

 

#Log output results

function LogOutput($Message) {

$LogFile = "C:\temp\Quick-Assist.log"

"$(get-date -Format 'MM/dd/yyyy HH:mm') $($Message)" | Out-file -FilePath $LogFile -Append -Force

}

 

#Start of Script

If ($Install){

Try {

LogOutput "***This script is used to install the new Quick Assist app that is from the Microsoft Store. It will also remove the old version***"

$InstallAppX = Get-AppxPackage -allusers MicrosoftCorporationII.QuickAssist

If ($InstallAppX.status -eq 'OK'){

LogOutput "[Info] Windows Store version of Quick Assist is already installed"

#lets uninstall the old version.

LogOutput "[Info] lets uninstall the old version"

Remove-WindowsCapability -Online -Name 'App.Support.QuickAssist~~~~0.0.1.0' -ErrorAction 'SilentlyContinue'

LogOutput "[Info] Old version of Quick Assist has been uninstalled"

}

If ($InstallAppX.status -ne 'OK'){

LogOutput "[Info] Installing the Windows Store version of Quick Assist..."

Add-AppxPackage -Path "c:\quickassist\MicrosoftCorporationII.QuickAssist.AppxBundle"

#Add-AppxProvisionedPackage -online -SkipLicense -PackagePath '.\MicrosoftCorporationII.QuickAssist.AppxBundle'

LogOutput "[Info] Attempting to remove the old version of Quick Assist..."

Remove-WindowsCapability -Online -Name 'App.Support.QuickAssist~~~~0.0.1.0' -ErrorAction 'SilentlyContinue'

}

LogOutput "[Success] The Windows store version of Quick assist has successfully installed and the old version has been removed."

} catch [exception] {

LogOutput "[Error] An error occurred installing Quick Assist: $($_.Exception.Message)"

}

}

 

We are using windows 10 21h1-2

 

Problem with this script is also that it says it removes the old version and installed the new version successfully, and when i look with get-package.... it also states that quick assist package is installed, but it is not in the startmenu anymore....

How can i deploy quick assist best for many computers without Intunes or sccm?

 

5 Replies

We have the same issue and have tried the same steps as you. The best reference found so far is https://droidkid.net/2022/05/17/powershell-script-to-install-the-new-quick-assist-silently/ @Surfer10 

Hi, i tried that but for some reason, when executing the script remotely it does not work, errors out with paramtre is incorrect..

@Surfer10 

I just made a simple batchfile that seems to work fine:

DISM.exe /Online /Add-ProvisionedAppxPackage /PackagePath:".\QuickAssist.AppxBundle" /SkipLicense

Hi bgiroux,

When i do this under account administrator dos prompt it gives me a error (when running batchfile it does nothing so i give the dism command in a elveated dos prompt) :
Image version: 10.0.19043...

Error: 2

The system cannot find file specified.

Logfile can be found....

@lloydpc 
See her how it is done on Windows Servers that by default do not have access to the Windows store, but the Appx package is also available in PowerShell.  https://youtu.be/SFhWP66AyEM 

You are all probably used to only know the Quick Assist tool from Microsoft for Windows 10 or Windows 11, but it can be installed on Windows Servers as well. In this video I show you how to do that. Find and grab get the standard PowerShell script Quick-Assist-Package.ps1 from Droid Kid that you ...