Windows update error 0x800f081f

Copper Contributor

I am trying to install the KB5000842 and i get the 0x800f081f error over and over. any solution for that?

17 Replies


Are you able to download and install other updates?

Take a look at Windows Update Troubleshooter for Windows 10 (

Hello @AdelSamir


Please run Windows Update troubleshooter from Settings app > Update & security > Troubleshoot > Additional troubleshooters. See if it works.


If that doesn't work, try this:


Open administrative Command Prompt and type following commands one-by-one followed by Enter key.


net stop wuauserv

net stop cryptSvc

net stop bits

net stop msiserver

Ren C:\Windows\SoftwareDistribution SoftwareDistribution.old

Ren C:\Windows\System32\catroot2 Catroot2.old

net start wuauserv

net start cryptSvc

net start bits

net start msiserver


Close Command Prompt and see if Windows Update installs then.


Let us know if this helps!

@Kapil Arya 

Thanks for your reply. I tried the mentioned steps, but they didn't solve the problem.

The windows update troubleshooter didn't find any problems

Open start and search for cmd or Command prompt and right click on it and run it as administrator and then type the following command:


sfc /scannow


Press enter and let it runs and see what is the result.

What's your current Windows 10 version/build?
same problem here
Beta channel?
Windows 10 pro 21H1 Build 19043.899



I did clean install Windows 10 Beta from ISO the other day and installed that update successfully.




so the problem you are facing is probably due to something happening in the past (or in rare cares hardware related which is unlikely imo)

I would do a Reset to take care of it. (choose to delete contents of Windows partition when asked)

Unfortunately i can't afford to do a clean install now and lose my personal files and apps
The scan didn't find any problems
"Windows Resource Protection did not find any integrity violations."

Try open start and search for feedback and open the Feedback Hub app and report this issue.

scanning system files is the most basic thing, it's never fixed any problem for me, ever, not a single time.
the tool is probably not thorough enough and only quickly scans some common files.
feedback hub is not a 2-way discussion though. it's be better if there was a solution.
I tried doing it. But it gives me a message "System error 5 has occurred. Access is denied."