Windows Security won't open on Windows 11

Copper Contributor

I have tried everything I can think of, I've had two friends who deal with IT problems look at my computer via shared screen with no luck. Since updating to Windows 11 I never noticed Windows Security would not open until recently, it's active and running in the background in Task Manager. I've tried the Powershell and CMD hotfixes, I've reset my PC locally and cloud but I have no restore or recovery points prior to the Windows 11 update. My PC is up to date on all firmware from Microsoft but Windows Security still will not open. Windows Security nor Windows Defender is not listed under my "Installed Apps" or "Default Apps" so I can't try a drop down repair on it. It does show within my Task Manager that there is Windows Defender engine running and in the hidden icons tab it shows Windows Security active. How do you fix this without having to lug your whole PC to a shop?

67 Replies

@TayDean 

 

You can try the following steps to resolve the issue:

  1. Run the Windows Security Troubleshooter: Go to Settings > Update & Security > Troubleshoot. Find and run the Windows Security troubleshooter.

  2. Repair Windows Security using DISM: Open Command Prompt as administrator and run the following commands: DISM.exe /Online /Cleanup-image /Restorehealth DISM.exe /Online /Cleanup-image /StartComponentCleanup

  3. Re-register Windows Security apps: Open a Command Prompt as administrator and run the following commands:

    powershell -ExecutionPolicy Unrestricted Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

  4. Reset Windows Security app: Go to Settings > Apps > Apps & features. Find Windows Security, and click Advanced options. Click Reset.

If none of these steps work, you may need to perform a clean install of Windows 11 to resolve the issue.

 

(external link removed by moderator)

Hello,

See if this fix helps you:

https://www.kapilarya.com/fix-windows-defender-wont-open-in-windows-11

Keep us posted!

Note: Included link in this reply refers to blog post by a trusted Microsoft MVP.
it worked, thank you
I tried all 6 of them, 2 times
Still windows security is blank.

Same here@TAHSN 

@TAHSN what kind of blank? The app opens but blank window, or the app doesn't open? Because mine doesn't open.

Doesnt open for me either @jpara_dise 

@ShahbazUbaid my windows license is already expired. and i am not getting any security updates ever since. and that is also the time where i noticed that my windows security app won't open. is it because of my windows license bein expired? do you think if i reactivate my license, it will solve my problem?

 

 @TayDean It's early 2024 and I am in the same boat since the most recent update. In all their wisdom, Microsoft has removed Troubleshooter with this update and wants me to contact tech support. The last time I did that, I was 77 people away from help. I do not have that kind of time. 

I've tried all the suggestions here except reinstalling Windows, which is a major hassle and would require hunting down the software I use for work and reinstalling it too.  I had to do this once last week because a previous update crashed my computer. It created all manner of work-related issues. 

This is really dumb and Microsoft should have fixed this already.  But I'm open to more suggestions. 

I've found a workaround for this.

Get-AppxPackage Microsoft.SecHealthUI -AllUsers | Reset-AppxPackage

 

Type the above command into Windows Powershell (as admin) and once it shows that the command os executed (should be instant), restart your device and your Windows Security should work now.

 

The only issue is that you'll have to redo this once you shutdown your device (at least in my case) @MaryPaddock 

No, I don't think that's the issue. This is just some stupid bug. I've typed out a solution to this problem in the comment below this. Check it out and see if it works.

@ShahbazUbaid  I appreciate the suggestion, but it didn't work. I'd actually tried it already along with a host of other suggestions found in other places, but thought I'd missed something. I did not. 

I'm fairly sure I'm going to have to reinstall Windows again to fix this. It will have to wait until the weekend as I work full-time from home and this has eaten up far too much of my time as it is. 

Exceedingly frustrating. 

I am in the same boat after the lastest update. I've tried everything, including factory reset (twice). Still locked out.@MaryPaddock 

This should work. It's actually a simple fix. Everyone is over complicating it. There was a bug in the latest release.

https://youtu.be/yQMpkEj_wo4?si=tzzpmqSGVmiWpjBk

Kindly share to others if you know of anyone with the same issue.
This should work. It's actually a simple fix. Everyone is over complicating it. There was a bug in the latest release.

https://youtu.be/yQMpkEj_wo4?si=tzzpmqSGVmiWpjBk

Kindly follow the steps and share to others if you know of anyone with the same issue. :) Thank you.

I watched your YT video and looked down below for the link and tried to click on it, however, its showing as just plain text and not an actual link.@Vinod444 

@AndrewSennis You will have to copy the link and paste it into a browser window. Thank you. Good luck!

I understand that. The link is incomplete and ends with ....

Browser doesn't recognize links that end with ....