Windows defender app

%3CLINGO-SUB%20id%3D%22lingo-sub-2310021%22%20slang%3D%22en-US%22%3EWindows%20defender%20app%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2310021%22%20slang%3D%22en-US%22%3E%3CP%3EIn%20de%20laatste%20update%20(21370)%20krijg%20ik%20als%20ik%20de%20defender%20open%20steeds%20dat%20ik%20een%20nieuwe%20app%20moet%26nbsp%3B%20installeren.%20Deze%20is%20dan%20vervolgens%20niet%20in%20de%20Store%20te%20vinden.%3C%2FP%3E%3CP%3EHeeft%20iemand%20een%20oplossing%3F%3CBR%20%2F%3EH.J.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2310431%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20defender%20app%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2310431%22%20slang%3D%22en-US%22%3EI'll%20switch%20to%20English%20to%20get%20more%20reaction%20%3B)%3C%2Fimg%3E%3CBR%20%2F%3EHow%20do%20you%20manage%20your%20machines%3F%20are%20you%20talking%20about%201%20device%2C%20or%20multiple%20devices%3F%3CBR%20%2F%3EWindows%20versions%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2310681%22%20slang%3D%22en-US%22%3ERE%3A%20Windows%20defender%20app%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2310681%22%20slang%3D%22en-US%22%3EHi%20Mathias%2C%20I%20have%20a%20standalone%20Shuttle%20SH170R6%20Windows%2010%20Pro%20N%20Dev%2021370.1%20Windows%2010%20Feature%20Experience%20Pack%20321.9601.0.3.%20I%20have%20the%20same%20version%20on%20my%20HP%20laptop%20and%20on%20this%20machine%20works%20it%20normal.%20Henk%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2310683%22%20slang%3D%22en-US%22%3ERE%3A%20Windows%20defender%20app%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2310683%22%20slang%3D%22en-US%22%3EI%20have%20olso%20long%20times%20problems%20with%20de%20latest%20Update%20.NET%3C%2FLINGO-BODY%3E
Occasional Contributor

In de laatste update (21370) krijg ik als ik de defender open steeds dat ik een nieuwe app moet  installeren. Deze is dan vervolgens niet in de Store te vinden.

Heeft iemand een oplossing?
H.J.

16 Replies
I'll switch to English to get more reaction ;)
How do you manage your machines? are you talking about 1 device, or multiple devices?
Windows versions?
Hi Mathias, I have a standalone Shuttle SH170R6 Windows 10 Pro N Dev 21370.1 Windows 10 Feature Experience Pack 321.9601.0.3. I have the same version on my HP laptop and on this machine works it normal. Henk
I have olso long times problems with de latest Update .NET

@henkwehe

 

If it is a standalone machine, try checking for updates via the settings UI, and via the store app. Make sure all is up to date and there are no pending updates.
Maybe stupid, but "have you tried turning it off and on again" :rolling_on_the_floor_laughing:

 

If that doesn't work, try to scan for corrupte files using the sfc /scannow command...

 

henkwehe_0-1619790390722.pnghenkwehe_1-1619790459190.png

this is the problem, it look like a lope

 

@Matthias Vandenberghe 

Did you try the SFC command?
Do you have other AV software installed on your machine?
I have running the DISM command but it have not any effect.
Hi,
can you run this command in an elevated PowerShell and post the results here?
Get-MpComputerStatus

@HotCakeX Doesn't this only give the status?

I think there will be some corrupted files... or a failing update....

Had something similar in the past... Think I needed to reset the store app as well in that case. (wsreset.exe)

what i would do in this case:

1. check if there are pending updates via updates in the Settings UI

2. check for pending updates in the store app

3. sfc /scannow if still not resolved

4. wsreset

5. check for updates again

 

If still nogo, then further analysis will be needed...  Maybe some policies or settings are left on the machine due to earlier installations, file type asociation which are wrongfully configured, other security software preventing normal behaviour.

 

But this is my opinion, didn't have any handons on the system :smile:

if the AV is running then OP can wait for the next build to possibly fix the app's GUI problem. if not running, perform a cloud reset (because it's not safe to stay without AV)

indeed... you're correct

henkwehe_0-1620291292422.png

The result of the adviced command
Thanks for thinking for/with me

@HotCakeX 

O sorry this is my normal working Laptop. To morrow i show te desktop list.
Thanks, everything seems to be ok and WD components are running, hopefully next dev build will fix the UI problem
Thanks everyone for his or her contribution, te latist buil solvd the problem as someone predictid.
Thanks a lot
Henk
Good to hear, you're welcome ^^