Windows 11, version 22H2 Insider Preview 10.0.22598.100 (ni_release)

Iron Contributor

Hello Everyone ! I am back almost a year with a new discussion. I am having an issue with latest Windows 11, version 22H2 Insider Preview 10.0.22598.100 (ni_release). The downloading gotten stuck at 99% and won't move to 100% and won't get installed. All the previous releases went successful. I am desperately looking for a help. I hope all my community buddies doing well :)

Screenshot attached !




26 Replies
I am getting a very similar issue, although my download is getting stuck at 98%. Left it for several minutes and no sign of it moving.
I got stuck on 100% now and its been a while now. More then 3 hours installation has not started yet




I had similar issue with installing version 22H2 Insider Preview 10.0.22598.100 (ni_release) and tried everything to sort it, inc disabling antivirus, updating drivers, sfc /scannow, turning secure boot OFF etc, deleting Software installation folder etc.


What worked for me was turning OFF all (i mean everything) features in 'Turn Windows Features On or Off'. After I did that, the install worked fine, so give that a go.



how much mobile data it requires? @Jauhar 



Mine downloads OK, then installs, and hangs on the MSI logo when rebooting... won't get past that and I've left it for several hours. Force shut down (holding power button) and it rolls back to the previous version.

After upgrading to the latest windows11 beta, my laptop's external monitor didn't display properly.@Jauhar 


I have the same behavior, ASUS MB. AMD 5900X CPU. 0xc1900101

I found this thread via google, it appears to be miscategorized.


Mi equipo HP AMD Ryzen 5 5500 8gb ram ssd 250GB  luego de descargar e instalar y al reiniciar el equipo se queda colgado en logo HP.

Por lo que estuve leyendo (no se otros casos)la mayoría les ocurre en AMD Ryzen que ya venia teniendo problemas en las pantallas al cambiar de resolución en algunos juegos.

Creo se deberá aguardar que Microsoft resuelva este problema.

I just unchecked Hyper-V in Windows resources and it worked fine for me.


Hello friend you are welcome again!

The error you wrote about concerns many people, currently no universal solution has been confirmed, probably this thread will be moved by the Moderator to the right place according to the topic there are a lot of similar threads 

Microsoft receives diagnostic data automatically so it will probably release a fix.

 Windows Insider Program - Microsoft Tech Community



I am having the exact same issue. On a Asus x570 dark horse. I've tried multiple fixes and nothing has worked. Just hangs at bios splash screen. Bios code is F3. 

You may need to turn on Virtualization under that ASUS Bios. I had a similar situation installing 22H2 with the same boot hang.

After turning it on went to reinstall the update and it worked without an issue.


Worked like a charm! thanks for the info!

Enable virtualization in your MSI bios

It’s under advanced>motherboard settings>Something along the lines of “enable SV”

My setting change allowed me to update successfully! 

you should be good to go after that!