Windows 11 start menu is missing Explorer bug?

Copper Contributor


I have been using the new Windows 11 Insider Preview with satisfaction for several weeks.

Unfortunately, bugs since the last update, probably the Explorer process, every time after logging in, the Explorer (i.e. the icons at the bottom right and the desktop icons) briefly flickers and I see a thousand reports in the task manager on Microsoft processes that require almost 100% CPU, But that will happen after a few minutes.

When that has loaded, I only have the problem that I cannot open the start menu and that when I try the settings etz. to open an error message comes up.


If there is no way to solve the problem in the near future either, I wanted to ask if there is any way to downgrade without losing the data.


Hope you can help me here.



14 Replies
Hi Chris,

I had the same issue when I was clicking the clock or notification tray that the tskbar would just crash and restart. Tskbar is part of the explorer.exe, and it seems it was fixed in the lastest patch.

Please make sure you are on the lastest Windows 11 Dev channel update, go to Update and check for updates. Also, if you click windows insider in the same page, it will tell you if you ar eup to date.




Thanks for the answer,
unfortunately do not open the settings, because then the error:


There is no app associated with the file to perform this action. Install an app, or create a mapping on the default app settings page if an app is already installed.



I don't know how to check for updates or the current version, let alone make updates.

Kind regards

I have:
Version 10.0.22000 Build 22000

Hi Chris,

Oh no, that is very bad, it seems there is no direct official Microsoft download for the KB update for you to get to 22000.100 as of yet.

So, can you please try the admin terminal with pswhell and use this command. Powershell:

Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

This will reinstall all the Universal Windows Apps, including Settings.

So please make sure the only app you have open is Admin Terminal (powershell) or you may use the normal Powershell Admin.

Since it is reinstalling all the UWA's, you need to only keep Terminal open so everything else can be fixed.


Also try in CMD: Sfc /scannow and the DCISM restore health cmd, you can Bing that help.

Let be know if this works, also try startup repair in repair mode, do you have a system restore, that is all I can find to offer.

I do not recommend using 3rd party sites to download this KB update or any ISO.

Thank you :)

Hope that helps,

Warm Regards,




Also you can check the version of Windows in , Windows key -> Winver



When I try to run the powershell command I get this error:
Get-AppXPackage: The term 'Get-AppXPackage' is not recognized as a name of a cmdlet, function, script file, or executable program.
Check the spelling of the name, or if a path was included, verify that the path is correct and try again.


Is there a way to open the control panel from powershell or task manager so I can check for updates?



I got the control panel started via powershell, but couldn't find anything helpful there.
When I click on Computer->Open Settings in File Explorer nothing happens beyond File Explorer appearing to hang.
Has Win11 bricked itself? What's the best path to recovering use of the computer?

Use CTRL-ALT-DEL and choose to open Task Manager.
Choose "More details" at the bottom of Task Manager to expand Task Manager.
Go to "File" and choose "Run new task".
Type "cmd" in the "Open" field.
Paste the following: reg delete HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\IrisService /f && shutdown -r -t 0
It should restart the machine and you will see the start menu

That seems to have worked, thanks --

Is anyone still having problems with this? I really am, I've tried both copying and pasting the Iris process thing into command and also restarting explorer from the task manager and each only works 1/20 times and it's driving me mad. Any other tips?

@GregTheEgg this is still happening for me too, even in the "stable" final version.

@cfcornejo Hello,
to the best of my knowledge, this is an error when installing the update. The only way I know of solving the problem is to try another update or reinstall Windows.

I've been having this issue on my brand new computer and have tried every solution on the internet with no success. Does Microsoft read these posts? Have they spoke about this and recommend a fix? This really isn't a good image of their company when their new flagship desktop OS is broken and nothing is being done about it!
I have been having this exact issue every time I have to restart my PC. Using the command will get it to work part of the times and restarting explorer.exe only seems to work on the 3rd reset of the PC. How is this still an issue on the official release??