Windows 11 installation error

%3CLINGO-SUB%20id%3D%22lingo-sub-2795055%22%20slang%3D%22en-US%22%3EWindows%2011%20installation%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2795055%22%20slang%3D%22en-US%22%3EError%20code%200x80070002%20-0x20007%2C%20the%20installation%20failed%20in%20the%20safe_os%20phase%20with%20an%20error%20during%20INSTALL_DRIVERS%20operation.%20how%20to%20fix%20this%3F%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2816205%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%2011%20installation%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2816205%22%20slang%3D%22en-US%22%3ESame%20here%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2816943%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%2011%20installation%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2816943%22%20slang%3D%22en-US%22%3E%3CP%3ESame%20here.%20Dell%20Laptop%26nbsp%3BIntel(R)%20Core(TM)%20i7-8750H%20CPU%20%40%202.20GHz%202.21%20GHz%3C%2FP%3E%3CP%3EDutch%20Windows%2011%20version.%20Great%20Microsoft%2C%20the%20second%20PC%20i'm%20trying%20(first%20PC%20didn't%20have%20a%20supported%20CPU)%20and%20it%20doesn't%20work....%20Going%20to%20look%20at%20it....%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2817335%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%2011%20installation%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2817335%22%20slang%3D%22en-US%22%3ESame%20here%3A%20Samsung%20Galaxy%20Book%20Flex%20Alpha%2C%20Intel%20Core%20i7-10510U%20-%2012GB%20Memory%20-%20512GB%20SSD%2C%20tried%20the%20downloadable%20update%203%20times%2C%20then%20update%20from%20USB%2C%20didnt%20work.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2818010%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%2011%20installation%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2818010%22%20slang%3D%22en-US%22%3E%3CP%3ESyncing%20Time%2C%20checking%20system%20files%2C%20removing%20update-files%20doesn't%20work.%20Same%20error%20on%20my%20Dell%20XPS%20laptop.%3C%2FP%3E%3CP%3ETried%20updating%20a%20Dell%20Vostro%2014%2C%20CPU%20not%20supported%2C%20tried%20HP%20Envy%20(2016)%2C%20CPU%20not%20supported....%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETerrible...%20Why%20does%20the%20message%20about%20not%20supported%20CPU%20show%20up%20if%20the%20process%20has%20been%20running%20for%20about%2015-30%20minutes.%20Why%20not%20at%20the%20start%3F%20I'm%20going%20to%20see%20if%20I%20can%20edit%20the%20installer%20so%20that%20I%20can%20try%20to%20install%20it%20anyway.%20Unknown%20why%20these%20CPU's%20aren't%20supported...%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESeems%20that%20MS%20'forces'%20a%20lot%20of%20people%20to%20buy%20new%20hardware%20just%20because%20of%20this%20upgrade...%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2818998%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%2011%20installation%20error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2818998%22%20slang%3D%22en-US%22%3E%3CP%3EHP%20spectre%20laptop%2C%20get%200x80070002%200x20007%20safe_os%20install%20drivers%20every%20time%20i%20try%20to%20upgrade%20to%20windows%2011.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor
Error code 0x80070002 -0x20007, the installation failed in the safe_os phase with an error during INSTALL_DRIVERS operation. how to fix this?
18 Replies
Same here

Same here. Dell Laptop Intel(R) Core(TM) i7-8750H CPU @ 2.20GHz 2.21 GHz

Dutch Windows 11 version. Great Microsoft, the second PC i'm trying (first PC didn't have a supported CPU) and it doesn't work.... Going to look at it....

Same here: Samsung Galaxy Book Flex Alpha, Intel Core i7-10510U - 12GB Memory - 512GB SSD, tried the downloadable update 3 times, then update from USB, didnt work.

Syncing Time, checking system files, removing update-files doesn't work. Same error on my Dell XPS laptop.

Tried updating a Dell Vostro 14, CPU not supported, tried HP Envy (2016), CPU not supported....

 

Terrible... Why does the message about not supported CPU show up if the process has been running for about 15-30 minutes. Why not at the start? I'm going to see if I can edit the installer so that I can try to install it anyway. Unknown why these CPU's aren't supported... 

 

Seems that MS 'forces' a lot of people to buy new hardware just because of this upgrade... 

HP spectre laptop, get 0x80070002 0x20007 safe_os install drivers every time i try to upgrade to windows 11.

I have an installation error also, @Srini4594 
It says my computer (a brand new Microsoft Surface Studio 2) is not compatible, due to my processor [Intel(R) Core(TM) i7-7820HQ CPU @ 2.90GHz 2.90 GHz] when the requirement indicates 1GHz...

I have found the Solution for Windows 11 installation failed error 0x80070002 -0x20007 !!! It is basically a problem of driver failing to install itself on Windows 11. In my case it was the driver for Western Digital Passport external hard drive driver.

Now, the question arises how I came to know which driver to delete? I searched online for a few days to find that I can learn about it in the Windows logs. They are a bit difficult to access, but you can do it.

First, you need to go to folder options of Windows explorer and allow windows to show hidden files and system files. Then you have to go to "$Windows.~BT\Sources\Panther" and you have to find a file named "setupact.log"

Now it would be a big-**bleep** log file which you need to open up (it took around 1 minute to open completely). Go to the bottom of the log file to see which driver forced the installation to fail. For me it was a driver from a folder named "system32\driverstore\ WDSCAMxAMD64\wdscam.ini" or something like that.

Now all I did was to go to system32\driverstore and find the folder in which the cursed WD drivers were kept, and delete the folder permanently.

For others, the driver could have a name like PeePoo.ini or something; you can always google that stuff to see which company makes those drivers. Remember to look for paths of corrupt drivers at the bottom of the log.

But I faced a problem, that I could not delete the file because it was owned by the system. So you will have to right-click the folder and click security and then edit the settings to make yourself the owner, and give yourself full control of the bad boy. (You can see a video on YouTube for a detailed method to delete system folders.)

Lo and behold! My Windows 11 installed finally after weeks.

@youaremine Having similar problem with Reaktek audio drivers presently. Except I can't seem to take ownership. Even with an elevated file explorer. I'm the only user of this PC and have admin privilege's and it's all grayed out.

@rcurci2  Ok you follow these steps

 

1) go to system32\driverstore\filerepository to find the folder with the naughty drivers.

2) right click to show Security tab

3) click on Edit

4)then select EVERYONE

5) then, in the bottom part of the window, select the checkbox for full control.

6) Now try to delete or move the folder to somewhere else.

7) restart your computer

8)Now run the downloaded Windows 11 ISO setup. (allow it to update and everything)

 

After this step, the Windows 11 installed smoothly for me!

 

youaremine_0-1633891832767.png

 

I found an article to help me. This was a little more advanced than I was used to. I will try again now. Thank you in advance
Thanks, that was exactly what I searched days for now - in my case it was the igcc_dch.inf (Intel graphics command center) driver that prevented me of upgrading to Win11. Thanks a lot, awesome!!
You are welcome. Now I am starting to realize why Microsoft wants to delay the rollout of Windows 11 on laptops and PCs until 2022. It's because of all these driver conflicts. But We are too impatient to wait for another 4 months.
How do I know which folder to delete? I know this sounds like a dumb question.

@mstrada  If you read my original comment, you will know how to know the identity of the driver and the folder in which its located. 

In short, you have to access a log file located in "$Windows.~BT\Sources\Panther". You will have to go to Windows explorer's view settings, to allow hidden items to be shown, in order to access this directory. Under this directory, you will have to open the file name setupact.log.

Now here is the slightly tricky part:

1)  You will have to open the log file with notepad.

2) Wait for the note pad to completely load the log file, as it can be large in size. (In my case it was around 50MBs.

3) Now the relevant information regarding drivers that are causing Windows 11 installation to fail, are located at the bottom of the log file. In order to directly jump to the end, press the CTRL key and then press the END key. 

4) Now you should start reading the log file from the bottom up. Keep reading every line for 5 to 10 minutes, until where you start to see Windows errors 0x80070002 -0x20007 alongside of some driver paths. In my case, the driver folder was something like System32\driverstore\filerepository\WDScamxAMD64\wdscam64.sys or something similar

 

5) now the moment I saw the line in the log that mentioned WDscam, I knew it had something to do with the Western digital and their crap software.

6) You dont necessarily need to know the origin of the driver, because your mission is to just delete the folder you just discovered in the log file.

7)Just go to the System32\driverstore\filerepository, and find the folder, and delete it. 

8) Remember, you won't be able to delete the file easily as it is a system file. For that purpose, you can refer to my original comment, on how to gain full access to system folders.

9) Your windows 11 should now install easily.

10) if it fails with the same error, repeat the process, because there might be some other bad driver in conflict with Windows 11.

I have full control in the System as administrator but it still will not let me delete. I did find the right file to delete.

I Just received the same error:


We couldn't install Windows 11

We've set your PC back to the way it was right before you started installing Windows 11.
0x80070002-0x20007
The installation failed in the SAFE_OS phase with an error during INSTALL_DRIVERS operation

The failing driver for me was: RealtekService.inf

Your solution worked for me,

Thanks

Glad I could help.