Windows 11 ARM Microsoft 365 broken login - Outlook "unable to connect right now"

Copper Contributor

Hi all, HNY


Came back from holiday to see that my Company Policy required to change my AD password as 4 months had passed. Did that on a Win 11 PC, no problems. Outlook showed 'trying to connect...' and 'Need Password', which when clicked opened the Microsoft 365 login page requesting the updated password etc.


Moving to my Win 11 ARM machine (build 25267.1000) and opening up Outlook, I immediately get a pop up saying "we are unable to connect right now". Clicking the 'Need Password' opens up the same dialog again.


I have tried to create a new profile using Control Panel->Mail, but the Add new account is again unable to Connect to the Mail server. My other Windows 11 PC Laptops work as expected from the same connection, so it is not a network issue.


Has anyone else noticed the latest Dev build breaking the Microsoft 365 login process? Have tried downgrading Office 365 two builds to see if that was the problem, but it is not.



4 Replies
Same problem still with build 25272 (Jan 5). For now I'm running on a backup copy of 22000 which shows the password dialogues correctly.
Same for me with build 25276.1000.

@jvravensberg It is ridiculous that after 2 different bug reports and 3 Dev Releases, this is still unfixed. It is also giving a "No Internet Connection" error in all Office apps and you are left unable to activate them in case of new installation.


Builds before December work with no issue and once you update, problem appears.


Seems the priority in Dev builds at the moment is how long to hover with your mouse before snap options for windows appear!


Build 25300 still same crap