W10-1903 UNC path failing 0x80070043

Copper Contributor

I can no longer access network shares through unc paths \\server\share I get the 0x80070043 "Network name cannot be found" error.


I suspect that this is related to the removal of Homegroups? but surely it was not intended to break basic UNC functionality, or am I missing something?

97 Replies

@dwatsonMany thanks for this. This has fixed my issue for now.

Just answering my own question - it looks like completely disabling SMBv3 on FluidFS is a workaround.  Not great, but at least it gets things working again.

Any updates on this? Thanks


Dell EMC just released an official KB about this:


DTA 534173: Dell EMC Unity: Windows users may be unable to access Common Internet File System (CIFS)...


They still recommend to downgrade to 3.0.2 or to go back to 1809 on the clients but it says that they are investigating an enchancement to adress this issue.




Same issues here with a Dell FluidFS compellent storage backed system.  When you mentioned setting the max protocol to version 3.0.2 is that something the Dell support guys had to do?  I only see the option to fully disable v3.



I think it's only possible to downgrade to 3.0.2 if your running on a Unity platform.
There is instructions provided for Unity in this kb: DTA 534173
For Compellent; it seems like you have to disable v3.
Thanks, that makes better sense. Hopefully they don't leave the Compellent customers hanging.

I'm not able to get by the login piece to those KB articles.

In reading its still not clear to me if Dell is saying this is a Microsoft problem, or if Dell is actively working on a fix for their systems?



You should make a SR to Dell EMC about Compellent if you haven't done it yet.

Seems like Dell EMC are working to address it; at least on the Unity platform.


From the kb:

"Dell EMC is investigating an enhancement to address this issue. Dell EMC will update customers once more information on this enhancement becomes available to customers under current Dell EMC maintenance contracts."



Case opened with them on the Compellent side.  To hear it from the rep I spoke with they just learned about this last week.  For anyone else who using the FluidFS compellent setup the only current solution is to uncheck the v3 SMB option on the FluidFS.


If anyone wanted the case toe reference,

SR 991311217

The engineering team at EMC are working on providing a resolution or hotfix in the next patch.

I've also got permission from EMC to post their official document about Unity and Windows 1903 here.

The .pdf includes instructions for the workaround to downgrade to 3.0.2


Please see the attached document.

From Dell on the Compellent end of things as of 6/2/2019

"I’m following up on our case regarding the Windows 10 1903 update and SMB share access. At this time, our development team is still testing possible solutions. They are also investigating potential client-side workarounds. However, we currently only have the workaround of disabling SMBv3 on the FS itself."

better get used to typing //192.168.0.xx on new shortcut



It works for me now, not sure if it is a windows update or update on fluidity that has fixed it.

@kurgan  Which version of Windows are you on now?  Start -> Run - > Winver


Dell has not released updated firmware for the Fluid FS as of 6/10/2019 that I'm aware of from my current open ticket.


"I don’t have any additional information to share regarding the SMBv3 and Windows 10 update 1903 issue. I’ll continue to monitor this and keep you informed."

1903 -18362.30
actually just updated to 18362.175 a minute ago, still works fine

I've just tried the latest update (18362.175) and it still does not work with FluidFS for me with SMBv3 turned on.

The message I got from my case with Dell was they weren't planning on making any changes to FluidFS and were leaving Microsoft to fix it.

Okay followed up on it, our IT department has disabled smb3 for now to fix it.

@kurgan I am the owner of SMB. I have not received any reports of this issue from Dell, nor any similar symptoms from other customers using non-Dell products. The symptoms, workaround, & lack of other vendor reports suggests an issue with Dell's specific implementation of SMB 3.1.1. 


Regardless, I am not going to punt this. If you have opened a support case on this issue with Microsoft, please private message me the SR #. I am following up with our contacts at Dell to find out if they've spoken to us about this. 


Whenever an OEM says it's an MS problem and asks you to uninstall critical security updates and stop using the safest network protocols, I highly recommend you immediately open a Support Case with MS and that vendor and force that vendor to prove it, before de-securing your systems. 


Ned Pyle | Principal Program Manager, MS | @nerdpyle on twitter

best response confirmed by NedPyle (Microsoft)

Hi everyone. We got access to the Dell KB and see the issue in Dell/EMCs 'Unity' CIFS implementation.


From the DELL EMC KB attached to thread (below), the Unity SMB Server implementation is failing on the "SMB2_NETNAME_CONTEXT" and "SMB2_COMPRESSION_CAPABILITIES" we added in 1903. These were changes designed to add some new capabilities to SMB; we make some variant of these at most OS releases. If an SMB/CIFS server doesn't recognize capabilities, it should ignore them, not fail. Otherwise Dell would have to update their SMB implementation every time we released a new SMB capability that didn't also include a protocol dialect revision (like "SMB 3.1.2"), forever and ever. 


Error Messages in the Unity c4_safe_ktrace.log:

sade:SMB: 3:[nas_serverx] Unrecognized SMB2 negotiate context type 0003
sade:SMB: 3:[nas_serverx] Unrecognized SMB2 negotiate context type 0003


SMB client sends the compression context before the netname context, so the server encounters the compression context first. The Unity server would probably encounter the same problem with the netname context. Instead of failing when their SMB Server version doesn't support more advanced capabilities, it should be ignoring those capabilities. This is what Windows and other 3rd party SMB products do.


@kurgan thanks for opening this techcommunity item, I'm sorry I didn't see it until now.


Ned Pyle | Principal Program Manager, MS | @nerdpyle on twitter