Update KB5039304 does not install

Copper Contributor

In Windows Update the update KB5039304 runs through 100%, but in restart it only runs to 36%.

After a few minutes there, it gives an error message (no numbers or anything identifiable) en performs a roll-back.

Back in Windows the update KB5039304 is then presented again etc. etc. etc.

10 Replies

@JaccoW Exactly the same for me. I have already contacted MS service and they tried some resetting of update parameters via remote but to no avail.

I can confirm that installing the update manually doesn't help either.
Sometimes a simple restart can resolve update issues. Also ensure you have a stable internet connection.

@Mr_Big Funny thing is, on my second system with exactly the same OS build it installed flawlessly. After rebooting it stopped for half a second at 36% and jumped almost immediat3ly to 100% ...

@LH2312 

I also am not able to install this KB. i get to 38% and it hangs and resets back. I have tried 6 times so far and does the same thing every time 

I paused updates for a couple of days (this cycle of update-rollback-update-etc. was not getting anywhere). When I restarted the update service, KB5039304 was no longer there, but apparently replaced by KB5040435? But my little hope was crushed: this one only gets to 40% before rolling back etc. etc.

@JaccoW Same for me, update stops at exactly 40%. I hoped the situation would be solved somehow, but it did not.

What do we do now?? I already opened a support case with MS and they would not help. Does MS do anything concerning this error? Does this mean I have to re-install my system from the scratch after using and implementing major parts for more that 6 years?? A nightmare.... 

I guess it's time MS gets some competition after all, finally. :unamused: 

Type DISM.exe /Online /Cleanup-image /Restorehealth (note the space before each "/"), and then press Enter. (Note: This step may take a few minutes to start and complete.) After you see a message that says "The operation completed successfully," type sfc /scannow (note the space between "sfc" and "/") and press Enter this may help
@krull1958 thats exactly what the MS support person did when they were remotely connected to my computer system. Unfortunately it did not help, nothing changed.
Same. Exactly at 40%. I can also confirm the image health and system files are good. This is definitely a bug Microsoft needs to investigate and fix.