Ubisoft Games Not Working

Copper Contributor

This is likely to be a niche issue, but it would seem games running on Ubisoft engines, specifically the AnvilNext engine, won't launch and crash immediately after the splash screen.

I have tested using Assassin's Creed Origins, Assassins's Creed Valhalla, Immortals Fenyx Rising. Oddly, Ghost Recon Breakpoint works fine. I'm due to test Assassin's Creed Odyssey as well, and I imagine it too won't launch.


They last worked on Windows Build 20231, but have since stopped. I'm now on Build 21277 and am still experiencing the same behaviour. Have tried all the usual tricks to eliminate issues with the game, and contacted Ubisoft Support. Having narrowed it down, it seems extremely likely that Windows is the problem.


Is there anyone else who has had similar problems, and is perhaps aware of any tips or tricks to get them working again?


My trouble shooting has involved:

  • Disabling all non-Windows Services and trying to run the games
  • Re-installing Ubisoft Connect, and each game (as well as trying different drives)
  • SFC /scannow
  • chkdsk
  • Windows updates
  • Nvidia driver updates
  • Re-installing appropriate Visual C++ distributables

I haven't re-installed Windows as this is always an absolute last resort, that I am not prepared to carry out.

5 Replies
as a gamer who is also using Windows insider Dev channel (same build), sometimes these problems happen, I wouldn't expect any support from game developers since it's a non-released version of Windows (had problems before with EAC anti cheat), but if you haven't already, please file a feedback for it in the feedback hub :)

Thanks for your response!
Yeah, I figured as much as I remember the issues with Easy Anti-Cheat.
Hoping for a response from Ubisoft, but otherwise may just have to wait it out until a fix is released. Cheers anyway!

@Isaac_Missingham I am also having this issue with Valhalla. I played rainbow 6 seige as well, but it runs smoothly on build 21277. Interestingly, soon after I installed Valhalla, r6s crashed too... I reinstalled them multiple times, and was even ready to say goodbye to ubi games, it suddenly worked after I reinstalled all the vc runtimes. However, Valhalla still doesn't work. Hope we can get a fix too.

Remember to update if you got anything from ubi!

Added to Feedback Hub, available here: https://aka.ms/AAao3aw

@Isaac_Missingham I know it's months later but... are you still having this issue? I saw on your feedback hub item that it was fixed but... I can't launch some games like Riders Republic,No Man's Sky, etc. past the splash screen without first disabling Windows Audio Service.

All Universal c runtime, gpu, cpu drivers & Windows up to date.

MSI Meg x570 ace

AMD 5800x


Win11 Pro Beta channel

I made a feedback hub issue here https://aka.ms/AAeeozj