THX Audio Issues (and ANNOYING fix) in Windows 11

Occasional Visitor

Windows 11 seems to have an issue with Razer's THX option on their headsets. Sometimes it works fine, but other times you have to spend a while flipping through audio outputs in various ways to get it to start working. This is a Windows 11 specific issue and is not related to drivers or the headset itself as the headset is less than a month old (in terms of unboxing) and I always check my drivers bi weekly or so for everything, and in troubleshooting. 

I'm not really looking for a fix as I don't believe there currently is one, but I wanted to bring this to the attention of the devs Because this is on the Windows 11 software end.

10 Replies
I'm having the same issue
have the same/similar issue, 'THX Spatial - Synapse' audio device doesn't work on Windows 11.
I couldn't get it work trying your steps.

All time, when i turn on my computer i need to go in profile Razer > Mixer until option of the setup THX to change default audio. The time of my computer is on, audio stay stable and fuctional. Under the calibration option. I hope Microsoft fixes this fast. 

 

 

I got it fixed by fully removing the razer audio drivers and the razer apps. Rebooting the system then installing the razer app synapse for the driver and last reconnected the USB cable for the headset. Now I am able to use THX for any apps that can use it.
It possible issue was due to migrating from win10 to 11 and it needing a fresh start install of related driver and software.

for some reason i cant set it as default and it stays as stereo@g-refundini  any fixes?

So far nothing, razer still do not release update, and Microsoft update will harm my processor (AMD). So I keep waiting.

Turn OFF THX Spatial in Razer Synapse > Audio. Change default audio input in Windows sound options. Change for your Razer Audio Device. And try set THX Spatial as default in Razer Synapse again.

I´m working now, when i get back for my home i´ll take the pictures and send here.

@g-refundiniThank you! Worked perfectly for me.

ty it worked for me my headset is razer nari ultimate ily dude.
I don't know if you still have this issue, but the way I finally fixed the issue permanently was by going to uninstall Razer Synapse and then using their "repair" option before fully uninstalling. Hope this helps!