Microsoft Store

Copper Contributor

Microsoft tore won't open after Factory reset.  Tried Powershell command to reinstall it but no luck. It says need a link  to  open something. 

3 Replies

Not sure which command you already tried. Try re-registering Store app using these steps:

1. Search for Windows PowerShell using Cortana or Windows Search.

2. From results, right click on Windows PowerShell and select Run as administrator.

3. Then type following command and press Enter key:

Get-AppXPackage *WindowsStore* -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

Let the command complete.

4. Close Windows PowerShell.

Let me know if issue still persists!

Hi Kapil, 


 Yes, that's what I've tried  and still not working.  I got the same error " You'll need a new app to open   Windows defender" when I try to open Windows defender but it fixed after  I ran 
Get_AppxPackage Microsoft.SecHealthUI -Allusers | Reset-AppxPackage


Do you have this kind of command for Microsoft store? 

@Kapil Arya 

Don't have that command for Store. But I suggest you to create a new user account and check if Store is available on that and works.