Killer wireless driver error (Code 10 and Code 43)

Copper Contributor

After the last update for Windows 11 insider (Home). The driver for the wireless card stopped working. There is already a guide on the issue on Intel's boards, but it is not working either. So i think the issue is with the Windows.


The card: Killer(R) Wireless-AC 1550i Wireless Network Adapter (9560NGW) 160MHz

What didn't work: 

  1. Restoring the system
  2. Reinstalling the drivers (normal reinstall and fresh reinstall)
  3. Rolling back to earlier drivers and deleting drivers from DriverStore in System32
  4. Following Intel's "guide" (Link)

Appreciate the help, thanks in advance.

53 Replies

@OussD I have the same problem on my Dell. WiFi is disabled after reboot. When I try to switch it on the slider jump back to the Off position. Let me know if you find a solution.

Is there an update to this?? I have the same issue right now!

I managed to bring my Killer wireless network adapter back - after wasted a whole morning. Windows updated overnight and I lost the card after that. This was the error I saw in Event Viewer:

Killer Wireless-n/a/ac 1535 Wireless Network Adapter : The version number is incorrect for this driver.

I'm using an Alienware 13R3, updating to the latest Killer drivers didn't solve my problem. Removing it entirely (incl. the drivers) and restarting the machine magically solved it.

@OussD After a lot of research, the problem is usually solved by resetting the bios to default, mainly on dell laptops. The problem is caused after doing bios update or installing windows 11.
Also don't forget to install the updated drivers.

yes!, latest update of windows 10 with an Alienware 13 R3, uninstalling the driver and removing it completely then rebooting the machine did the trick! thanks!!

@ballon999 This is not working on my Surface Pro 7. I've tried uninstalling and removing the driver completely several times and each time on the restart it automatically comes back (even when I'm not connected to the internet). I had Windows 11 and reverted back to Windows 10 and still not right. 

@OussD I have found this fix on Reddit and it fixed my problem. hope this works as well on you guys.

Credits to whoever that guy was. I can't find it anymore.


Edit: Step by step: First you’ll want to open up device manager, then select Network adapters. Then double click on your 1535, you might see two adapters labeled as 1535s, so when you double click make sure to read the device status text that’s show at the bottom of the double click pop up. Once you’ve located the component with the error you’ll need to click on the driver tab on the top section of the double click pop up, then click update driver, select browse my computer, then select let me pick from the list of available drivers, I chose the Microsoft drivers but either will fix the issue. Hope this helps!

Did you find any fix? I'm dealing with this issue since October :|
I have been having a code 43 issue as well. I have done almost everything I could possible. To be fair I have tried updating my BIOS but could not figure it out for the life of me, but that seems to be about the only step left to try.

I would like to note that I have ((Intel(R) Wi-Fi 6 AX201 160MHz)) under my Network Adapter.
I am using an MSI GF65 Thin 10SDR, I have a 1660 TI and i710750H. I dont know if those have anything to do with the issue but thought it would be good to know.

I would like to start with this. Whenever my internet goes out, I head to my WiFi settings and troubleshoot, it finds a fix, I apply the fix, theres chance that the internet may come back. I believe it resets my network driver and that somehow works. A completely random amount of time later code 43 pops up again, could be 3 seconds, could be 30 minutes.

After that I try to uninstall the driver, afterwards I would shutdown my computer, it may work and it may not work, but same as last time its only temporary before it inevitably goes out again. If I restart my computer and it doesn't connect to the internet, it gives me a code 10 because it cant even startup.

Ill save some reading time, Reinstalling the drivers doesnt work, rolling back doesnt work, I updating after rolling back and it still didnt work. After doing other things youtubers told me to do that may or may not have anything really to do with the problem, it still doesnt work. Im thinking BIOS may be the reason but I dont know. This is a very frustrating situation for me and I have no idea why its acting like this.
Any help on this would be greatly appreciated.
On my MSI GS65 I deleted all Killer network drivers and then entered BIOS with Del on startup, changed settings to default and saved with reset. It helped.
All other actions didn’t.



I had a similar issue when I got my first wifi 6 networking card. My solution was to turn off automatic band selection in the wifi router settings. Apparently the network card couldn't handle when the band changed (something that the router did seemingly randomly), and so the network card errored out and stopped working until it was reset. However, after I turned off automatic band selection there hasn't been another issue, with that machine.


Hope it helps!

Dear bro.
I have done with your instruction, but it's still not working.
I have tried all the fixes shown above but nothing's gonna happen.
It still cannot start (code 10)
Have you found a solution to this?, I have the same problem

@O513-Epsilon Thanks.


Everyone, try removing the driver then shutting down the OS, not reset/reboot. I've been fighting this for 2 days straight and even after a complete OS reinstall/downgrade from 11 to 10 the problem is still there. Immediately after the reinstall the wifi adapter worked, but after a few reboots it went back to the same issues/events in the system log. Then I tried removing the driver and shutting down completely before powering back on and the wifi is now working. For how long who knows, but give this a shot if you are struggling.

best response confirmed by OussD (Copper Contributor)
The issue was a driver issue. It was resolved for me after Intel issued a fix. Please try to update to the newest driver.

hey people, I think I fixed my issue because I haven’t had this wifi issue for a couple days now. I finally managed to replace my BIOS to the newest version and once I did I had to restart my computer after it restarted itself from the BIOS update. So two restarted, but I have been getting good wifi connection. 

good luck y’all 

1 best response

Accepted Solutions
best response confirmed by OussD (Copper Contributor)
The issue was a driver issue. It was resolved for me after Intel issued a fix. Please try to update to the newest driver.

View solution in original post