Issue with Windows Defender on Windows 11

Brass Contributor

I cannot open any of the settings on windows defender, when i try to it tells me to look for a compatible app in the Microsoft Store. Is this a bug or some other (fixable) issue?

438 Replies
Note; this was after a complete re-install of windows and happens to every other fresh install after (i tried to re-install 2 times trying to fix it)

@Asuka_Okami I am having the same exact issue.

same here , last update killed the link or overlay with windows defender .cant access any of the settings . same issue on laptop and home pc .
It's possible to reach the settings by using the search tool. Enter "Windows Defender" and you'll find a link to Windows Defender. You can also reach it from the control panel.

I have got the same issue. I can't even open it from the control panel or the setting menu. 

Are you facing this issue with other Settings?
It looks like a bug and I advise you open the Feedback Hub app and report this issue.
Doesn´t work. Any click on any of the itens presented under "Protection Areas" prompts the appearance of this message: "You´ll need a new app to open this windowsdefender link", plus the option to "Look for an app in the Microsoft Store".



I found that running the steps here resolved the issue, so it seems like the update corrupted some files.

No other settings work fine. Its just that windows defender wont open. I am going to report this. Thnx for the quick reply.

best response confirmed by Asuka_Okami (Brass Contributor)
I had this problem on all machines updated from 19043.1151 to 22000.120.
This command from elevated PowerShell fixed the problem for me, try it and report the results:

Get-AppxPackage Microsoft.SecHealthUI -AllUsers | Reset-AppxPackage

Thats for windows 10, and older, this post already said that it was using windows 11.
This worked with me! Thank you very much!
Worked! Thank you!

If you had this problem with build 22000.120 you probably also have the bug on (Shift + Restart)
Recovery advanced startup gets a BSOD PROCESS1_INITIALIZATION_FAILED, you should try and see if you have also that bug.


Re: Windows 11 Upgrade 10.0.22000.120 BSOD Process1_Initalization_Failed upon reboot - Microsoft Tec...

Thank you so much. It worked for me.

Has anyone found a fix for this yet? I'm having the same issue. I can't install software for school because Windows Defender keeps deleting the files. The app is working fine and great so why can't we access it? It clearly exists
Yeah, I have HP laptop and I did get PROCESS1_INITIALIZATION_FAILED on Windows RE
Running 22000.120
[I found a fix everyone!!]

Open PowerShell (as Administrator) and run this command (without the "")
"Get-AppxPackage Microsoft.SecHealthUI -AllUsers | Reset-AppxPackage"

After doing this, check your settings-> Privacy & Security-> Open Windows Security

This should open up Windows defender like it used to on Windows 10. I hope this fixes your problem.
It work thank you