Failure to Start, Error Msg [wdfilter.sys]

Copper Contributor
Windows Insider
First opportunity to update on the road.
Attempted to roll back to previous build but don't remember my password, have been using PIN#. Though password of my MS account is same as network device (laptop), an assumption that has proved true before but may have just been my using the same password for both.

I have an endless green screen reboot, can't login, and can't get back to previous version. I would prefer not resetting my machine if possible.
6 Replies
Forgot to include this . . .
Edition: Windows 10 Professional
Version: 1709
OS Build: 10.0.17074.1002
Serial#: 6X9W832
Processor: Intel(R) Core(TM) i3-5005U CPU @ 2.00GHz
Graphics Card: Intel(R) HD Graphics 5500
System OS Type: 64-Bit X64

I had the same issue. It'seems I fixed it by going to C:\Windows\System32\drivers and renaming the driver to wdfilter.old.

The rename of the file sounds like good advice. I remember now doing something similar in the past.


My problem now is being locked out of my system. Someone suggested resetting my password because my laptop isn't authenticating my access. Password worked for accessing Outlook and my MS Account, but I assumed the knew something I didn't.

Turns out the laptop has no way to see my new password because for some reason it is locked in [airplane mode] when I bootup in [Windows Safe Mode with Networking].

So I can't get into my system at all now because it can't authenticate my password and I don't have media necessary to reload from scratch. It came preloaded with Win Pro 7, I updated to 8.1, then took advantage of the free upgrade to Win 10 Pro 64-bit. I never have had media and can't find my USB or anywhere near I can walk to to get another one. I have to struggle through a meeting now without material because this happened before my regular backup.

I will check back for suggestions on a couple of hours.

Drithliú in San Francisco
How did you get the rights to alter it? I have no rights to change this file, although I'm the administrator on the machine...

Change the permissions on the file to Full Control for your user account.

Renaming to wdfilter.old worked for me too. Remember to change your profile to grant full control/access beforehand then restart after renaming.