Cumulative Update for Windows 11 (10.0.22000.100) (KB5004300) - Error 0x800f0900

%3CLINGO-SUB%20id%3D%22lingo-sub-2588596%22%20slang%3D%22en-US%22%3ECumulative%20Update%20for%20Windows%2011%20(10.0.22000.100)%20(KB5004300)%20-%20Error%200x800f0900%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2588596%22%20slang%3D%22en-US%22%3E%3CP%3EBeen%20getting%20this%20error%20since%20I%20first%20installed%20the%20preview%20build.%20Error%200x800f0900.%20Anyone%20else%20with%20this%20issue%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2589466%22%20slang%3D%22en-US%22%3ERe%3A%20Cumulative%20Update%20for%20Windows%2011%20(10.0.22000.100)%20(KB5004300)%20-%20Error%200x800f0900%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2589466%22%20slang%3D%22en-US%22%3EHello%2C%3CBR%20%2F%3E%3CBR%20%2F%3ERun%20Windows%20Update%20troubleshooter%20from%20Settings%20app%20%26gt%3B%20System%20%26gt%3B%20Troubleshoot%20%26gt%3B%20Additional%20troubleshooters.%20%3CBR%20%2F%3E%3CBR%20%2F%3ELet%20us%20know%20what%20it%20reports%20back.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2593461%22%20slang%3D%22en-US%22%3ERe%3A%20Cumulative%20Update%20for%20Windows%2011%20(10.0.22000.100)%20(KB5004300)%20-%20Error%200x800f0900%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2593461%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F11684%22%20target%3D%22_blank%22%3E%40Kapil%20Arya%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20the%20Same%20Error%20When%20i%20trying%20to%20Download%20This%20Update%3C%2FP%3E%3CP%3EI%20Attached%20Detailed%20Information%20When%20i%20Running%20Troubleshoot%20For%20Windows%20Update%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22alieslam_1-1627432699410.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F298838iA4E31A43E606F418%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22alieslam_1-1627432699410.png%22%20alt%3D%22alieslam_1-1627432699410.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22alieslam_0-1627432366899.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F298837i57E7B9B1261F7731%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22alieslam_0-1627432366899.png%22%20alt%3D%22alieslam_0-1627432366899.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22alieslam_2-1627432865169.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F298839i3EA4AF89CE9BF6CE%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22alieslam_2-1627432865169.png%22%20alt%3D%22alieslam_2-1627432865169.png%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22alieslam_3-1627432887393.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F298841i7AF578A7117BE27A%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22alieslam_3-1627432887393.png%22%20alt%3D%22alieslam_3-1627432887393.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Been getting this error since I first installed the preview build. Error 0x800f0900. Anyone else with this issue?

56 Replies
Hello,

Run Windows Update troubleshooter from Settings app > System > Troubleshoot > Additional troubleshooters.

Let us know what it reports back.

@Kapil Arya 

 

Hello,

 

I have the Same Error When i trying to Download This Update

I Attached Detailed Information When i Running Troubleshoot For Windows Update

 

 

alieslam_1-1627432699410.png

 

alieslam_0-1627432366899.png

alieslam_2-1627432865169.pngalieslam_3-1627432887393.png

 

@Kapil Arya 

 

Yep I run it and it has me try:

net stop bits

net stop wuauserv

net stop appidsvc

net stop cryptsvc

 

Some of these weren't running anyway so I proceeded with:

 

Del “%ALLUSERSPROFILE%\Application Data\Microsoft\Network\Downloader\qmgr*.dat”

 Which then throws an error saying:

Could Not Find C:\ProgramData\Application Data\Microsoft\Network\Downloader\qmgr*.dat

 

I also tried the commands in here:

Windows update fails with Error 0x800f0900 - Microsoft Community

 

Open administrative Command Prompt and type following commands one-by-one followed by Enter key.

 

net stop wuauserv

net stop cryptSvc

net stop bits

net stop msiserver

Ren C:\Windows\SoftwareDistribution SoftwareDistribution.old

Ren C:\Windows\System32\catroot2 Catroot2.old

net start wuauserv

net start cryptSvc

net start bits

net start msiserver

 

These did not resolve the issue either.

@Kapil Arya 

So tried sfc /scannow and it says there were corrupt files, but was unable to fix them. It points me to the path of the cbs.log file which I have attached.

@Briggie 

i succesfuly installed this update  (10.0.22000.100) .. there was no issue.. I think you should reset the laptop and try downloading this update again...........


@Briggie wrote:

So tried sfc /scannow and it says there were corrupt files, but was unable to fix them. It points me to the path of the cbs.log file which I have attached.


@Briggie, try these steps:

 

1. Search for 'windows powershell' using Cortana or Windows Search.

 

2. From results, choose Windows PowerShell and select Run as administrator.

 

3. Then type/paste following and press Enter key:

 

Repair-WindowsImage -Online -RestoreHealth

 

4. Let the command complete, restart your system then.

 

Let us know if this helps! 

Tried this and I get this:

Repair-WindowsImage : The restore operation failed. Either the repair source was not found or the component store
cannot be repaired.
At line:1 char:1
+ Repair-WindowsImage -Online -RestoreHealth
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Repair-WindowsImage], COMException
+ FullyQualifiedErrorId : Microsoft.Dism.Commands.RepairWindowsImageCommand

@Briggie 

 

Hello,

 

I am facing the same issue ( Build 10.0.22000.100 error )

After following the steps for restore health I got the same message displaying restoration failed.

 

Hello,

I tried running Windows Update Troubleshooter, it reported me " Windows Update " and then an error symbol, I clicked next and it started displaying " Resolving problems " but it didn't help.

How to restart Windows Update Service ? and will it cause me to leave the Insider Program ?

I am also facing the same problems and none of the solutions seems to work for me. If a Microsoft technician sees this reply I am willing to share all the logs required to you for solving this problem.

Screenshot 2021-07-28 190528.png

Screenshot 2021-07-28 190432.png

 Screenshot 2021-07-28 191644.png

Screenshot 2021-07-28 191922.png

Run this to resolve this

net stop bits
net stop wuauserv
net stop appidsvc
net stop cryptsvc
Del "%ALLUSERSPROFILE%\Application Data\Microsoft\Network\Downloader\*.*"
rmdir %systemroot%\SoftwareDistribution /S /Q
rmdir %systemroot%\system32\catroot2 /S /Q
sc.exe sdset bits D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)
sc.exe sdset wuauserv D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)
cd /d %windir%\system32

regsvr32.exe /s atl.dll
regsvr32.exe /s urlmon.dll
regsvr32.exe /s mshtml.dll
regsvr32.exe /s shdocvw.dll
regsvr32.exe /s browseui.dll
regsvr32.exe /s jscript.dll
regsvr32.exe /s vbscript.dll
regsvr32.exe /s scrrun.dll
regsvr32.exe /s msxml.dll
regsvr32.exe /s msxml3.dll
regsvr32.exe /s msxml6.dll
regsvr32.exe /s actxprxy.dll
regsvr32.exe /s softpub.dll
regsvr32.exe /s wintrust.dll
regsvr32.exe /s dssenh.dll
regsvr32.exe /s rsaenh.dll
regsvr32.exe /s gpkcsp.dll
regsvr32.exe /s sccbase.dll
regsvr32.exe /s slbcsp.dll
regsvr32.exe /s cryptdlg.dll
regsvr32.exe /s oleaut32.dll
regsvr32.exe /s ole32.dll
regsvr32.exe /s shell32.dll
regsvr32.exe /s initpki.dll
regsvr32.exe /s wuapi.dll
regsvr32.exe /s wuaueng.dll
regsvr32.exe /s wuaueng1.dll
regsvr32.exe /s wucltui.dll
regsvr32.exe /s wups.dll
regsvr32.exe /s wups2.dll
regsvr32.exe /s wuweb.dll
regsvr32.exe /s qmgr.dll
regsvr32.exe /s qmgrprxy.dll
regsvr32.exe /s wucltux.dll
regsvr32.exe /s muweb.dll
regsvr32.exe /s wuwebv.dll
netsh winsock reset
netsh winsock reset proxy
net start bits
net start wuauserv
net start appidsvc
net start cryptsvc
Iran all of that and error still shows up when try to update.

@Briggie 

Yes I too ran it, it didn't work the error still pops up.

I also get the same error
10.0.22000.100

@gptshubham5952435 

This does not help me. Can you check the attached event viewer log to understand what the problem is.

Maybe installing the update from Official Windows website might help,
I found a download link in the website : https://www.microsoft.com/en-us/software-download/windowsinsiderpreviewSDK