Can't update to windows 11(cFosSpeed Driver)

Occasional Visitor

i ran the PC health check software to see if my PC was capable of running windows 11,it checked out fine, but when i go to my updated and click to install the windows 11 upgrade i get the error that i need this driver. I've never heard of  it and when i search for what it is I get sites trying to sell me the driver. is there a way around this or is this driver actually needed for the upgrade to continue?

32 Replies



Uninstall Turbo LAN, it's related to that.

@Blackgravity it’s normal it’s integrated thing for MSI gigabyte and some other motherboards to help with connection speeds I don’t know what is the driver for windows 11 but if I find out I’ll tell you

@BlackgravityI have the same problem. Trying to sell me an upgrade for this program. My Pc is from MSI. I saw it's MSI related.

I had the same issue, so i had to unistall Turbolan Software@Blackgravity 

I ran into the same issue. I had to cancel the install.


Mine was called Gigabyte Speed.  I uninstalled it and was able to proceed without issue.

I had the same issue when attempting to upgrade. I had the MSI Utility installed for my motherboard and had cFosSpeed installed as a part of that utility. I uninstalled the MSI utility and cFodSpeed but still had the same error message. I finally found the what was causing the error to trigger. Go to your Network and Sharing Center and select Change Adapter Settings. Right click on your network and selet properties. Look under "This conection uses the following items:" and select cFosSpeed and click "Uninstall". A pop up box may appear and tell you it will remove the feature from all adapters, click ok/continue. Go back to your windows update, and it should start to update without that cFosSpeed error. (There may be a faster way to get to these areas I listed, that's just how I did it)

@Blackgravity  I went through this issue this morning. First I've just turned off MSI Dragon Center, killed CFos process and uninstalled CFos in my adapter preferences as it was mentioned above. It didn't help though.

So I've turned off MSI Dragon Center in the task manager and killed all of it's processes, uninstalled CFos using Revo Uninstaller Advanced Mode, next I,ve run CCleaner and Wise Registry Cleaner and now I've got Win 11 ;)

It's not only the driver, but registry entries also...

I had exactly the same problem. Tried several ways to uninstall or update the cFosSpeed Driver and software but could never go beyond the 35% installation and error. Also tried installing via USB and that just said device wasn't compatable (despite the system checker confirming all was good). Guess I will wait a few months and try again!
There are two another solutions:
1) if You are using DragoCenter or something like that with LanManager installed: find the root folder of the Lan Manager, in my case it was c:\Program Files (x86)\MSI\one Dragon Center\Lan Manager and there you will find unins000.exe. By this file You'll uninstall CFos permanently
2) update CFos to the latest version.
But I think that at least one of solutions mentioned above should help.
Gosh, didn't know this is such an annoing issue
best response confirmed by ___rj (Microsoft)

@Blackgravity If you're using an MSI product with Dragon Centre installed. Open Dragon Centre, click on the support tab on the left, then Live Updates, then scan. select the check boxes on the list, and update.


This will update cFosSpeed (and all the other programs that DC uses) to it's newest version, and will allow you to update to Windows 11.

@GrizzlyDurer He usado esta solución y me ha funcionado perfectamente.

Ya tengo instalado mi W11 sin problemas.

Muchas gracias.

The update for Windows 11 is gone. I'll wait for the next time they offer and if that worked. thank you.
F.ex. I didn't have update options in DC, so I couldn't just update it to solve the problem. So it's not for everyone
You can use Windows Installation Assistant

I've installed W11 using this app and it works just fine.
However there were some minor problems with Installation, caused by some drivers, but nothing that you can't manage with simple uninstall lol.
I've got bluescreens because of Attempted to Write to Read-Only Memory Error.
So I had first uninstalled all DC package and Kaspersky Internet Security. It didn't help so then I uninstalled Realtek Audio, Realtek Network and NVidia Graphics drivers. And all W11 Installation went perfect. Next I reinstalled KIS, DragonCenter and NVidia, updated all drivers (Realtek etc.) and now I have a decent Win11 ;)
Hope this will help

@Blackgravity I was getting CFossSpeed error at 35% point. However I'm now at 82% point. I downloaded from CFosSpeed the latest retail version. Since I already have a Asus mobo x299 Prime Deluxe II factory installed CFossSpeed version the new latest CFosFossSpeed driver instaleld with no issues (free of course). Its the latest "retail" version and unlike the Asis factory CFosSpeed Version that is outdated for W11 requirements.

@Pudddinhead  so maybe it's not CFos problem. Probably some other drivers, like it was in my case. Try uninstalling audio, network and graphics drivers and run the installer again.

I had problem at about 80-85% just like You, so I think it's worth to try.

I've updated Dragon Center and the programs in MSI Driver & App Center. After that i could install windows 11 with ease. Problem solved for me.