/o=exchangelabs/ou=exchange administrative group (fydibohf23spdlt)/cn=recipients/cn=

Occasional Contributor



Our IT team has synced our outlook contacts with icloud for use on our iPhones.

Contacts were synced over but all the emails have been change to 


/o=exchangelabs/ou=exchange administrative group (fydibohf23spdlt)/cn=recipients/cn=


does anyone know why this has happened?


we currently are using Microsoft admin center to create our email accounts until our server room is complete so we cannot add any script commands to resolve this problem



10 Replies

no reply to this post? no one has seen this before?

@MilanVuletic I am seeing this error every day. Any emails I have replied to remain in the inbox marked as draft, they also appear in the drafts folder and the sent items. when I delete the draft, /o=exchangelabs/ou=exchange administrative group (fydibohf23spdlt)/cn=recipients/cn=

appears in the deleted items. I have searched for a solution, but haven't found one. IT support suggested to switch off the cached mode, but that's not a viable solution as it cripples the search functionality.


I really hope that someone figures this out soon



I'm seeing exactly the same with one of my users. Seems to be intermittent but Outlook appears to be saving copies of replies in to the drafts folder when sent. I've checked the settings in Outlook and they don't have the setting to "...save a copy to the same folder" selected.

We're unable to find any rules relating to this that might be causing this either. Also worth noting we've had cache mode switched off and still the issues occurs. We've just recently migrated the user across to a hosted desktop solution and the issue has even persisted through that. Completely stumped...

@MilanVuletic Getting a related problem. Every so often I get ghost meeting invites from the organisation I used to work for. In some cases the invites were 15 years ago. The meeting organiser is shown in the format above. At the moment, I'm not able to delete them as the declines aren't sent. In the past, I was able to delete, but they periodically return. This has happened pretty quickly after installing iOS 14. I am no longer a member of that Exchange group and I am not connected to that domain in anyway that I am aware of. Again in the past I had synched contacts with iCloud but that is now turned off. Interestingly, these invites only appear on the phone, they are not replicated through to the exchange group I am now part of. So my assumption is that this is an Apple/iCloud issue rather than Microsoft. No solution, but posting for more information about the problem.....

@arnisv One of our employees has the exact same issue as you have described. Were you able to come up with a solution?

@ShaanSilver nope no one knows how to fix this. we are syncing contact list from sharepoint. the email address changes to this string. Contacted Micorsoft they said it wasnt coming from their end. had to resort to google contacts. 


We managed to solve the issue. It looked like the issue was caused by Mimecast (email security).

Updating Mimecast to the latest version (v7.9) appears to have solved the issue 

I had a user come to me today with this. I told him to clear the address from the "remembered" addresses in his Outlook client (i.e. start typing the name and, when it comes up, click the cross to delete it) and then to retype the address. It reverted to normal! So, for us, it was just a glitch with how the Outlook client recorded the address when originally used, and it remembered it that way.


I deleted my delay for 3 minutes before sending rule. Seems to have worked.