Skype Room System - Cannot fetch calendar

New Contributor



We have a about a dozen Skype Room System units (both the Surface and Lenovo Hub 500) deployed in our environment, installed with SRS version, Windows version 10.0.16299.785 and they all have the error message "cannot fetch calendar".


Some background history:

This message appeared during a Exchange on-prem -> cloud migration, and was expected because of our autodiscover records still pointing to the on-prem server. It was also expected that it would be fixed by itself once we updated our autodiscover records to point to the cloud, but unfortunately this did not solve the problem. We are currently running on a Skype for Business 2013 server on-prem, and Exchange Online (hybrid)



  • I first thought this was autodiscover related, because of what i mentioned above. I have tried to manually add the cloud autodiscover server to the hosts file a few of the systems, that did not help. 
  • Further step was checking that the licensing in Office 365 is ok, all accounts have E3 license. 
  • Installed Office 365 proplus on a few of the systems, to check if sign-in to to a normal desktop version of SFB worked and it did. The SFB client read the calendar and everything worked as it should. 
  • Created a new meeting room account in the cloud
  • Re-installed one of the systems (worth a shot) 

Now, if i try with a room mailbox account only existing on our on-prem server, it works. I have looked through many SRS articles here with the same problem, and i noticed someone mentioned that it was ADFS related, but i am not sure where to look.


At this point i am lost, and am hoping one of you brilliant people could help me out. Also, happy new year! 

10 Replies
Same here, please post if you find a solution
We did configure SFB hybrid and moved one of the SRS meeting room accounts to the cloud, and that have brought the Join meetings button back. However, it is greyed out and there is a constant "Sign-in" circle spinning on the screen, so we are not 100% operational again. Will post an update here when i have one
Did you manage to solve the calendar problem?

@Knut Martin Gabrielsen Sorry for the late response. Not in any other way than creating new meeting rooms, per now there is no way to re-use our old ones. 


Did you find a solution?


We use a Logitech SMARTDOCK with a Surface 6 Pro.

Win1803 and SRS v2 Version April 2019


- Exchange hybrid

- Skype f. Business onPremise


SIP works, but they don t fetch the calendar.

We have use 3 different Accounts

- Exchange onPremise

- Exchange Online User Account

- Exchange Online Ressource Account with license for the Room System


When i log on the local Admin Account and install a Offfice 365, all works fine (Skype f Business login and Outlook)


i have also installed the srs v2 system on the local Account on srs , but it have the same problem.


Is that a modern authentication problem? 


Kind Regards








For us, it was the modern authentication. Once we allowed basic auth, it works!

I did find that configuring DHCP option 252 (Web Proxy Auto Discover, WPAD) with the full URL to my organisation's Proxy Auto-Config (PAC) file resolved this in our case. Since we're using a local, non-domain account on the SRS/MTR device, it would have been too difficult to configure the PAC through another method such as a script. Conveniently, our cloud proxy provider supports forwarding requests to Office 365/Exchange Online without authentication so using the local account didn't pose any issue


(Copied my reply from a post on another conversation)



Hi Marcus,


I had a similiar issue and found that the on-prem user object password had expired. 


Try setting a new password and setting the password to never expire.





We are using Skype for business online, with )365 online, accounts are sync with local AD ( and using Okta ). We had hard-on "cannot fetch calendar" message at the beginning, but it was cleared after enabling basic Auth for exchange ( we had basic auth disabled for our tenant). 


But now all devices showing "cannot fetch calendar" message intermittently. Upon device restart , massage go away (sometime), but appears randomly again.

We have direct connection to internet ( no proxy) via firewall. 

Any thought ?

Thanks, Nick.