Home

Error of "presence unknown" and "This message wasn't sent to ***@hotmail.com due to company policy."

%3CLINGO-SUB%20id%3D%22lingo-sub-1104124%22%20slang%3D%22en-US%22%3EError%20of%20%22presence%20unknown%22%20and%20%22This%20message%20wasn't%20sent%20to%20***%40hotmail.com%20due%20to%20company%20policy.%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1104124%22%20slang%3D%22en-US%22%3E%3CH3%20id%3D%22toc-hId-1081669772%22%20id%3D%22toc-hId-1081669772%22%3EIssue%3A%26nbsp%3BAdd%20a%20contact%20not%20in%20my%20organzation%20in%20SFB%20client%20with%20show%20status%20%22presence%20unknown%22%20and%20sent%20message%20will%20show%20error%20of%20%22This%20message%20wasn't%20sent%20to%20***%40hotmail.com%20due%20to%20company%20policy.%22%3C%2FH3%3E%3CP%3ETested%20or%20done%3A%3C%2FP%3E%3COL%3E%3CLI%3EDNS%20in%20edge%20server%20set%20to%20outside%20DNS%20already%3C%2FLI%3E%3CLI%3EEnabled%20federation%20(port%205061)%20in%20Edge%20pool%20(also%20enable%20skype-skype%20federation%20search%20(port%204443)%3C%2FLI%3E%3CLI%3EConfigured%20SIP%20federated%20providers%20by%20follows%3A%3CBR%20%2F%3E%3CP%3ENew-CsPublicProvider%20-Identity%20Skype%20-ProxyFqdn%20federation.messenger.msn.com%20-IconUrl%20%3CA%20href%3D%22https%3A%2F%2Fimages.edge.messenger.live.com%2FMessenger_16x16.png%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fimages.edge.messenger.live.com%2FMessenger_16x16.png%3C%2FA%3E%20-NameDecorationRoutingDomain%20msn.com%20-NameDecorationExcludedDomainList%20%22msn.com%2Coutlook.com%2Clive.com%2Chotmail.com%22%20-Enabled%20%24true%20-EnableSkypeIdRouting%20%24true%20-EnableSkypeDirectorySearch%20%24true%3C%2FP%3E%3C%2FLI%3E%3CLI%3E%3CP%3E%3CSPAN%3EAdded%20SRV%20records%3A%3C%2FSPAN%3E%3CSPAN%3E%3CBR%20%2F%3E%3C%2FSPAN%3E%3CSPAN%3E_sip%20(Protocol%3A%20_tls%20%2F%20Port%3A443)%20%26amp%3B%20_sipfederationtls%20(Protocal%3A_tcp%20%2F%20Port%3A5061)%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLI%3E%3C%2FOL%3E%3CP%3E%26nbsp%3B%20%26nbsp%3B%20%26nbsp%3B%205.%20Added%20CHAME%20records%20with%20sip.%3CDOMAINNAME%3E%20%26amp%3B%20lyncdiscover.%3CDOMAINNAME%3E%3C%2FDOMAINNAME%3E%3C%2FDOMAINNAME%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%20%26nbsp%3B%20%26nbsp%3B%206.%20Use%20Test-CsFederatedPartner%20-TargetFqdn%20%3CDOMAINNAME.COM%3E%20-Domain%20hotmail.com%20show%20error%3A%3CBR%20%2F%3E%26nbsp%3B%20%26nbsp%3B%20%26nbsp%3B%20%26nbsp%3B%20%26nbsp%3BError%20Message%3A%20504%2C%20server%20time-out%3C%2FDOMAINNAME.COM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%20%26nbsp%3B%20%26nbsp%3B%20%26nbsp%3B%20%26nbsp%3BDiagnosis%20%3A%20ErrorCode%3D1008%2CSource%3D%3CDOMAINNAME.COM%3E%2CReason%3DUnable%20to%20resolve%20DNS%20SRV%3C%2FDOMAINNAME.COM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%20record%2C%20domain%3D%3CDOMAINNAME.COM%3E%2Cdns-source%3DInternalCache%2Cdns-srv-result%3DQueryFailed%3C%2FDOMAINNAME.COM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%20Microsoft.Rtc.Signaling.DiagnosticHeader%3C%2FP%3E%3CP%3E%26nbsp%3B%20%26nbsp%3B%20%26nbsp%3B%20%26nbsp%3B7.%26nbsp%3B%2053%20port%20opens%20in%20firewall%20for%20DNS%20service%2C%20but%20run%20%E2%80%9Cnetstat%20%E2%80%93%20na%E2%80%9D%20in%20edge%20server%2C%20no%2053%20port%20service%20show%20me%20with%20listening%20status.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20professional%20suggestion%3F%20many%20thanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1104124%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Epresence%20unknown%20Add%20a%20contact%20not%20in%20my%20organzation%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Visitor

Issue: Add a contact not in my organzation in SFB client with show status "presence unknown" and sent message will show error of "This message wasn't sent to ***@hotmail.com due to company policy."

Tested or done:

  1. DNS in edge server set to outside DNS already
  2. Enabled federation (port 5061) in Edge pool (also enable skype-skype federation search (port 4443)
  3. Configured SIP federated providers by follows:

    New-CsPublicProvider -Identity Skype -ProxyFqdn federation.messenger.msn.com -IconUrl https://images.edge.messenger.live.com/Messenger_16x16.png -NameDecorationRoutingDomain msn.com -NameDecorationExcludedDomainList "msn.com,outlook.com,live.com,hotmail.com" -Enabled $true -EnableSkypeIdRouting $true -EnableSkypeDirectorySearch $true

  4. Added SRV records:
    _sip (Protocol: _tls / Port:443) & _sipfederationtls (Protocal:_tcp / Port:5061)

      5. Added CHAME records with sip.<domainname> & lyncdiscover.<domainname>

      6. Use Test-CsFederatedPartner -TargetFqdn <domainname.com> -Domain hotmail.com show error:
         Error Message: 504, server time-out

         Diagnosis : ErrorCode=1008,Source=<domainname.com>,Reason=Unable to resolve DNS SRV

                record, domain=<domainname.com>,dns-source=InternalCache,dns-srv-result=QueryFailed

                Microsoft.Rtc.Signaling.DiagnosticHeader

       7.  53 port opens in firewall for DNS service, but run “netstat – na” in edge server, no 53 port service show me with listening status.  

 

Any professional suggestion? many thanks.