Skype Room Systems v2 Windows 10 Version 1803 (RS4) unblocked November 1st

Published 10-30-2018 06:47 PM 7,675 Views

SRSv2 devices now running Windows 10 Version 1709 (RS3) will be updated to Version 1803 (RS4) update starting November 1st.  Devices with an open Internet connection will receive 1803 directly from Windows Update.  Until now, 1803 has been blocked from SRSv2 devices while we completed testing.

Senior Member

one of my device just updated today . 

Occasional Contributor


can someone tell me, how the Updates are blocked on SRS Systems? Is it a kind of registry key or does it depend on the Installed SRS Version?


And is this setting already active BEFORE i complete the configuration wizard for SRS? I am preparing some systems for my customers and want to patch Windows to the current supported Build BEFORE configuring the SRS.


Thanks for your help.


@Daniel Jelinek Microsoft tests latest Windows Updates on Room Systems devices prior to offering as a device update.  The Room Systems team works with the Windows team to put a block in place in the cloud during this test period.  At this point, Windows 10 Version 1803 (RS4) is the latest, tested version that you should be running on your device.  We have a block in place on the more recent update version, RS5.

Occasional Contributor

@David Groom i understand this.

But i like to know how this is technically realized. Are these Systems in a different Update Ring or are the build Updates blocked by a registry key? I like to Check of these settings are applied to my System. 

Occasional Contributor

What actually triggers the update to run through?   I've got a number of Lenovo SmartHubs Devices on remote sites, not sure I want them to just suddenly update to a new OS version? 

The process is simply Windows Update - no different than the process that every Windows computer uses in your environment and optionally managed the same as every windows computer in your environment. The OS update block is a Windows Update block at the cloud level, not the registry level on the local machine. If you want to kick-off the update process sooner than later, simply go to Windows Update on the SRSv2 device and click check for updates. Assuming it is checking directly with WU, it will being the OS download/upgrade process. If you manage the update internally it is up to you to allow/block the update when MSFT has completed their testing.

This means SRSv2 is now CURRENT, if that's not an encouragement to the Windows team to try releasing 1809 again I don't know what is.

Occasional Contributor

Thanks David, this is what has been worrying me following the release last year of 1709 and the problems related to that unexpectedly bricking a couple of my older Logitech SRS's


Is anybody experiencing issues with the 1803 upgrade ?


I am in the process of building 10+ SP5 SRS systems and the upgrade from 1703 to 1709 is mostly going ok, although some systems are refusing to even recognise they should upgrade but I am having to repeatedly rebuild from scratch to get 1803 to install and it can take anything from an hour to 12+ hours to upgrade to 1803. I've tried upgrades on different LANs with both proxy and no proxy services in place to help determine if the network is impacting the upgrade, but it's not really made it clear why some upgrade quick and some just won't upgrade at all. The typical failure scenario is that the upgrade demands the Rigel app is uninstalled and running the upgrade troubleshooter doesn't tend to resolve this. Other times it just sits at 0% download for ever.


Also, any ideas why two SP5 would sit at 1703 and complete fail to recognise they need an upgrade?




I mostly resolved my build issues through the following:


- Being very patient with upgrades

- Moving to a different network to complete an upgrade

- Forcing an update by downloading the Windows 1709 update


I applied this across the various builds to eventually get all systems built. I have just built an HP Elite Slice SRS and it updated from 1709 to 1803 within a matter of hours. Possibly the HP does not have the issue the Surface pro has or coming from a higher base build avoids upgrade issues.


I created a new image with the W1803 version as described in the deployment guide (

This worked fine with the 1703 and 1709 versions but does not work with 1803.

SRS starts with the installation of W10 but at the end it ends up in a continous reboot cycle and never finishes the install.

Anyone else experiencing this issue?


Applied 1709 recovery image to SRS. After this Surface Pro is working again.

Tried to deploy SRS 1709 image after this. Same issue as with 1803. Endless loop at the end.

removing USB stick gives error. Windows could not complete the installation. To install Windows on this computer restart the installation.


Update: There seems to be an issue with an older version of the SRSDeploymentKit. 

This week I tested with the new version SRSDeploymentKit- and I was able to install 1803 on the SRS. 

Version history
Last update:
‎Nov 02 2018 08:45 AM
Updated by: