Trying to Create SP site with Site provisioning with CSOM - But Error throws

%3CLINGO-SUB%20id%3D%22lingo-sub-765771%22%20slang%3D%22en-US%22%3ETrying%20to%20Create%20SP%20site%20with%20Site%20provisioning%20with%20CSOM%20-%20But%20Error%20throws%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-765771%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20been%20trying%20to%20create%20a%20SharePoint%20subsite%20with%20Site%20provisioning%20with%20CSOM%20Approach%3CBR%20%2F%3E%3CBR%20%2F%3EReference%20link%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fsharepoint.stackexchange.com%2Fquestions%2F76316%2Fcustom-site-creation-with-csom%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsharepoint.stackexchange.com%2Fquestions%2F76316%2Fcustom-site-creation-with-csom%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EIn%20my%20case%20sub-site%20provision%20successfully%20but%20the%20unnecessary%20error%20comes%20out%20%22Error%3A%20Unexpected%20error%20from%20the%20server%20%22%3CBR%20%2F%3E%3CBR%20%2F%3ESo%20is%20there%20any%20update%20from%20Microsoft%20that%20prevent%20to%20do%20this%20operation%3F%3CBR%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-left%22%20style%3D%22width%3A%20722px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F123920i8DA311C5FB0B9DDC%2Fimage-dimensions%2F722x281%3Fv%3D1.0%22%20width%3D%22722%22%20height%3D%22281%22%20alt%3D%22image_2019_07_20T12_10_07_888Z.png%22%20title%3D%22image_2019_07_20T12_10_07_888Z.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-765771%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-806276%22%20slang%3D%22en-US%22%3ERe%3A%20Trying%20to%20Create%20SP%20site%20with%20Site%20provisioning%20with%20CSOM%20-%20But%20Error%20throws%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-806276%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F229623%22%20target%3D%22_blank%22%3E%40Amit%20Koyani%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThere%20are%20probably%20about%20a%20million%20possible%20things%20that%20could%20be%20going%20wrong.%20Can%20you%20step%20through%20your%20code%20and%20try%20to%20give%20us%20some%20context%20as%20to%20where%2Fwhy%20the%20error%20occurs%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

 

I have been trying to create a SharePoint subsite with Site provisioning with CSOM Approach

Reference link: https://sharepoint.stackexchange.com/questions/76316/custom-site-creation-with-csom

In my case sub-site provision successfully but the unnecessary error comes out "Error: Unexpected error from the server "

So is there any update from Microsoft that prevent to do this operation?
image_2019_07_20T12_10_07_888Z.png

 

 

 

 

 

 

 

 

1 Reply
Highlighted

@Amit Koyani 

 

There are probably about a million possible things that could be going wrong. Can you step through your code and try to give us some context as to where/why the error occurs?