Home

The required feature is not enabled for this column type error when creating taxonomy column

%3CLINGO-SUB%20id%3D%22lingo-sub-905029%22%20slang%3D%22en-US%22%3EThe%20required%20feature%20is%20not%20enabled%20for%20this%20column%20type%20error%20when%20creating%20taxonomy%20column%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-905029%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20trying%20to%20create%20a%20new%20taxonomy%20(managed%20metadata)%20column%20in%20SharePoint%20online.%20However%2C%20I%20am%20facing%20below%20error%20when%20try%20to%20select%20term%20set%20for%20this%20column.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EThe%20required%20feature%20is%20not%20enabled%20for%20this%20column%20type.%3C%2FSTRONG%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20tried%20this%20on%20both%20team%20sites%20and%20communication%20sites.%20I%20also%20don't%20see%20any%20OOTB%20managed%20metadata%20columns%20such%20as%20Enterprise%20Keywords%20present%20in%20the%20site%20collection.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20this%20an%20issue%20with%20my%20tenant%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-905029%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Emanaged%20metadata%20column%20issue%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ETaxonomy%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Etaxonomy%20service%20issue%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-907954%22%20slang%3D%22en-US%22%3ERe%3A%20The%20required%20feature%20is%20not%20enabled%20for%20this%20column%20type%20error%20when%20creating%20taxonomy%20column%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-907954%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F365409%22%20target%3D%22_blank%22%3E%40mohandivraniya%3C%2FA%3E%26nbsp%3BHave%20you%20checked%20if%20your%20able%20to%20access%20term%20store%20manager%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-908314%22%20slang%3D%22en-US%22%3ERe%3A%20The%20required%20feature%20is%20not%20enabled%20for%20this%20column%20type%20error%20when%20creating%20taxonomy%20column%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-908314%22%20slang%3D%22en-US%22%3EYes%2C%20I%20was%20able%20to%20access%20term%20store%20manager.%3CBR%20%2F%3EThe%20behavior%20is%20very%20weird.%20Today%2C%20when%20i%20checked%20again%2C%20term%20store%20management%20link%20is%20now%20available%20and%20I%20am%20able%20to%20create%20managed%20metadata%20columns.%20I%20didn't%20provide%20any%20extra%20permission%20or%20enabled%20any%20settings%2Ffeatures.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-908337%22%20slang%3D%22en-US%22%3ERe%3A%20The%20required%20feature%20is%20not%20enabled%20for%20this%20column%20type%20error%20when%20creating%20taxonomy%20column%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-908337%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F365409%22%20target%3D%22_blank%22%3E%40mohandivraniya%3C%2FA%3E%26nbsp%3Bprobably%20service%20was%20down%20yesterday%20when%20you%20tried%2C%20you%20can%20ask%20your%20Tenant%20Admin%20to%20check%20more%20on%20this%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-911851%22%20slang%3D%22en-US%22%3ERe%3A%20The%20required%20feature%20is%20not%20enabled%20for%20this%20column%20type%20error%20when%20creating%20taxonomy%20column%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-911851%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F365409%22%20target%3D%22_blank%22%3E%40mohandivraniya%3C%2FA%3E%26nbsp%3BI%20have%20the%20same%20issue%20on%20newly%20created%20modern%20sites.%20On%20one%20tenant%20it%20works%2C%20on%20another%20-%20not.%20Also%20I%20can't%20add%20SharePoint%20add-in%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20905px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F137400i052BEDCA32E8D09D%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%222019-10-14%20(6).png%22%20title%3D%222019-10-14%20(6).png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
mohandivraniya
New Contributor

I am trying to create a new taxonomy (managed metadata) column in SharePoint online. However, I am facing below error when try to select term set for this column.

 

The required feature is not enabled for this column type. 

 

I have tried this on both team sites and communication sites. I also don't see any OOTB managed metadata columns such as Enterprise Keywords present in the site collection.

 

Is this an issue with my tenant? 

5 Replies

@mohandivraniya Have you checked if your able to access term store manager?

Yes, I was able to access term store manager.
The behavior is very weird. Today, when i checked again, term store management link is now available and I am able to create managed metadata columns. I didn't provide any extra permission or enabled any settings/features.

@mohandivraniya probably service was down yesterday when you tried, you can ask your Tenant Admin to check more on this

@mohandivraniya I have the same issue on newly created modern sites. On one tenant it works, on another - not. Also I can't add SharePoint add-in

2019-10-14 (6).png

 

 

I've also seen this issue today on a demo tenant that I've provisioned. Managed Metadata service is running and has terms available, but can't use the Managed Metadata column type in a document library